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Working with Frames

In this section...

“Frames” on page 1-3
“Frame Types” on page 1-3
“Frame Transforms” on page 1-4

“Frame Networks” on page 1-5

Frames form the foundation of multibody modeling. These constructs encode
the relative position and orientation of one rigid body with respect to another.
In SimMechanics™, every rigid body contains at least one frame.

]

.

Consider a double pendulum with two links. Each link has a set of physical
properties that affect its dynamic behavior and appearance—geometry,
inertia, and color. Yet, none of these properties contain information about the
spatial arrangement of the links. To position and orient one link with respect
to another, you need frames.



Working with Frames

You relate two rigid bodies in space by connecting two frames together. In
the double pendulum, you connect the end frame of one link to the end frame
of another link using a joint. In turn, each link contains a local reference
frame against which you define the two end frames. You can make two frames
coincident, translate them, or rotate them with respect to each other.

Frames

Frames have one origin and three axes. The origin defines the local zero
coordinate of the frame. This is the point with respect to which you measure
the translational distance between two frames. The axes define the directions
in which the components of a 3-D vector are resolved. For example, if you
measure the translation vector between two frame origins, you can resolve the
vector components along the axes of the base frame. For more information,
see “Measurement Frames” on page 4-47.

Frame Types

A multibody model generally contains two frame types: global and local. The
global frame represents the world. It is inertial and defines absolute rest in
a model. In SimMechanics, you represent the global frame with the World
Frame block. This block is available in the Frames and Transforms library.
The World frame is uniquely defined in every model. You can add multiple
World Frame blocks to a model, but they all represent the same frame.

A local frame represents a position and orientation in a rigid body. It can
move with respect to the World frame, but not with respect to the rigid body

1-3
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itself. Because it can move with respect to the World frame, a local frame is
generally non-inertial. To add a local frame to a rigid body, you use the Rigid
Transform block. You can add multiple local frames to a rigid body—to define
the position and orientation of joints, to apply an external force or torque,

or to sense motion. For more information, see “Frame Transformations” on
page 1-19.

Frame Transforms

To separate two frames in space, you apply a frame transformation between
them. In SimMechanics, two frame transformations are possible: rotation
and translation. Rotation changes the relative orientation of two frames.
Translation changes their relative position.

Translation Fotation

Rigid transformations fix spatial relationships for all time. When you rigidly
connect two frames, they move as a single unit. They cannot move with
respect to each other. In SimMechanics, you apply a rigid transformation
with the Rigid Transform block.

Note Frame transformations are important in multibody models. The Rigid
Transform block is among the most commonly used in SimMechanics.

You can also relate to frames with a time-varying transformation. In this
case, the rotation, translation, or both, can vary as a function of time. One
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example is the connection between two links in a double-pendulum. Two
frames, one on each link, connect with a joint that allows their spatial
relationship to vary with time.

To add a time-varying transformation, you use joint blocks. These blocks
allow frame transformations to vary with time. However, unlike the Rigid
Transform block, you cannot directly specify the time-dependence of the
frame transformation. This dependence follows directly from the dynamics
of the model.

Frame Networks

A single rigid body may have multiple frames. For example, a simple binary
link — a link with two joints — generally has one reference frame near the
geometry center and two frames at the joint locations. More complex rigid
bodies may have yet more frames. In fact, SimMechanics imposes no limit
on the number of frames a rigid body can have. You can add as many frames
as your application requires.

The set of frames that belong to a rigid body form a frame network. Like
other networks, it is often convenient to organize frames hierarchically. You
can, for example, organize the frames of a binary link such that its two joint
frames are defined with respect to the geometry center frame. In this simple
example, the frame network contains two hierarchical levels: a top level
containing the geometry center frame, and a lower level containing two joint
frames. More complex rigid bodies generally have more hierarchical levels.

1-5
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Concepts

The top hierarchical level contains the parent frame. Lower hierarchical
levels contain children frames. Children frames can in turn contain their own
children frames. All frames in a frame network depend, directly or indirectly,
on the parent frame. This is because the frame transformations used to define
the children frames ultimately reference the parent frame.

¢ “Frame Transformations” on page 1-19
e “Representing Frames” on page 1-7
e “Motion Sensing” on page 4-29



Representing Frames

Representing Frames

asntmy

In this section...

“Identity Relationships” on page 1-8

“Translation and Rotation” on page 1-9

“Interpreting a Frame Network” on page 1-10

You represent frames with frame ports, lines, and nodes. Each of these frame
entities represents one frame. You connect one frame entity to any other
using a connection line. When you do so, you apply a spatial relationship
between the two frames. Spatial relationships that you can specify include:

¢ Identity — Make two frames coincident with each other.

¢ Translation — Maintain an offset distance between two frame origins.

¢ Rotation — Maintain an angle between two frames.

The figure illustrates these spatial relationships. Letters B and F represent
the two frames between which you apply a spatial relationship.

Translation Raotation

e —
-

A frame port is any port with the frame icon E. A frame line is any connection
line that joins two frame ports. A frame node is the junction point between
two or more frame lines. You can connect one frame entity only to another
frame entity. Connecting frame ports, lines, or nodes to other types of ports,
lines, or nodes is invalid. For example, you cannot connect a frame port to a
physical signal port.

1-7
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Identity Relationships

To make two frames coincident in space, connect the corresponding frame
entities with a frame line. The frame line applies a rigid identity relationship
between the two frames. During simulation, the two frames can move only as
a single unit. They cannot move with respect to each other. The figure shows
three ways to make two frames coincident.

Connect Two Frame Ports Connect Two Frame Lines

\ \
| |
[Solid Sokd!

Connect Two Frame Nodes

Alternatively, use the Weld Joint block to make two frames coincident. By
connecting two frame entities to the base and follower frame ports of this
block, you make them coincident for all time. Use the Weld Joint block to
rigidly connect two frames that belong to different rigid bodies. In the figure,
a Weld Joint block makes two solid reference frames coincident in space.
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Connect Frames with Weld Joint Block

43}

Waid Joint

- Y}

Note If you apply an identity relationship with the Weld Joint block, check
that a Solid or Inertia block rigidly connects to the joint frames. Failure to do
so results in a degenerate mass error during simulation.

Translation and Rotation

To separate two frames in space you use the Rigid Transform block. By
connecting two frame entities to the base and follower frame ports of this
block, you apply the rigid transformation that the block specifies. Rigid
transformations include translation and rotation.

You can apply an offset distance between two frame origins, a rotation angle
between the frame axes, or both. Two frames that you connect using a Rigid
Transform block behave as a single entity. If you specify neither translation
or rotation, the Rigid Transform block represents the identity relationship.
The two frames become coincident in space. In the figure, a Rigid Transform
block applies a rigid transformation between two solid reference frames.

Connect Frames with Rigid Transform Block

Figid Trara form

s.m -
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Interpreting a Frame Network

As an example, consider the frame network of a binary link. SimMechanics
provides a model of this rigid body. To open it, at the MATLAB® command
line enter sm_compound_body. Double-click subsystem Compound Body to
view the underlying block diagram. The figure shows this block diagram.

M ain ﬂ
Link
¥
[] L_'l []
(T» 0 = = FRO = o2)

Hole Frame ba e Peg Frame
End Cap Peg

Transform i Transform
' End Cap )_ 'I ;aaf:-lr:nce Peg '

To represent the binary link, the Compound Body subsystem contains three
solids. These represent the main, peg, and hole sections. Three frames provide
the position and orientation of the three solids according to the guidelines
that section “Identity Relationships” on page 1-8 introduces. Each group of
frame ports, lines, and nodes that directly connect to each other represents
one frame. The figure shows the three frames in the block diagram.
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Hole Frame Reference Frame Peg Frame

Two Rigid Transform blocks represent the spatial relationships between
the three frames. One block translates the hole frame with respect to the
reference frame along the common -X axis. The other block translates the
peg frame with respect to the reference frame along the common +X axis.
The figure shows these two blocks.
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PN ! " o S
L
Translate Translate
Along -X Along +X
Related ¢ “Represent Box Frame Tree” on page 1-41
Exqmples ¢ “Represent Binary Link Frame Tree” on page 1-36

Concepts “Working with Frames” on page 1-2
“Frame Transformations” on page 1-19
“World and Reference Frames” on page 1-13

“Find and Fix Frame Issues” on page 1-63
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World and Reference Frames

In this section...

“World Frame” on page 1-13

“Reference Frame” on page 1-16

Two preset frames are available in SimMechanics: World and Reference.
These are standalone frames with respect to which you can define other
frames in a model. New frames can in turn serve as the basis to define yet
other frames. However, directly or indirectly, all frames depend on either
World or Reference frames. Both frames are available as blocks in the Frames
and Transforms library.

o f [ [] g
Ref
)_ F‘E:EHDE =1 /{: [ B ",J‘\‘.E P World Frame
A s = P ¥ L
Rigid Transform
Transform Sensor

Frames and Transforms. Library

World Frame

The World frame represents the external environment of a mechanical system.
It is always at absolute rest, and therefore experiences zero acceleration. As
a consequence, centripetal and other pseudo-forces are not present in the
world frame, and it is said to be inertial. Rigidly connecting any frame to the
World frame makes that frame also inertial. To add the World frame to a
model, use the World Frame block.

1 E

b
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The World frame is the ultimate reference frame. Its position and orientation
are predefined and do not depend on any other frame. This property makes
the World frame invaluable. You can always apply a transform to the World
frame and obtain a new frame. Applying a transform to the resulting frame in
turn yields more new frames, all indirectly related to the World frame. The
result is a frame tree with the World frame at the root. The figure shows such
a frame tree for a double-pendulum system.

Warld
I-."‘-'I —
Frame
Jaint
Reference
C Binary
/n f ! Link
Hole Peqg
.'r-
!
o Jaint
Iy
~ Reference
X, - _
S , Binary
' ! Link
Hole Peg

The double-pendulum block diagram is based on this frame tree. The World
Frame block identifies the root of the frame tree. A Revolute Joint block
applies the variable transform that relates the World frame to the binary link
peg frame. A second Revolute Joint block applies a similar variable transform
between the hole and peg frames of adjoining binary links. The figure shows
this block diagram.
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The World frame is present in every model. However, the World Frame block
1s strictly optional. If you do not add this block to a model, SimMechanics
assigns one of the existing frames as the World frame. This implicit World
frame connects to the rest of the model via an implicit 6-DOF joint, which in
the absence of counteracting forces allows a machine to fall under gravity.

You can connect multiple World Frame blocks to a model. However, all World
Frame blocks represent the same frame. In this sense, the World frame is
unique. You can add multiple World Frame blocks to simplify modeling tasks,
e.g., sensing motion with respect to the World frame. The figure shows the
model of a double-pendulum with two World Frame blocks. Both World
Frame blocks represent the same frame.
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Reference Frame

The Reference frame represents the root of a rigid body or multibody
subsystem. Within a subsystem, it denotes the frame against which all
remaining frames are defined. To add a Reference frame, use the Reference
Frame block. Use this block to mark the top level of a subsystem frame tree.

) -

[

Applying a transform to the Reference frame yields other frames. Applying
transforms to these other frames yields still more frames. The overall

set of frames forms a frame tree with the Reference frame at the root.

The figure shows such a frame tree for one of the binary links used in the
double-pendulum system.
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The block diagram of the binary link subsystem is based on this frame tree.
The following figure shows the binary link block diagram. The Reference
Frame block identifies the root of the frame tree. Rigid Transform block
to_hole adds the hole frame. Rigid Transform block to_peg adds the peg
frame. It is a simple task to add the main, peg, and hole solids once these
frames are defined.
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The distinguishing feature of the Reference frame is that it can move with
respect to other frames. Depending on the dynamics of a model, a Reference
frame can accelerate, giving rise to pseudo-forces that render this frame
non-inertial. Rigidly connecting any frame to a non-inertial Reference frame
makes that frame also non-inertial.

The Reference frame is present in every subsystem. However, the Reference
Frame block is strictly optional. If you do not add this block to a subsystem,
SimMechanics assigns one of the existing frames as the Reference frame.

¢ “Working with Frames” on page 1-2
¢ “Frame Transformations” on page 1-19
e “Representing Frames” on page 1-7
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Frame Transformations

In this section...

“Rigid and Time-Varying Transformations” on page 1-19
“Rigid Transformation Example” on page 1-22

“Reversing Rigid Transformations” on page 1-25

To place a solid in space, with a given position and orientation, you use
frames. By connecting the solid reference frame to another frame, you resolve
its position and orientation within the model. For example, connecting the
solid reference frame directly to the World frame causes their origins and
axes to coincide. However, if the model does not yet contain the desired frame,
you must first add it.

Adding a frame is the act of defining its position and orientation. Because
these properties are relative, you must always define a frame with respect to
another frame. Every model starts with one of two frame blocks you can use
as reference: World Frame or Reference Frame. As a model grows, so does the
number of frames that you can use as a reference.

Rigid and Time-Varying Transformations

The spatial relationship between the two frames, the existing and the new,
is called a frame transformation. When the transformation is fixed for all
time, it is rigid. Two frames related by a rigid transformation can move with
respect to the world, but never with respect to each other. In SimMechanics,
you add a new frame by applying a rigid transformation to an existing frame.
The block you use for this task is the Rigid Transform block.
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Frame Transfarmation

Frame transformations can also vary with time. In this case, the two frames
that the transformation applies to can move with respect to each other. In
SimMechanics, joint blocks provide the degrees of freedom that allow motion
between two frames. Depending on the joint block, frames can move along
or about an axis. For example, the Revolute Joint block allows two frames
to rotate with respect to each other about a common +Z axis. Likewise, the
Prismatic Joint block allows two frames to rotate with respect to each other
along a common +Z axis. For more information about joints, see “Joints”

on page 3-2.



Frame Transformations

You can apply two rigid transformations: rotation and translation. Rotation
changes the orientation of the follower frame with respect to the base
frame. Translation changes the position of the follower frame with respect
to the base frame. A third, implicit, transformation is available: identity.
This transformation is marked by the absence of both frame rotation and
translation, making base and follower frames coincident in space.
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ranslation Raotation

Every rigid transformation involves two frames: a base and a follower. The
base frame is a reference, the starting point against which you define the
new frame. Any frame can act as the base frame. When you apply a rigid
transformation, you do so directly to the base frame. The follower frame

is the new frame — the transformed version of the base frame. The Rigid
Transform block identifies base and follower frames with frame ports B and
F, respectively.

Rigid Transformation Example

As an example, consider a binary link. You can model this rigid body with
three elementary solids: main body, peg, and hole sections. This type of rigid
body is known as compound. Each solid has a local reference frame, which
is fixed with respect to the solid, but which can move with respect to the
world. The figure shows the binary link compound rigid body and the three
solids that comprise it.
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When modeling the binary link, the goal is to place the peg at one end of the
link, and the hole section at the other end. The proper approach is to apply

a rigid transformation between the main peg and peg reference frames, and
main body and hole section reference frames. The transformations specify the
separation distance and rotation angle, if any, between each pair of frames.
Because the transformations are rigid, they constrain the solids to move as a
single unit — a rigid body. The rigidly connected solids can move together
with respect to the World frame, but never with respect to each other.

The figure shows the set of transformations used to model the binary link.
These include translation, rotation, and identity. No Rigid Transform block
is required to apply an identity transformation. See “Representing Frames”
on page 1-7.
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The block diagram, shown in the following figure, reflects the structure of
the binary link. Three Solid blocks represent the main body, peg, and hole
sections. Their R ports identify the respective reference frames. Two Rigid
Transform blocks, named to_hole and to_peg apply the rigid transformations
that relate the solid pairs main—hole and main—peg.
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Reversing Rigid Transformations

Rigid transformations describe the operation that takes the base frame into
coincidence with the follower frame. In this sense, the transformation acts
on the base frame. Switching base and follower port frames causes the
transformation to act on a different frame, changing the relationship between
the two frames. The result is a follower frame with different position and
orientation and, as a consequence, a different rigid body subsystem.

Consider the binary link system. In the original configuration, rigid
transformations translate the peg to the right of the main body and the hole
to the left. To accomplish this, the main body frame connects to the base
port frame of the corresponding Rigid Transform blocks, while the hole and
peg frames connect to the follower port frames. When you switch base and
follower frame ports, the transformations instead translate the main body to
the right of the peg and to the left of the hole.
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While in the first case the peg translated to the right of the main body, in the
second case the peg translated to the left. The same principle applies to the
hole. The figure shows the effect of switching base and follower frames in both
Rigid Transform blocks of the binary link block diagram.



Frame Transformations

Concepts

“Rotation Methods” on page 1-28

“Translation Methods” on page 1-32

“Frame Transformations” on page 1-19
“Represent Binary Link Frame Tree” on page 1-36
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Rotation Methods

1-28

In this section...

“Specifying Rotation” on page 1-28
“Aligned Axes” on page 1-28
“Standard Axis” on page 1-29

“Arbitrary Axis” on page 1-30

You can specify frame rotation using different methods. These include aligned
axes, standard axis, and arbitrary axis. The different methods are available
through the Rigid Transform block. The choice of method depends on the
model. Select the method that is most convenient for the application.

Specifying Rotation

Rotation is a relative quantity. The rotation of one frame is meaningful only
with respect to another frame. As such, the Rigid Transform block requires
two frames to specify a transformation: base and follower. The transformation
operates on the base frame. For example, a translation along the +Z axis
places the follower frame along the +Z axis from the base frame. Reversing
frame ports is allowed, but the transformation is reversed: the base frame is
now placed along the +Z axis from the follower frame.

Aligned Axes

Rotate two frames with respect to each other by aligning any two axes of one
with any two axes of the other. The figure illustrates the aligned axes method.



Rotation Methods

Aligned Axis Rotation

Step 1 - Align axis pair 1.
Follower = +X
Base = +Y

Slep 2 - Align axis pair 2
Fallower = +Y
Base =+Z

Standard Axis

Rotate frames with respect to each other about one of the three base frame
axes: X, Y, or Z.
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Stancard Axis Rotation
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Arbitrary Axis

Rotate two frames with respect to each other about an arbitrary axis resolved
in the base frame.
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Concepts

Arbitrary Axis Rotation
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x ¥

Rotation B About Axis with Compenents [ax ay az)
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“Translation Methods” on page 1-32

“Rotational Measurements” on page 4-34
“Translational Measurements” on page 4-39
“Represent Binary Link Frame Tree” on page 1-36
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Translation Methods

1-32

In this section...

“Specifying Translation” on page 1-32
“Cartesian” on page 1-32

“Standard Axis” on page 1-33

“Cylindrical” on page 1-34

You can specify frame translation using different methods. These include
Cartesian, standard axis, and cylindrical. The different methods are available
through the Rigid Transform block. The choice of method depends on the
model. Select the method that is most convenient for the application.

Specifying Translation

Translation is a relative quantity. The translation of one frame is meaningful
only with respect to another frame. As such, the Rigid Transform block
requires two frames to specify a translation: base and follower. The
transformation operates on the base frame. For example, a translation along
the +Z axis places the follower frame along the +Z axis from the base frame.
Reversing frame ports is allowed, but the transformation is reversed: the base
frame is now placed along the +Z axis from the follower frame.

Cartesian

Translate follower frame along arbitrary Cartesian vector resolved in the
base frame.



Translation Methods

Carlesian Translation

i

Translation Along Cartesian X, Y, and Z Axes

4

Standard Axis

Translate follower frame along one of the three axes of the base frame.
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Standard Axis Translation

Translation Along Base X Axis
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Cylindrical

Translate follower frame along cylindrical axes resolved in the base frame.

1-34



Translation Methods

Cylingrical Translation

Translation Along Base Z, R, and §) Axes

4

'}

Concepts ® “Translational Measurements” on page 4-39
e “Rotation Methods” on page 1-28
¢ “Rotational Measurements” on page 4-34
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Represent Binary Link Frame Tree

1-36

In this section...

“Model Overview” on page 1-36

“Build Model” on page 1-37

“Generate Binary Link Subsystem” on page 1-38
“Visualize Model” on page 1-39

“Open Reference Model” on page 1-40

Model Overview

In this example, you model the frame tree of a binary link. This tree contains
three frames to which you later connect solid elements. You specify these
frames using the Rigid Transform block.

ik

&

You can promote subsystem reusability by parameterizing link dimensions
in terms of MATLAB variables. In this example, you initialize the variables
in a subsystem mask. You can then specify their numerical values in the
subsystem dialog box. Refer to the table for the dimensions needed to model
the binary link frame tree.



Represent Binary Link Frame Tree

Dimension MATLAB Variable
Length L
Width W
Thickness T

Build Model

1 Drag these blocks into a new model.

Block Quantity Library

Reference Frame 1 Frames and
Transforms

Rigid Transform 2 Frames and
Transforms

Solver Configuration 1 Simscape™ Utilities

2 Connect and name the blocks as shown in the figure.

Note Pay close attention to Rigid Transform port orientation. Both base
(B) port frames should connect to the Reference Frame port. This ensures
the rigid transform applies fo the Reference frame, and not the end frames.

Sohver

Configuration Rigid Transform Rigid Transform
.-"'z ._.-'z
flx)=10 D; - ‘E‘E m B - n';.
W A

3 In the Rigid Transform block dialog box, specify these parameters.
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Parameter Setting

Translation > Method Select Standard Axis.
Translation > Axis Select -X.

Translation > Offset Enter L/2. Select units of cm.

4 In the Rigid Transform1 block dialog box, specify these parameters.

Parameter Setting

Translation > Method Select Cartesian.

Translation > Offset Enter [L/2 0 3/2*T]. Select units
of cm.

Generate Binary Link Subsystem

To initialize the MATLAB dimension variables used to specify the frame
transforms, convert the binary link block diagram into a subsystem and use
the subsystem mask:

1 Select all the blocks excluding Solver Configuration.

2 Generate a new subsystem, e.g., by pressing Ctrl+G.

=0 T+ FE

Soher
‘Configuration

binary_lirk

3 Select the Subsystem block and press Ctrl+M to create a subsystem mask.

4 In the Parameters & Dialog tab, add three text boxes to the Parameters
folder and click OK.
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Prompt Name
Length L
Width W
Thickness T

5 In the subsystem dialog box, specify these parameters.

Parameter Value
Length 30
Width 2
Thickness 0.8

Visualize Model

Update the block diagram. You can do this in the Simulink® Editor menu
bar, by selecting Simulation > Update Diagram. Then, in the Mechanics
Explorer menu bar, select View > Show Frames. The visualization pane
shows the binary link frame tree.
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Open Reference Model

To see a completed version of the frame tree model, at the MATLAB command
prompt enter smdoc_binary_linke_frames.

Related e “Model Binary Link” on page 2-53
Examples
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Represent Box Frame Tree

In this section...

“Model Overview” on page 1-41

“Start Model” on page 1-43

“Initialize Model Workspace Parameters” on page 1-44
“Add Bottom Plane Frames” on page 1-46

“Add Top Plane Frames” on page 1-49

“Add Arch Frames” on page 1-53

“Save Model” on page 1-57

Model Overview

In SimMechanics, you can rigidly connect multiple Solid blocks to represent
a complex rigid body. To position and orient different solids with respect to
each other, you create a frame network that you can connect the solids to.
The frame network contains Rigid Transform blocks that specify the spatial
relationships between the different frames. In this example, you represent
the frame tree for a box shape.
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The example highlights the Rigid Transform block as the basic tool that you
use to specify spatial relationships between frames and the solids that connect
to them. The complete frame network is complex. It highlights nearly every
type of rigid transformation that you can apply between two frames.

The modeling process in this example contains four stages:
1 Add World Frame (W).

This is the ultimate reference frame against which you define all other
frames.

2 Add the frames of the box bottom plane (frames A-D in the figure).
You define these frames directly with respect to the World frame.
3 Add the frames of the box top plane (frames E-I in the figure).

You define these frames directly with respect to the box bottom plane
frames.



Represent Box Frame Tree

4 Add the frames of the box arch (frames K and J in the figure).

You define these frames directly with respect to the center frame of the
box top plane.

This example is based on model sm_frame_tree, which accompanies your
SimMechanics installation. To open this model, at the MATLAB command
line, enter sm_frame_tree.

Start Model

Start a new model. Then, add a global reference frame that you can use to
define other frames.

Use the World Frame block to represent the World frame:
1 Start a new model.

2 Drag the following blocks into the model.

Library Block Quantity
Frames and World Frame 1
Transforms

Simscape Utilities Solver Configuration 1

3 Connect the blocks as they appear in the figure.
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Initialize Model Workspace Parameters

To specify the distance offsets between frames, you use Rigid Transform
blocks. In this example, you specify the distance offsets in terms of MATLAB
variables that you initialize in the model workspace. The table lists these

variables.
Dimension Variable
Length L
Width w
Height H
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To initialize the MATLAB variables:

1 On the Simulink menu bar, click Tools > Model Explorer.

2 On the Model Hierarchy pane, double-click the name of your model (e.g.
frame_tree).

3 Click Model Workspace.

4 On the Model Workspace pane, in the Data Source drop-down list,
select MATLAB Code.

5 In the MATLAB Code section that appears, enter the following code:

% Size of Cube
L =12;
W = 10;
H = 8;
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1-46

6 Click Reinitialize from Source.

Add Bottom Plane Frames

The World frame is the ultimate reference frame in a model. Now that you
added the World frame to your model, you can define other frames with
respect to it. You do this using the Rigid Transform block.

c

To define the four corner frames of the bottom box plane:

1 From the Frames and Transforms library, drag four Rigid Transform
blocks to the model.

2 Connect and name the blocks as they appear in the figure.
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Vertex W-A
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Vertex W-C
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Vertex W-D
Transform

3 Double-click the Vertex W-A Transform block and, in the dialog box, specify

the parameters that the table provides.

Parameter Section Parameter Value
Rotation Method Select Standard Axis
Axis Select +Z
Angle Enter 90 (deg)
Translation Method Select Cartesian
Offset Enter [L/2 W/2 0]
(cm)
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4 Double-click the Vertex W-B Transform block and, in the dialog box, specify
the parameters that the table provides.

Parameter Section Parameter Value
Rotation Method Select Aligned Axis
Pair Select +X/-X
1 > Follower/Base
Pair Select +Y/-Y
2 > Follower/Base
Translation Method Select Cartesian

Offset

Enter [-L/2 W/2 0]
(cm)

5 Double-click the Vertex W-C Transform block and, in the dialog box, specify
the parameters that the table provides.

Parameter Section Parameter Value

Rotation Method Select Standard Axis
Axis Select +Z
Angle Enter 270 (deg)

Translation Method Select Cartesian
Offset Enter [-L/2 -W/2 0]

(cm)

6 Double-click the Vertex W-D Transform block and, in the dialog box, specify
the parameters that the table provides.

Parameter Section Parameter Value

Rotation Method Select None

Translation Method Select Cartesian
Offset Enter [L/2 -W/2 0]

(cm)
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&, s create_frame_tree 1

To visualize the frames that you just added, on the Simulink menu bar, select
Simulation > Update Diagram. Mechanics Explorer opens with a static
3-D display of your model. To view the position and orientation of each frame,
in the Mechanics Explorer menu bar, select View > Show Frames.

;)7; World_Frame

---,_'.p Vertex_W_A_Transform

i -",_f.” Vertex W_B_Transform
-",_f.” Vertex W_C_Transform

: ---,_'.” Vertex W_D_Transform

B)-Connection Frames

s

s

s

4
4

.

=
k.
ai

Add Top Plane Frames

You can now define the top plane frames with respect to the bottom plane
frames.
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To add the top plane frames:

1 From the Frames and Transforms library, drag five Rigid Transform blocks.

2 Connect and name the blocks as they appear in the figure.
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3 Double-click the following blocks:

e Vertex A-E Transform

e Vertex B-F Transform

e Vertex C-G Transform

e Vertex D-H Transform

4 In each block dialog box, specify the following parameters.
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Parameter Section Parameter Value
Rotation Method Select None
Translation Method Select Standard Axis
Axis +Z
Offset Enter H (cm)

5 Double-click the Vertex W-I Transform block and, in the dialog box, specify

the following parameters.

Parameter Section Parameter Value

Rotation Method Select Aligned Axes
Pair Select +Y/-Z
1 > Follower/Base
Pair Select +Z/+Y
2 > Follower/Base

Translation Method Select Standard Axis
Axis +Z
Offset Enter H (cm)

To visualize the frames that you just added, on the Simulink menu bar, select
Simulation > Update Diagram. Mechanics Explorer updates the 3-D view

of the box frame tree.
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Add Arch Frames

Finally, add the two arch frames. As before, use the Rigid Transform block to
define these frames. Define them with respect to the center frame of the top
plane (frame I).
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To define the arch frames:

1 From the Frames and Transforms library, drag two Rigid Transform blocks.

2 Connect and name the blocks as they appear in the figure.

1-54



Represent Box Frame Tree

Wertex W-A Vertex A-E
Transform Transform
f Frame A i
5 ./.H:E 5 "'f‘iEI
= =
Vertex W-B Vertex B-F
Transform Transform
f Frame B [
5 '”{*.D 5 'f"‘iEI
= =
[l
5 "f“.EI
: =
f Frame |
A= wD 4 Wertex |-J
- 5 .D Transform
=
‘World Frame Vertex W-I \-E ,r“:s
Transform § ~/RE
J=
Vertex |I-K
Transform
[] Frame C ]
foxp=0 g “7X[3 g “7k[D
J= J=
_ Sabver Vertex W-C Veertex C-G
Configuraticn Transform Transform
f Frame D [l
5 KD 5 X[
J= J=
Vertex W-D Vertex D-H
Transform Transform

3 Double-click the Vertex I-J Transform block and, in the dialog box, specify

the parameters that the table provides.

Parameter Section Parameter Value

Rotation Method Select Standard Axis
Axis Select +Z
Angle Enter -90 (deg)
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Parameter Section Parameter Value
Translation Method Select Cylindrical
Radius Enter L/2 (cm)
Theta Enter -90 (deg)
Z Offset Enter W/2 (cm)

4 Double-click the Vertex I-K Transform block and, in the dialog box, specify

the parameters that the table provides.

Parameter Section Parameter Value
Rotation Method Select Standard Axis
Axis Select +Z
Angle Enter -90 (deg)
Translation Method Select Cylindrical
Radius Enter L/2 (cm)
Theta Enter -90 (deg)
Z Offset Enter -W/2 (cm)

To visualize the frames that you just added, on the Simulink menu bar, select
Simulation > Update Diagram. Mechanics Explorer opens with a static
3-D display of your model. To view the position and orientation of each frame,

on the Mechanics Explorer tool bar, check that the frame visibility icon

is toggled on.



Represent Box Frame Tree

}_; create_frame_tree
2 World_Frame
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Related
Examples

Concepts

Save Model

Save the model as frame_tree in a convenient folder. In a subsequent
example, you use Graphic blocks to represent each frame with a graphic icon.
See “Visualize Box Frame Tree” on page 1-58

® “Visualize Box Frame Tree” on page 1-58

e “Represent Binary Link Frame Tree” on page 1-36
® “Representing Frames” on page 1-7

¢ “Frame Transformations” on page 1-19

¢ “World and Reference Frames” on page 1-13

[ ]

“Translation Methods” on page 1-32
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Visualize Box Frame Tree

In this section...

“Model Overview” on page 1-58
“Build Model” on page 1-59

“Visualize Model” on page 1-61

Model Overview

To visualize a frame or frame network, you can use the Graphic block. By
connecting this block to a frame, you add a graphic icon to that frame. The
graphic icon has zero inertia and it does not affect model dynamics during
simulation. In this example, you use Graphic blocks to add graphic icons to
the box frame tree that you modeled in a previous example. See “Represent
Box Frame Tree” on page 1-41.
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Build Model

To add a graphic icon to each frame in your model:
1 Open model frame_tree.

This is the model that you created in example “Represent Box Frame
Tree” on page 1-41.

2 From the Body Elements library, drag 12 Graphic blocks to that model.

3 Connect and name the blocks as they appear in the figure.
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4 Double-click each Graphic block.

5 In the dialog box, specify parameters according to the following table.
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Graphic Block
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Visualize Model

You can now visualize your model in Mechanics Explorer. To do this, on the
Simulink menu bar, select Simulation > Update Diagram. Mechanics
Explorer opens with a static 3-D display of your model. Rotate, pan, and

zoom to explore.
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Related ® “Represent Box Frame Tree” on page 1-41
Exqmples “Represent Binary Link Frame Tree” on page 1-36

Concepts “Representing Frames” on page 1-7
“Frame Transformations” on page 1-19
“Rotation Methods” on page 1-28

“Translation Methods” on page 1-32
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Find and Fix Frame Issues

In this section...

“Rigidity Loops” on page 1-63
“Shorted Rigid Transform Blocks” on page 1-64

If your model contains an invalid frame connection, SimMechanics issues an
error and the model does not simulate. Possible error sources include:

¢ Rigidity loops — Rigidly connecting multiple frames in a closed loop

¢ Shorted Rigid Transform Blocks — Rigidly connecting base and follower

frame ports of a Rigid Transform block

Rigidity Loops

A rigidity loop is a closed loop of Rigid Transform blocks. The loop contains
one redundant Rigid Transform block that over-constrains the subsystem. If
a rigidity loop is present, SimMechanics issues an error and the model does

not simulate.

To remove the simulation error, disconnect one Rigid Transform block. This

step removes the redundant constraint, and allows the model to simulate. The
following figure shows a rigidity loop. The loop contains four Rigid Transform
blocks directly connected to each other.
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Shorted Rigid Transform Blocks

A shorted Rigid Transform block contains a direct connection line between
base (B) and follower frames (F). The connection line makes the two port
frames coincident in space. However, the Rigid Transform block enforces a
spatial transformation that translates or rotates one port frame relative to
the other. The result is a conflict in the frame definition.

If a shorted Rigid Transform block is present, SimMechanics issues an
error and the model does not simulate. The error remains even if the Rigid
Transform block specifies no rotation and no translation. To remove the
simulation error, delete the direct connection line between base and follower
frame ports of the Rigid Transform block. The following figure shows a
shorted Rigid Transform block.

Related e “Represent Box Frame Tree” on page 1-41
Exqmples ¢ “Represent Binary Link Frame Tree” on page 1-36

“Representing Frames” on page 1-7
“Frame Transformations” on page 1-19
“Rotation Methods” on page 1-28
“Translation Methods” on page 1-32

Concepts
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® “Solid Geometry” on page 2-2

e “Advanced Solid Shapes” on page 2-6

¢ “Revolution and General Extrusion Cross-Sections” on page 2-9
® “Cross-Section Coordinates” on page 2-12

® “Specifying Solid Inertia” on page 2-18

¢ “Inertia Tensor” on page 2-24

e “Solid Color” on page 2-26

e “Model Cone” on page 2-32

e “Model Dome” on page 2-37

¢ “Model I-Beam” on page 2-42

¢ “Model Box Beam” on page 2-47

¢ “Model Binary Link” on page 2-53

¢ “Model Two-Hole Binary Link” on page 2-61
¢ “Model Pivot Mount” on page 2-67



2 Rigid Bodies

Solid Geometry

In this section...

“Simple Shapes” on page 2-2
“Advanced Shapes” on page 2-4

SimMechanics provides a set of shapes that you can use to represent rigid
bodies. You can specify the shapes directly in the Solid block dialog box.

[ Solid : Solid ===

Description

Represents a solid combining a geometry, an inertia and mass,
and a graphics component into a single unit. A solid is the common
building block of rigid bodies. The Solid block obtains the inertia
from the geometry and density, from the geometry and mass, or
from an inertia tensor that you specify.

In the expandible nodes under Properties, select the types of
geometry, inertia, and graphic features that you want and their
parameterizations.

Port R is a frame port that represents a reference frame
assocated with the geometry.

Properties
General Bxtrusion hd
Cross-section Cylinder
Length Sphere

& Inertia Brick

& Graphic Ellipsoid
Regular Extrusion

General Extrusion

Revalution
From File

Simple Shapes

Shapes range from simple to advanced. Simple shapes require a small number
of dimensional parameters. The following simple shapes are available.




Solid Geometry

e Cylinder — Cylinder with custom dimensions, centroid at the solid
reference frame origin, and symmetry axis along the solid reference frame
Z-axis.

® Sphere — Sphere with custom dimensions and center located at the solid
reference frame origin.

® Brick — Brick with custom dimensions along the three Cartesian axes and
centroid located at the block reference frame.

® Ellipsoid — Ellipsoid with custom dimensions with centroid located at
the block reference frame.

® Regular Extrusion — Extruded solid with constant cross-section along
the z-axis and centroid located at the block reference frame. The constant
cross-section 1s a regular polygon with a custom number of sides.

Simple shapes are easier to use than advanced shapes. When modeling a
rigid body, consider using a simple shape as a first approximation. After
successful model assembly, you can add detail to the rigid body. The following
figure shows the four simple shapes, ordered left to right: cylinder, Sphere,
Brick, and E11ipsoid.

806~

The Regular Extrusion shape is more versatile than other simple shapes.
With this shape, you can model solids with constant cross sections.
Cross-sections can have any number of sides, but all lengths and internal
angles are equal.

The following figure shows a set of shapes you can model with the Regular
Extrusion shape.
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Advanced Shapes

Advanced shapes include:

® General Extrusion — Extruded solid with custom cross-section swept
along the z-axis and centroid located at the block reference frame.

® Revolution — Solid of revolution with constant cross-section revolved

about the z-axis and centroid located at the block reference frame.

The shapes require a MATLAB cross-section matrix. To be valid, the matrix
must observe a set of rules. See “Cross-Section Coordinates” on page 2-12.

General Extrusions

For extrusions with irregular cross-section, SimMechanics provides a
General Extrusion geometry. This geometry is among the most versatile
in SimMechanics. You can use it to model shapes with an increased level
of detail.

This shape requires a MATLAB matrix that contains the cross-section
coordinates. The matrix must follow a set of rules that are specific to the

shape. See “Revolution and General Extrusion Cross-Sections” on page 2-9.

The following figure shows some shapes you can model with General
Extrusion.

QVIN

For General Extrusion examples, see:

* “Model I-Beam” on page 2-42
e “Model Box Beam” on page 2-47



Solid Geometry

Concepts

Solids of Revolution

Solids that have a constant cross-section about an axis are solids of revolution.
To model these solids, use the Revolution shape.

The Revolution shape requires a MATLAB matrix that contains the
cross-section coordinates. The matrix must follow a set of rules specific
to the Revolution geometry. See “Revolution and General Extrusion
Cross-Sections” on page 2-9.

The following figure shows some shapes you can model with Revolution.

e “Advanced Solid Shapes” on page 2-6

e “Revolution and General Extrusion Cross-Sections” on page 2-9
® “Specifying Solid Inertia” on page 2-18

e “Solid Color” on page 2-26
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Advanced Solid Shapes

2-6

In this section...

“When to Use Extrusion and Revolution Shapes” on page 2-6

“Specifying Extrusion and Revolution Shapes” on page 2-7

With the Solid block, you can specify the geometry of a solid. This block
provides a set of standard shapes so that you can easily specify simple shapes,
e.g., Cylinder. For more complex shapes, the block provides two shapes:
General Extrusion and Revolution.

When to Use Extrusion and Revolution Shapes

Use General Extrusion and Revolution shapes to represent solids that are

to complex for standard shapes. The choice of shape depends on the symmetry
of the solid. If the solid has translational symmetry, use General Extrusion.
If the solid has rotational symmetry, use Revolution.

The solid has translational symmetry if its cross-section is constant along its
length axis. The solid has rotational symmetry if its cross-section is constant
about its length axis. The figure shows two solids that you can represent
using Revolution and General Extrusion shapes.




Advanced Solid Shapes

Both solids are too complex for standard shapes like Cylinder, Brick, or
Sphere. The solid on the left possesses a constant cross-section about its
length axis. You can represent it using shape Revolution. The solid on
the right possesses a constant cross-section along its length axis. You can
represent it using shape General Extrusion.

Specifying Extrusion and Revolution Shapes

To specify General Extrusion and Revolution shapes, you must provide
the cross-section coordinates. Enter these coordinates as a matrix in the
Geometry > Cross-Section parameter of the Solid block dialog box.
SimMechanics connects the coordinate pairs with straight lines to generate
the cross-section shape.

Note To see the Cross-Section parameter, you must first select General
Extrusion or Revolution from the Geometry > Shape drop-down list.

The figure shows the cross-sections that you must specify to represent the
extrusion and solid of revolution introduced in this section. The coordinate
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matrices for these cross-sections must follow a set of rules to be valid as input.
For more information, see “Cross-Section Coordinates” on page 2-12.

Solid Extrusion Extrusion Cross-Section

A

Zolid Revalution Revolution Cross-Section

Axis of Revolution

Offset ‘

Use the Length parameter of the General Extrusion shape to specify
the length to extrude the cross-section along. Use the Revolution Angle
parameter of the Revolution shape to specify the angle to sweep the
cross-section about.

Note To see the Revolution Angle parameter, you must first select Custom
from the Geometry > Extent of Revolution drop-down list.

Related ¢ “Model Box Beam” on page 2-47
Exqmples * “Model Dome” on page 2-37
Concepts e “Cross-Section Coordinates” on page 2-12

“Revolution and General Extrusion Cross-Sections” on page 2-9



Revolution and General Extrusion Cross-Sections

Revolution and General Extrusion Cross-Sections

In this section...

“Revolution Coordinates are [x z] Pairs” on page 2-9
“Revolution Axis Aligns with Z-Axis” on page 2-9
“Revolution X-Coordinates Must Equal or Exceed Zero” on page 2-10

“Extrusion Coordinates are [x y] Pairs” on page 2-10

“Extrusion Axis Aligns with Z-Axis” on page 2-11

SimMechanics interprets the coordinate matrices of Revolution and General
Extrusion according to a set of rules. These rules ensure consistency across
all Revolution and General Extrusion shapes.

Revolution Coordinates are [x z] Pairs

SimMechanics maps the cross-section that you specify onto the XZ plane
of the solid reference frame. When you enter the coordinate matrix in the
Cross-Section parameter of the Solid block, SimMechanics treats those
coordinates as [X Z] pairs, in that order.

Axis of Revelution

& X Axs

& 7 Axis

o

Revolution Axis Aligns with Z-Axis

SimMechanics revolves the cross-section that you specify about the Z axis
of the solid reference frame. The revolution axis runs along the thickness
of the revolution.
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Extrusion § Axis

Revolution X-Coordinates Must Equal or Exceed Zero

The X coordinates of a revolution cross-section must be equal to or greater
than zero. Negative X coordinates causes the cross-section to overlap during
revolution. If you specify a cross-section with negative X coordinates,
SimMechanics issues an error and the model does not simulate.

Extrusion Coordinates are [x y] Pairs

SimMechanics maps the cross-section that you specify onto the XY plane.
When you enter the coordinate matrix in the Cross-Section parameter of
the Solid block, SimMechanics treats those coordinates as [X Y] pairs, in
that order.

e X Axis

e Y Axis




Revolution and General Extrusion Cross-Sections

Related
Examples

Concepts

Extrusion Axis Aligns with Z-Axis

SimMechanics extrudes the cross-section that you specify along the Z axis of
the solid reference frame. The extrusion axis runs along the length of the
extrusion.

e 7 Axis

“Model Box Beam” on page 2-47
“Model I-Beam” on page 2-42
“Model Cone” on page 2-32
“Model Dome” on page 2-37

® “Cross-Section Coordinates” on page 2-12
“Advanced Solid Shapes” on page 2-6
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Cross-Section Coordinates

2-12

In this section...

“Specifying Coordinates” on page 2-12
“Coordinate Order” on page 2-13

“Hollow Cross-Sections” on page 2-14

“Path Intersection” on page 2-16

To represent a solid using the Revolution or General Extrusion shapes,
you must provide the cross-section coordinates for that solid. For example,
to represent a beam with a trapezoidal cross-section, you must provide the
coordinates for that trapezoid. You must enter these coordinates according to
a set of rules that ensure SimMechanics properly represents the cross-section
shape.

Specifying Coordinates

The Solid block accepts the cross-section coordinates as an Mx2 matrix.
This matrix contains M rows, each with the coordinates of a cross-section
point. Enter the coordinates sequentially: SimMechanics connects adjacent
coordinate pairs with a straight line to represent the complete cross-section
shape.

The figure shows the cross-section of a trapezoidal beam. SimMechanics
connects adjacent points with straight lines, so you need to provide only four
points. The figure labels these points A, B, C, and D. Specify the coordinates
for these points in the order [A; B; C; and D]. Using the point coordinates in
the figure, the MATLAB matrix for the trapezoid cross-section is:

trapezoid = [X_A, Y_A; X B, Y.B; X C, Y.C; X D, Y_D]




Cross-Section Coordinates

Cross-Section Points Point Coordinates
D C [ ] A - [J’(_ﬁ. \{_A]
eB-[X_B Y_B]

o C-[X_C,¥_C]

A B o D-[¥_D,¥_D]

SimMechanics automatically connects the first and last points of a coordinate
matrix. This ensures that every cross-section path is closed. For example, in
the trapezoid cross-section, SimMechanics automatically connects point D to
point A. The result is a closed trapezoid path that SimMechanics can extrude.

You can enter the MATLAB matrix directly in the Cross-Section parameter
of the Solid block. The figure shows an example. You can replace the X and Y
coordinates with the numerical values directly, or you can define their values
elsewhere, e.g., a subsystem mask or the model workspace.

B Geometry
Shape General Extrusion -
Cross-section |[X_A Y_A: X.B, Y_B: X.C,Y.C:X.D,Y.D] |m v

Coordinate Order

Any boundary path separates the dense and hollow regions of a cross-section.
The dense region is to the left of the path, and the hollow region is to its

right. The figure illustrates how a cross-section path divides dense and hollow
regions.
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—
m r_q.
-
A Hollow B é’ Path
o

Always enter the cross-section coordinates so that the dense region is to the
left of the arrow connecting one coordinate pair to the next. For example, to
represent the trapezoidal cross-section in the figure, enter the coordinates in
the order [A B C D]. This matrix specifies that the dense region is to the left
of the arrows connecting A to B, Bto C, C to D, and D to A.

Coordinate Order:

I
m

Hollow Cross-Sections

A cross-section need not be dense. You can specify a hollow cross-section.
One example is the cross-section of a box beam. This cross-section has a
rectangular shape with a dense area at the periphery, and a hole at the
center. The figure shows that cross-section.



Cross-Section Coordinates

Box Beam Cross-Section

«Hole

— Material

As with dense cross-sections, you specify a hollow cross-section as a single
path. To do this, you must cut the cross-section across its dense region. By
cutting the cross-section, you can merge the inner and outer paths into a
single path. The figure shows the cut box beam cross-section.

Box Beam Cross-Section

I—-Cut

The cut connects the first and last cross-section coordinate pairs. As with
dense cross-sections, you must specify the coordinate pairs so that the dense
region is to the left of the path. A counterclockwise order satisfies this
requirement for the outer portion of the path. A clockwise order satisfies this
requirement for the inner portion of the path. Always specify all coordinates
as a single path—not as two paths. You do this by connecting the inner and
outer portions of the path through the cut.

The figure shows the order that you specify the cross-section coordinates
in. The cut joins the last outer path point to the first inner path point. You
specify the outer path in a counterclockwise order: [A, B, C, D, E]. You
specify the inner path in a clockwise order: [F, G, H, I, j]. The entire
coordinate matrix is [A, B, C, D, E, F, G, H, I, J]. SimMechanics
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automatically closes the path by connecting the last point that you specify (J)
to the first point (A).

Box Beam Cross-Section Quter Path
D
| - - - g -
: A B C D E
Inner Path
‘
F G H I J

To connect the outer path to the inner path through the cut, you must repeat
the first point of each path. For the outer path, you repeat point A (labeled
E). For the inner path, you repeat point F (labeled J). Omitting these points
distorts the cross-section that you specify. The figure shows the cross-section
that results if you omit point E. As before, SimMechanics automatically closes
the path by connecting the last point that you specify (J) to the first point (A).

Box Beam Cross-Section Quter Path
- - [ ] -
A B C D
Inner Path
F G H I J

Path Intersection

The coordinate matrix must define a path that does not self-intersect. If the
path intersects itself at any point, SimMechanics issues an error and the
model does not simulate. Path intersection is a common error source in hollow
cross-sections. The figure shows a self-intersecting path.
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Self-Intersecting Path

lw)

e 3

A
Il

Related e “Model Box Beam” on page 2-47
Exqmples e “Model I-Beam” on page 2-42
¢ “Model Cone” on page 2-32
e “Model Dome” on page 2-37
Concepts ® “Revolution and General Extrusion Cross-Sections” on page 2-9

“Advanced Solid Shapes” on page 2-6
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Specifying Solid Inertia

In this section...

“Point Mass” on page 2-19
“Mass Distribution” on page 2-20

The inertial properties of a rigid body influence its dynamic behavior. One
example is the flywheel: the greater its inertia, the greater the rotational
energy that it can store. In SimMechanics, you specify the inertial properties
using a Solid or Inertia block. Use a Solid block to specify geometry and color
in addition to inertia. Use an Inertia block to specify only inertia. Both blocks
provide multiple inertia types that you can select. You can represent a solid
as a point mass or as a mass distribution (3-D solid).

Paint Mass 3-0) Mass Distribution

To use the blocks, drag them from the Body Elements library.
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Specifying Solid Inertia

-

a1

Graphic

Inertia

~ s
-

Body Elements Library

Point Mass

A point mass occupies an infinitesimally small volume. When you treat a
solid as a point mass, you assume its total mass exists at its center of mass.
The moments and products of inertia of a point mass are zero, and you need

only specify the total mass.

Point Mass

Parameters

Adding a Point Mass to a Model

To position a point mass in a model, connect the block reference frame port
(R) to the frame of your choice. A frame port, line, or node represents the
frame. The point mass coincides with the origin of this frame. For example,
connect the Solid block R frame port to the World Frame block W frame port
to represent a point mass that coincides with the World frame origin.
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i Wi orld Frame ' Soild
mr

For more information about frames, see “Representing Frames” on page 1-7.

Specifying Point Mass Inertia

To specify the inertial parameters of a point mass:

1 In the block dialog box, expand Inertia.
2 In Type, select Point Mass.

3 In Mass, enter the total mass of the solid.

Mass Distribution

A mass distribution occupies a measurable region of space. All rigid bodies
are 3-D mass distributions. To completely describe a mass distribution, you
specify the total mass, center of mass, moments of inertia, and products of

inertia.



Specifying Solid Inertia

Mass Distribution
Parameters

Center
of Mass

Moments Products
of Inertia of Inertia

You can use two inertia types to represent a mass distribution. Select
Calculate from Geometry to automatically calculate the center of mass,
moments of inertia, and products of inertia from the solid geometry. Select
Custom to manually specify all inertial properties. The Solid block provides
both inertia types. The Inertia block provides only Custom.

Mass Distribution Inertia

Automatically Calculate

Manually Specify
fram Geometry

as Custom Inertia

3 3 &)

Solid Inertia Solid

o]

Adding a Mass Distribution to a Model

To position a mass distribution, connect the block reference frame port (R) to
the frame of your choice. A frame, line, or node represents the frame. The
reference frame origin coincides with the origin of this frame. For example,
connect the Solid block R frame port to the World Frame block W frame port
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to represent a 3-D mass distribution whose reference frame origin coincides
with the World frame origin.

i W orkd Frame ' Saki
Irer

The center of mass of the solid depends on the inertia type you use. If

you select Custom, the center of mass depends on the coordinates that you
manually specify with respect to the solid reference frame. If you select
Calculate from Geometry, the center of mass depends on the geometry that
you use. For more information, see the Solid block reference page.

Automatically Calculating Inertia

To automatically calculate the center of mass, moments of inertia, and
products of inertia of a mass distribution:

1 In the Solid block dialog box, expand Inertia.
2 In Type, select Calculate from Geometry.

3 Specify the remaining parameters as defined in the Solid block reference
page.
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Related
Examples

Note To automatically calculate the inertia of a solid from its geometry, you
must specify a valid SimMechanics shape. If you specify a geometry from

a file, you must manually enter all inertia parameters using inertia type
Custom.

Specifying Custom Inertia
To manually specify all inertia parameters of a mass distribution:

1 In the block dialog box, expand Inertia.
2 In Type, select Custom.

3 Specify the remaining parameters as defined in the Solid block reference
page.

¢ “Model Binary Link” on page 2-53
® “Model Pivot Mount” on page 2-67
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Inertia Tensor

2-24

In this section...

“Specifying Inertia Tensor” on page 2-24
“Moments of Inertia” on page 2-24

“Products of Inertia” on page 2-25

The inertia tensor is a 3X3 matrix that governs the rotational behavior of a
rigid body. This matrix is symmetric: elements with reciprocal indices have
the same value. That is:

Ixy:Iyx’ Iyz:Izy’ sz:Ixz
Because the inertia tensor is symmetric, it requires only six elements. Three

are the moments of inertia and three are the products of inertia. The complete
inertia tensor has the form:

Specifying Inertia Tensor

You can specify the inertia tensor manually, using one of two blocks: Solid
and Inertia. To do this, in the block dialog box select Custom from the
Inertia > Type drop-down menu. In the new set of parameters that appears,
specify the inertia tensor in terms of the moments and products of inertia.

Moments of Inertia

The moments of inertia are the three diagonal terms of the inertia tensor:




Inertia Tensor

In the Moments of Inertia dialog box parameter, enter the three diagonal
elements as a row vector. Enter the elements in the order [I , I, , I, ]. These
are the moments of inertia of the solid with respect to a frame whose axes
align with the block reference frame, and whose origin coincides with the

solid center of mass.

Products of Inertia

The products of inertia are the three unique off-diagonal elements. Because
the inertia tensor is symmetric, each off-diagonal element appears twice in
the matrix.

In the Products of Inertia dialog box parameter, enter the three unique
off-diagonal elements. Enter the elements in the order [Iyz, L., Ixy]. One
easy way to remember the element order is to think of the missing subscript
component: x, y, and z respectively. The elements are the products of inertia
of the solid with respect to a frame whose axes align with the block reference
frame, and whose origin coincides with the solid center of mass.

Related ¢ “Model Binary Link” on page 2-53
Exqmples ¢ “Model Pivot Mount” on page 2-67
Concepts e “Specifying Solid Inertia” on page 2-18
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Solid Color

In this section...

“Basic Graphic Parameters” on page 2-27

“Advanced Graphic Parameters” on page 2-29

To make the most of the visualization capability of Mechanics Explorer,

the Solid block provides two parameterizations that you can use to

specify the graphic appearance of a solid: Simple and Advanced. The two
parameterizations accept material color and opacity parameters as input.
Light source parameters are fixed for all models. The table provides a
comparison of the input parameters present in each graphic parameterization.

Graphic Parameter | Simple Advanced

Diffuse Color v

Ambient Color

Specular Color

Emissive Color

Opacity v

SN RN RN RN R

Shininess

As an example, the figure shows two identical elliptical extrusions, one based
on Simple and the other on Advanced graphic parameterizations. In both
cases, the extrusion is completely opaque with a gray diffuse color. The
advanced version adds to the solid a set of blue highlights, through the use of
specular color, and a red ambient hue, through the use of ambient color.

Color Parameter Simple Advanced

Diffuse Color [0.8 0.8 0.8] [0.8 0.8 0.8 1.0]
Ambient Color — [0.1 0.05 0.05 1.0]
Specular Color — [0 0 1.0 1.0]




Solid Color
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Solid with Simple color parameterization. Solid with Advanced color parameterization.

The material colors — diffuse, ambient, specular, and emissive — form the
core of the graphical representation of a solid in SimMechanics. You can
specify the material colors in terms of RGB or RGBA color vectors.

Basic Graphic Parameters

Both Simple and Advanced graphic parameterizations require you to specify
the diffuse color and opacity of the solid. Together, these two parameters
represent the graphical core of a SimMechanics solid. The way in which you
specify the parameters differs slightly between the two parameterizations,

but the meaning of each parameter remains the same.

Diffuse Color

Apparent color of a rough solid surface exposed to direct white light.
Diffuse light scatters equally in all directions according to Lambert’s
law, causing the intensity and color of the scattered light to appear the
same from all angles. The diffuse color normally provides the dominant
contribution to the color of a solid surface. In most cases, you can think
of the diffuse color as the “true color” of a solid surface.

Parameterization | Parameter Name | Specification
Used

Simple Color [R G B] vector

Advanced Diffuse Color [R G B A] vector
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The figure shows the effect of varying the diffuse color of a solid. The
array of spheres have identical graphical properties, with the exception
of Diffuse Color. The RGBA color vector of the diffuse color progresses
from [1 1 1], at the left corner, to [0.85 0.45 0], at the right corner. A
gray ambient color gives the solid a darker appearance.

VOO0

The opacity is the degree to which a solid blocks light from passing
through. A completely opaque solid blocks all light penetration through
the solid. The opposite of a completely opaque solid is a transparent
solid, which allows all light to pass through. You can reduce the opacity
of a solid in order to improve the visibility of other solids otherwise
blocked from view.

Opacity

Parameterization Parameter Name Specification
Used

Simple Opacity Scalar number (0-1)

Advanced A element of Diffuse | Scalar number (0-1)
Color [R G B A]
vector

The figure shows the effect of varying the opacity of a solid. The array
of spheres have identical graphical properties, with the exception of
Opacity. The opacity value progresses from 0.1, at the left corner, to
1, at the right corner. An opacity value of O represents a completely
transparent, or invisible, solid. An opacity value of 1 represents a
completely opaque solid.

000
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Advanced Graphic Parameters

In addition to the diffuse color and opacity, the Advanced parameterization
provides a set of colors that enhance the 3—-D graphical appearance of the
solid. The additional colors include specular, ambient, and emissive colors,
each of which includes an opacity (A) element in the [R G B A] color vector.
You can omit the fourth element in the RGBA vector, in which case the color
uses a maximum opacity value of 1.

Specular Color
The specular color is the apparent color of the glossy highlights arising
from a solid surface exposed to direct light. The size of the specular
highlights depends on the value of the Shininess parameter. The
intensity of the specular color is not uniform in space, and has a strong
dependence on the viewing angle. Changing the specular color changes
only the color of the specular highlights. For most applications, the [R G
B A] vector [0.5 0.5 0.5 1] works well.

The figure shows the effect of varying the specular color of a solid.

The array of spheres have identical graphical properties, with the
exception of Specular Color. The RGBA color vector of the specular
color progresses from [1 1 1 1], at the left corner, to [1 0 0 1], at the right
corner. A gray ambient color gives the solid a darker appearance.

QOO O9

Ambient Color
The ambient color is the apparent color of a solid surface exposed only to
indirect light. Changing the ambient color changes the overall color of
the entire solid surface. For most applications, the RGBA vector [0.15
0.15 0.15 1] works well.

The figure shows the effect of varying the ambient color of a solid. The
array of spheres have identical graphical properties, with the exception
of the Ambient Color. The RGBA color vector of the ambient color
progresses from [1 1 1 1], at the left corner, to [1 0 0 1], at the right
corner. A gray ambient color gives the solid in the left corner a darker
appearance.
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UV

Emissive Color

The emissive color is the apparent color of light emitted directly by the
solid surface. Examples of solids with a nonzero emissive color include
glowing hot metal, light displays, and the Sun. For most applications,

the RGBA vector [0 0 0 1] works well.

The figure shows the effect of varying the emissive color of a solid. The
array of spheres have identical graphical properties, with the exception
of the Emissive Color. The RGBA color vector of the emissive color
progresses from [1 1 1 1], at the left corner, to [1 0 0 1], at the right
corner. A gray ambient color gives the solid in the left corner a darker
appearance. The glowing appearance of the emissive color differentiates
the emissive color from ambient and diffuse colors.

QLU

Shininess

The shininess is a parameter that encodes the size and rate of decay

of specular highlights on a solid surface. A small shininess value
corresponds to a large specular highlight with gradual falloff in highlight
intensity. On the other hand, a large shininess value corresponds to a
small specular highlight with sharp falloff in highlight intensity.

The figure shows the effect of varying the shininess of a solid. The array
of spheres have identical graphical properties, with the exception of
Shininess. The shininess value progresses from 5, at the left corner,
to 25, at the right corner. As the shininess value increases, the area

of the specular highlight decreases, while the falloff rate in highlight
intensity increases.



Solid Color

DOOOO

Related e “Model Binary Link” on page 2-53
Examples ® “Model Pivot Mount” on page 2-67
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Model Cone

In this section...

“Model Overview” on page 2-32
“Modeling Approach” on page 2-32
“Build Model” on page 2-33

“Specify Parameter Values” on page 2-35
“Visualize Model” on page 2-35

Model Overview

You can model solids of revolution using the SimMechanics Revolution
shape. Examples of solids of revolution include cone and circular dome
shapes. In this example, you model a simple solid with cone shape using the
Revolution shape. For an example that shows you how to model a circular
dome solid, see “Model Dome” on page 2-37.

Modeling Approach

To represent the cone geometry, first identify its cross-section shape. This

is the 2-D area that SimMechanics revolves to obtain the 3-D cone. Then,
specify the cross-section coordinates in the Solid block dialog box. These
coordinates, must satisfy certain restrictions. See “Cross-Section Coordinates”
on page 2-12.



Model Cone

The cone in this example has a trapezoidal cross-section. The figure shows
this cross-section.

T tan{ce) = R/H

The [0 0] cross-section coordinate identifies the reference frame origin for
this solid. To place the solid reference frame at the cone tip, you by specify
the coordinates so that the [0 0] coordinate coincides with the tip. By
parameterizing the cross-section coordinates in terms of the relevant cone
dimensions, you can quickly change the cone dimensions without having to
reenter the cross-section coordinates. The figure shows the parameterized
cross-section coordinates points.

A=[0, 0]

B=[R, H]

C = [R-Tleos(w), H]
0= [0 Tisinice), H]

-

D

Build Model

Add and connect the blocks to represent the cone. Include a Solver
Configuration block so that you can visualize the solid in Mechanics Explorer
during the modeling process.

1 Drag these blocks into a new model.
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Library Block Quantity
Body Elements Solid 1
Simscape Utilities Solver Configuration 1

2 Connect the blocks as shown.

flx)=10

Configuration

3 In the Solid block dialog box, specify these parameters.

Parameter

Value

Geometry > Shape

Select Revolution.

Geometry > Cross-Section Enter CS. Select units of cm.

Graphic > Visual
Properties > Color

Enter RGB

4 Select the Solid block and generate a new subsystem, e.g., by pressing

Ctrl+G.
flx)=10 L] Conni
Sohver
Configuration Subsystem



Model Cone

Specify Parameter Values

In the subsystem mask, initialize the solid parameters. Then, in the
subsystem dialog box, specify their values.

1 Select the Subsystem block and create a subsystem mask, e.g., by pressing
Ctrl+M.

2 Injhe Parameters & Dialog tab of the Mask Editor, drag four edit boxes

into the Parameters group and specify these parameters.

Prompt Name
Base Radius R
Cone Height H
Wall Thickness T
Color RGB

3 In the Initialization tab of the Mask Editor, enter the initialization code
for the CS variable.

Alpha = atan(R/H);
CS = [0 0; R H; R-T/cos(Alpha) H; 0 T/sin(Alpha)];

4 In the Subsystem block dialog box, specify these parameters

Parameter Value

Base Radius 1

Cone Height 2

Wall Thickness 0.1

Color [0.85 0.45 0]

Visualize Model

You can now visualize the cone that you modeled. To do this, on the Simulink
menu bar, select Simulation > Update Diagram. Mechanics Explorer
opens with a 3-D display of your model. Rotate, pan, and zoom to explore.
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Try modifying the cone geometry. To do this, in the subsystem dialog box,
change the dimension parameter values. Then, update the model. The figure
shows some examples.

R=1; R=1; R=1;
H=2; H=1; H=5
T=0.1; T=0.35; 'I':|:|-"|I
Related ¢ “Model Dome” on page 2-37
Exqmples ¢ “Model I-Beam” on page 2-42
¢ “Model Box Beam” on page 2-47
Concepts ® “Cross-Section Coordinates” on page 2-12

“Revolution and General Extrusion Cross-Sections” on page 2-9
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Model Dome

In this section...

“Model Overview” on page 2-37
“Modeling Approach” on page 2-37
“Build Model” on page 2-38

“Specify Parameter Values” on page 2-40
“Visualize Model” on page 2-41

Model Overview

You can model a solid of revolution with a round cross-section. One example is
the circular dome. In this example, you specify the cross-section coordinates
of a circular dome using the MATLAB cos and sin functions. For an example
that shows you how to model a cone-shaped solid, see “Model Cone” on page
2-32.

Modeling Approach

To represent the dome geometry, first identify its cross-section shape. This is
the 2-D shape that SimMechanics revolves to obtain the 3-D dome. You can
then specify the cross-section coordinates in the Solid block dialog box. These
coordinates must satisfy certain restrictions. See “Cross-Section Coordinates”
on page 2-12.

The dome has a quarter-circle cross-sectional shape. The figure shows this
shape.
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The [0 0] cross-section coordinate identifies the reference frame origin for this
solid. To place the solid reference frame at the dome base center, you specify
the coordinates so that the [0 0] coordinate coincides with the base center. By
parameterizing the cross-section coordinates in terms of the relevant dome
dimensions, you can quickly change the dome dimensions without having to
reenter the cross-section coordinates. The figure shows the parameterized
cross-section coordinate points.

Ew

o = (0:0.01:m2),

[} = {mi2:-0.01:00,

AB = R*[cos(ce), sinfo)]
C:D = {R-T)*[cos(p), sin(]

L]

L]

-
L ]

s

To define the dome cross-section, first define two angle arrays—one in
counterclockwise order, running from 0-90°; the other in a clockwise
order running from 90-0°. You can then use the first array to define the
outer cross-section coordinates, and the second array to define the inner
cross-section coordinates. You do that using the MATLAB cos and sin
functions.

Build Model

Add and connect the blocks to represent the dome. Include a Solver
Configuration block so that you can visualize the solid in Mechanics Explorer
during the modeling process.

1 Drag these blocks into a new model.



Model Dome

Library Block Quantity
Body Elements Solid 1
Simscape Utilities Solver Configuration 1

2 Connect the blocks as shown.

fx)= 0
Soher
Configuration o £
1 Salid
i £]

3 In the Solid block dialog box, specify these parameters.

Parameter Value

Geometry > Shape Select Revolution
Geometry > Cross-Section Enter CS. Specify units of cm.
Graphic > Visual Enter RGB

Properties > Color

4 Select the Solid block and generate a subsystem, e.g., by pressing Ctrl+G.

flx)=10 1] Conni
Soher
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Specify Parameter Values

In the subsystem mask, initialize the solid parameters. Then, in the
subsystem dialog box, specify their values.

1 Select the Subsystem block and create a subsystem mask, e.g., by pressing
Ctrl+M.

2 In the Parameters & Dialog tab of the Mask Editor, drag three edit boxes

a1 . .
into the Parameters group and specify these parameters.

Prompt Name
Radius R
Wall Thickness T
Color RGB

3 In the Initialization tab of the Mask Editor, enter the initialization code
for the xsection variable.

% Circular dome outer coordinates:
Alpha = (0:0.01:pi/2)"';

QuterCS = R*[cos(Alpha), sin(Alpha)];
% Circular dome inner coordinates:

Beta = (pi/2:-0.01:0)"';

InnerCS = (R-T)*[cos(Beta), sin(Beta)];

CS = [OuterCS; InnerCS];

4 In the Subsystem block dialog box, specify these parameters.

Parameter Value

Radius (in) 1

Wall Thickness (in) 0.1

Color [R G B] [0.85 0.45 0]
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Related
Examples

Concepts

Visualize Model

You can now visualize the dome that you modeled. To do this, on the Simulink
menu bar, select Simulation > Update Diagram. Mechanics Explorer
opens with a 3-D display of your model. Rotate, pan, and zoom to explore.

Try modifying the dome geometry. To do this, in the subsystem dialog box,
change the dimension parameter values. Then, update the model. The figure
shows some examples.

=1

R=0% R=0.75;
= 0.2; T=0.05

[ T
—
[
3

“Model Cone” on page 2-32
* “Model I-Beam” on page 2-42
e “Model Box Beam” on page 2-47

e “Advanced Solid Shapes” on page 2-6
® “Cross-Section Coordinates” on page 2-12
¢ “Revolution and General Extrusion Cross-Sections” on page 2-9
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Model I-Beam

2-42

In this section...

“Model Overview” on page 2-42
“Modeling Approach” on page 2-42
“Build Model” on page 2-43

“Specify Parameter Values” on page 2-45

“Visualize I-Beam in Mechanics Explorer” on page 2-46

Model Overview

You can model an extrusion using the SimMechanics shape General
Extrusion. Examples of extrusions include the I-beam and box-beam shapes.
In this example, you model a simple solid with I-beam shape using the
General Extrusion shape. For an example that shows you how to model a
box beam, see “Model Box Beam” on page 2-47.

Modeling Approach

To represent the I-beam geometry, first identify its cross-section. This is the
2-D area that SimMechanics extrudes to obtain the 3-D I-beam. You can then
specify the cross-section coordinates in the Solid block dialog box. The figure
shows the I-beam cross-section that you specify in this example.




Model I-Beam

The [0 0] coordinate identifies the solid reference frame origin. To place

the reference frame at the center of the I-beam, specify the coordinates so
that the [0 0] coordinate is at the cross-section center. Because the I-beam
cross-section is symmetric about the horizontal and vertical axes, you need
only define the coordinates for one cross-section half—e.g, the right half. You
can then define the left half coordinates in terms of the right half coordinates.

By parameterizing the cross-section coordinates in terms of relevant I-beam
dimensions, you can quickly change the I-beam dimensions without having
to reenter the cross-section coordinates. The figure shows the cross-section
dimensions and coordinates that you must specify to represent the I-beam.

o o A=[WI2, -H2]
« B=[W2 -0]
« C=[T12 -0]
« D=[T72,0|
i e E=[Wi2 0]
S o F=[W2 H2)

Using the cross-section points that the figure shows, you define the coordinate
matrix as:

HalfCS = [A; B; C; D; E; F];
CS = [HalfCS; -HalfCS];

Build Model

Add and connect the blocks to represent the I-beam. Include a Solver
Configuration block so that you can visualize the solid in Mechanics Explorer
during the modeling process.

1 Drag these blocks into a new model.
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Library Block Quantity
Body Elements Solid 1
Simscape Utilities Solver Configuration 1

2 Connect the blocks as shown.

flx)=10

Configuration

3 In the Solid block dialog box, specify these parameters.

Parameter

Value

Geometry > Shape

Select General Extrusion

Geometry > Cross-Section Enter CS. Select units of cm.

Geometry > Length

Enter L. Select units of cm

Graphic > Visual
Properties > Color

Enter RGB

4 Select the Solid block and generate a new subsystem, e.g., by pressing

Ctrl+G.
flx)=10 L] Conni
Sohver
Configuration Subsystem
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Specify Parameter Values

In the subsystem mask, initialize the solid parameters. Then, in the

subsystem dialog box, specify their values.

1 Select the Subsystem block and create a subsystem mask, e.g., by pressing

Ctrl+M.

2 In the Parameters & Dialog tab of the Mask Editor, drag five edit boxes

into the Parameters group and specify these parameters.

Prompt Name
Length (in) L
Height (in) H
width (in) w
Thickness (in) T
Color [R G B] RGB

3 In the Initialization tab of the Mask Editor, enter the initialization code
for the xsection variable and click OK:

D = H/2-T;

HalfCs = [W/2, -H/2; W/2, -D; T/2, -D;

T/2, D; W/2, D; W/2, H/2];
CS = [HalfCS; -HalfCS];

4 In the Subsystem block dialog box, specify these parameters.

Parameter Value

Length 10

Height 4

Width 2

Thickness 0.2

Color [0.85 0.45 0]
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Visualize I-Beam in Mechanics Explorer

You can now visualize the I-beam that you modeled. To do this, on the
Simulink menu bar, select Simulation > Update Diagram. Mechanics
Explorer opens with a 3-D display of your model. Rotate, pan, and zoom to
explore.

Try modifying the I-beam geometry. To do this, in the subsystem dialog box,
change the dimension parameter values. Then, update the model. The figure
shows some examples.

L=10; L=10; L=10;
H=4 H=4 H=23

W= 2 W= 3; W= 2.
T=0.3; T=0.2; T=02;

Related “Model Cone” on page 2-32

Exqmples e “Model Dome” on page 2-37
e “Model Box Beam” on page 2-47

Concepts e “Advanced Solid Shapes” on page 2-6

® “Cross-Section Coordinates” on page 2-12
¢ “Revolution and General Extrusion Cross-Sections” on page 2-9
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Model Box Beam

In this section...

“Model Overview” on page 2-47
“Modeling Approach” on page 2-47
“Build Model” on page 2-49

“Specify Parameter Values” on page 2-50

“Visualize Box Beam in Mechanics Explorer” on page 2-51

Model Overview

You can model an extrusion with a hole. One example is the box beam.
Specifying hollow cross-sections must satisfy the cross-section guidelines. See
“Cross-Section Coordinates” on page 2-12. In this example, you specify the
cross-section coordinates of a box beam. For an example that shows you how
to model an I-beam extrusion, see “Model I-Beam” on page 2-42.

Modeling Approach

To represent the box beam geometry, first identify its cross-section. This is
the 2-D area that you sweep along an axis to obtain the 3-D box beam. You
can the specify the cross-section coordinates using the Solid block. The figure
shows the box beam cross-section that you specify in this example.
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The [0 0] coordinate identifies the solid reference frame origin. To place the
reference frame at the center of the box beam, specify the coordinates so that
the [0 O] coordinate is at the cross-section center. By parameterizing the
cross-section coordinates in terms of relevant box beam dimensions, you

can later change the box beam dimensions without having to reenter the
cross-section coordinates. The figure shows the cross-section dimensions and
coordinates that you must specify to represent the box beam.

- = A E=[-W2 -H2]
R o e B=[W2,-H2|
i s C=[W2 H2
o D= [W2, H2
B | « FJ=[-D,-D2
- s G=[-D1, 02
e '.n = H=[D1, D2]
e - = |=[D1,-D7

Using the cross-section points that the figure shows, you define the coordinate
matrix as:

OuterCS = [A, B, C, D, E];
InnerCS = [F, G, H, I, J];
CS = [OuterCS; InnerCS];

For more information about specifying the hollow cross-section coordinates,
see “Hollow Cross-Sections” on page 2-14.



Model Box Beam

Build Model

Add and connect the blocks to represent the box beam. Include a Solver
Configuration block so that you can visualize the solid in Mechanics Explorer
during the modeling process.

1 Drag these blocks into a new model.

Library Block Quantity
Body Elements Solid 1
Simscape Utilities Solver Configuration 1

2 Connect the blocks as they appear in the figure.

fx) =10

Soher
Canfiguration 2l

15::&:1

3 In the Solid block, specify these parameters.

Parameter Value

Geometry > Shape Select General Extrusion
Geometry > Cross-Section Enter CS. Select units of cm.
Geometry > Length Enter L. Select units of cm
Graphic > Visual Enter RGB

Properties > Color

4 Select the Solid block and generate a subsystem, e.g., by pressing Ctrl+G.

2-49



2 Rigid Bodies

flx)=10 1] Conni
Soher
C onfiguration Subsystem

Specify Parameter Values

In the subsystem mask, initialize the solid parameters. Then, in the
subsystem dialog box, specify their values.

1 Select the Subsystem block and create a subsystem mask, e.g., by pressing
Ctrl+M.

2 Injhe Parameters & Dialog tab of the Mask Editor, drag five edit boxes

inside the Parameters group and specify these parameters.

Prompt Name
Length L
Height H
Width w
Thickness T
Color RGB

3 In the Initialization tab of the Mask Editor, enter the initialization code
for the xsection variable and click OK:

D1 W/2-T;

D2 H/2-T;

OuterCS = [-W/2,-H/2; W/2,-H/2; W/2,H/2;

-W/2,H/2; -W/2,-H/2];

InnerCS = [-D1,-D2; -D1,D2; D1,D2; D1 -D2; -D1,-D2];
CS = [OuterCS; InnerCS];

4 In the Subsystem block dialog box, specify these parameters.
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Related
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Visualize Box Beam in Mechanics Explorer

Parameter Value
Length (in) 10
Height (in) 4
Width (in) 2
Thickness (in) 0.2

Color [R G B]

[0.85 0.45 0]

You can now visualize the box beam that you modeled. To do this, on the
Simulink menu bar, select Simulation > Update Diagram. Mechanics

Explorer opens with a 3-D display of your model. Rotate, pan, and zoom to
explore.

Try modifying the box beam geometry. To do this, in the subsystem dialog
box, change the dimension parameter values. Then, update the model. The
figure shows some examples.

* “Model I-Beam” on page 2-42
e “Model Cone” on page 2-32
e “Model Dome” on page 2-37

“Advanced Solid Shapes” on page 2-6

“Cross-Section Coordinates” on page 2-12
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® “Revolution and General Extrusion Cross-Sections” on page 2-9
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Model Binary Link

In this section...

“Model Overview” on page 2-53
“Modeling Approach” on page 2-53
“Solid Properties” on page 2-55
“Build Model” on page 2-56
“Update Subsystem” on page 2-58
“Visualize Model” on page 2-59

“Open Reference Model” on page 2-60

Model Overview

In example “Represent Binary Link Frame Tree” on page 1-36, you modeled
the frame tree of a binary link rigid body. In this example, you add to that
frame tree the solid properties of the binary link: geometry, inertia, and color.

Modeling Approach

To model a binary link, you must use multiple Solid blocks. Each Solid block
represents an elementary portion of the binary link. Rigid bodies that you
model using multiple Solid blocks are called compound rigid bodies. The
compound rigid body technique reduces a single complex task (modeling the
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entire binary link shape) into several simple tasks (modeling the Main, Hole,
and Peg sections of the binary link).

To use the compound rigid body technique:

1 Divide shape into simple sections.

Dividing the shape simplifies the modeling task in more complex cases.
You can divide the binary link into three simple sections: Main, Peg, and

Hole, shown in the figure.

¢ ¥ o~

2 Represent each section using a Solid block.

Each section should be simple enough to model using a single Solid block.
In the binary link example, you can represent sections Main and Hole
using SimMechanics shape General Extrusion, and section peg with

SimMechanics shape Cylinder.

Main

[a:]

'3---.
o

.. 3

3 Rigidly connect Solid blocks to rigid body frame tree.

Rigid connections ensure the different solid sections move as a single rigid
body. Connect the Solid blocks to the binary link frame tree to apply the
correct spatial relationships between the solid sections.
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Solid Properties

You model the binary link as a compound rigid body subsystem. In this
subsystem, three Solid blocks represent the basic solid sections of the binary
link. Each solid section has a shape and a local reference frame that you
connect to the binary link frame tree. Two SimMechanics shapes are used:
General Extrusion and Cylinder.

You can promote subsystem reusability by parameterizing solid properties

in terms of MATLAB variables. In this example, you initialize the variables
in a subsystem mask. You can then specify their numerical values in the
subsystem dialog box. The table provides the dimensions needed to model the
binary link solid sections. In the previous example, “Represent Binary Link
Frame Tree” on page 1-36, you used the first three dimensions to specify the
spatial relationships between the different binary link frames.

Dimension MATLAB Variable
Length L
Width w
Thickness T
Peg Radius R
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SimMechanics shape General Extrusion requires you to specify a set of
cross-section coordinates. This is a MATLAB matrix with all the [X Y]
coordinate pairs needed to draw the cross-section. Straight line segments
connect adjacent coordinate pairs.

Coordinate matrices must obey a set of rules. The most important rule is that
the solid region must lie to the left of the line segment connecting adjacent
coordinate pairs. For more information, see “Cross-Section Coordinates”

on page 2-12. The figure shows the coordinates required to specify the
cross-section shapes of solid sections Main and Hole.

-
B o= (mi2-0.01-mi2), o= (20012,
-
Hole End Coordinates: . '_ .
[-L/2 WiZ; -Li2 + Recos(f)... ;
R=sin([); -L/2 -Wi2],

Peg End Coordinates:

ILA2+Wi2 cos(o), W2 sin(o)]

e
L o= (m2:0.01:34w2), ) { B = (a*r/2:-0.01:m2)"
Outer Coordinates: :" { Inner Coordinates:
Wi2*cos(o), Wi2*sinfa];, % .. [Rrcos(B) R sin([)];

Build Model

1 At the MATLAB command prompt, enter smdoc_binary_link_frames.
A SimMechanics model opens with the frame tree you modeled in the
“Represent Binary Link Frame Tree” on page 1-36 tutorial.
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2 Right click Binary Link and select Mask > Look Under Mask.

Rigid Transform Rigid Transform
Coe—Els 75 Els 7 rE—e( 2
Conni r P Conn2

From the SimMechanics Body Elements library, drag three Solid blocks
into the model.

3 Connect and name the blocks as shown in the figure.

Rigid Transform Rigid Transform1

© 1l o 1k
- @ [~

4 In the Solid block dialog boxes, specify these parameters.
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Parameter Hole Main Peg

Geometry > Shapeelect General Select General Select Cylinder
Extrusion Extrusion

Geometry > CrostsstatboneCS Enter MainCS —

Geometry > Radius — Enter R
Geometry > Lenglthter T Enter T Enter 2*T
Geometry > Densdlityter Rho Enter Rho Enter Rho

Graphic > Coloxt Enter LinkRGB Enter LinkRGB Enter LinkRGB

Update Subsystem

In the subsystem mask, initialize the MATLAB variables you entered for
the block parameters.

1 Select the subsystem block and press Ctrl+M to create a subsystem mask.

2 Ithhe Parameters & Dialog tab of the Mask Editor, drag four edit boxes

into the Parameters group and specify these parameters. Then, click

OK.

Prompt Name
Peg Radius R

Mass Density Rho
Link Color [R G B] LinkRGB
Peg Color [R G B] PegRGB

Note The subsystem mask should contain three other parameters: L, W,
and T. You specify those parameters in “Represent Binary Link Frame
Tree” on page 1-36.

3 In the Initialization tab of the Mask Editor, define the extrusion
cross-sections and press OK:
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% Cross-section of Main:

Alpha = (-pi/2:0.01:pi/2)"';

Beta = (pi/2:-0.01:-pi/2)"';

PegCS = [L/2+W/2*cos(Alpha)...
W/2*sin(Alpha)];

HoleCS = [-L/2 W/2; -L/2 + R*cos(Beta)...
R*sin(Beta); -L/2 -W/2];

MainCS = [PegCS; HoleCS];

% Cross-section of Hole:

Alpha = (pi/2:0.01:3*pi/2)"';

Beta = (3*pi/2:-0.01:pi/2)";

HoleCS = [W/2*cos(Alpha) W/2*sin(Alpha);
R*cos(Beta) R*sin(Beta)];

4 In the binary_link subsystem block dialog box, specify these parameters.

Parameter Value

Length 30

Width 2

Thickness 0.8

Peg Radius 0.4

Mass Density 2700

Link Color [R G B] [0.25 0.4 0.7]
Peg Color [R G B] [1 0.6 0.25]

Visualize Model

Update the block diagram. You can do this by pressing Ctrl+D. Mechanics
Explorer opens with a static 3-D display of the binary link.
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Open Reference Model

To view a completed version of the binary link model, at the MATLAB
command prompt enter smdoc_binary_link_a.

Related * “Model Two-Hole Binary Link” on page 2-61
Exqmples * “Model Pivot Mount” on page 2-67
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Model Two-Hole Binary Link

In this section...

“Model Overview” on page 2-61
“Build Model” on page 2-61
“Generate Subsystem” on page 2-63
“Visualize Model” on page 2-65

“Open Reference Model” on page 2-66

Model Overview

In this example, you model a two-hole binary link as a rigid body. Three
Solid blocks represent the main body and hole sections of the link. Two Rigid
Transform blocks define the spatial relationships between the three solids.
This example is a variation of “Model Binary Link” on page 2-53.

Build Model

1 Start a new model.

2 Drag the following blocks to the model.
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Library Block Quantity
Simscape > Utilities | Solver Configuration 1
SimMechanics > Seconldigid Transform 2
Generation > Frames

and Transforms

SimMechanics > Seconsblid 3
Generation > Body

Elements

3 Connect and name the blocks as shown in the figure.

Be sure to flip the Rigid Transform1 block. Its B frame port must face the
Main Solid block. Include the broken line extending from the Hole B block
(right click the existing connection line and drag).

Rigid Transform Rigid Transform

-, A

o) =0 &5 7h, S = ¥
|J_r| )= J=
Solver
Canfigur ation
' Hole A ' Iviain ' Hole B

4 In the solid block dialog boxes, specify these parameters.
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Parameter Hole A Main Hole B
Geometry > Shap&elect General | Select General | Select General
Extrusion Extrusion Extrusion

Geometry > Cros¥~startHod eACS.

Select units of
cm.

Enter MainCS.
Select units of
cm.

Enter HoleBCS.
Select units of
cm.
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Parameter Hole A Main Hole B

Geometry > Lengtlinter T. Select | Enter T. Select | Enter T. Select
units of cm. units of cm. units of cm.

Inertia > Density Enter Rho Enter Rho Enter Rho

Graphic > Visudl Enter LinkRGB | Enter LinkRGB Enter LinkRGB
Properties > Color

5 In the rigid transform block dialog boxes, specify these parameters.

Parameter Rigid Transform Rigid Transform1
Translation > Method Standard Axis Standard Axis
Translation > Axis +X +X

Translation > Offset L_Link/2 +L_Link/2

Generate Subsystem

Enclose the binary link blocks in a Subsystem block, define the general
extrusion coordinates, and specify the relevant parameter values:

1 Select all blocks excluding Solver Configuration and press Ctrl+G..

Simulink encloses the selected blocks in a new subsystem block. Rename
the subsystem block as shown in the figure.
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2 Select the subsystem block and press Ctrl+M. Simulink adds a parameter
mask to the subsystem block.

3 In the Parameters & Dialog tab of the Mask Editor, drag six edit boxes

into the Parameters group and specify the following parameters.

Prompt Name
Length L
Width W
Thickness T

Peg Hole Radius R

Mass Density Rho
Link Color LinkRGB

4 In the Initialization tab of the Mask Editor, define the extrusion cross
sections and click OK:

% Cross-section of Main:
Alpha = (pi/2:-0.01:-pi/2)"';
Beta = (3*pi/2:-0.01:pi/2)"';

EndACS = [-L/2 W/2; -L/2+R*cos(Alpha)...
R*sin(Alpha); -L/2 -W/2];

EndBCS = [L/2 -W/2; L/2+R*cos(Beta)...
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R*sin(Beta); L/2 W/2];
MainCS = [End1CS; End2CS];

% Cross-section of HoleA:

Alpha = (pi/2:0.01:3*pi/2)"';

Beta = (3*pi/2:-0.01:pi/2)";

HoleACS = [W/2*cos(Alpha) W/2*sin(Alpha);...
R*cos(Beta) R*sin(Beta)];

% Cross-section of HoleB:
Alpha = (-pi/2:0.01:pi/2)
Beta = (pi/2:-0.01:-pi/2)"
HoleBCS = [W/2*cos(Alpha)
R*cos(Beta) R*sin(Beta)];

[
3
3

W/2*sin(Alpha);...

5 In the dialog box of the Binary Link B subsystem block, specify these
parameters.

Parameter Value

Length (m) 30

Width (m) 2

Thickness (m) 0.8

Peg Hole Radius (m) 0.4

Mass Density (kg/m”3) 2700

Link Color [R G B] [0.25 0.4 0.7]

Visualize Model

Update the block diagram. You can do this by pressing Ctrl+D. Mechanics
Explorer opens with a static 3-D display of the binary link rigid body.
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You can open a copy of the resulting model. At the MATLAB command line,
enter smdoc_binary_link_b.

Open Reference Model

To open a completed version of the two-hole binary link model, at the
MATLAB command line enter smdoc_binary_link_b.

Related e “Model Binary Link” on page 2-53

Examples ® “Model Pivot Mount” on page 2-67
e “Model Four Bar” on page 3-31
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Model Pivot Mount

In this section...

“Model Overview” on page 2-67
“Modeling Approach” on page 2-67
“Build Model” on page 2-69
“Generate Subsystem” on page 2-71
“Visualize Model” on page 2-72

“Open Reference Model” on page 2-73

Model Overview

In this example, you model a simple pivot mount. This mount is a compound
rigid body with a hexagonal shape and a protruding cylindrical peg. You
represent the hexagonal shape using solid shape Regular Extrusion. You
then offset the protruding peg from the hexagonal shape using a Rigid
Transform block. In later examples, you use this mount to support mechanical
linkages like the double pendulum and the four bar system.

Modeling Approach

To model the pivot mount, you use two Solid blocks. Because the pivot mount
has a hexagonal shape, you can model it using the Regular Extrusion shape.
To represent the cylindrical peg, you use the Cylinder shape.
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2-68

B b

Base Peg

Each shape has a reference frame with origin at the geometry center. To
offset the cylindrical peg with respect to the hexagonal mount, you apply a
rigid transform between the two reference frames. You do this using the
Rigid Transform block.

The Z axes of the two reference frames align with the cylindrical and
extrusion axes of the peg and mount, respectively. Assuming the two solids
both have thickness T, the rigid transform between the two reference frames
is a translation T along the common Z axis.




Model Pivot Mount

In later examples, you connect the pivot mount to a binary link using

a revolute joint. One example is a double pendulum that moves due to
gravity. In this example, it helps to rotate the Z axis of the mount so that it
is orthogonal to the world frame Z axis. This task, which involves a Rigid
Transform block, makes the pivot rotation axis orthogonal to the gravity
vector, [0 O -9.81] m/s"2.

Build Model

1 Drag these blocks into a new model.

Block Library Quantity
Solid SimMechanics > Seconil
Generation > Body
Elements
Rigid Transform SimMechanics > Seconil

Generation > Frames
and Transforms

Reference Frame SimMechanics > Second
Generation > Frames
and Transforms

Solver Configuration Simscape > Utilities | 1

2 Connect and name the blocks as shown in the figure.

Note Include the disconnected frame line. This line becomes important
when you generate a subsystem for the pivot mount. To add this line,
right-click on the solid frame line and drag to the right.
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Configuration

3 In the Hexagon block dialog box, specify these parameters.

Parameter Value

Geometry > Shape Select Regular Extrusion.
Geometry > Number of Sides Enter 6.

Geometry > Outer Radius Enter HexagonR. Select units of cm.
Geometry > Length Enter T. Select units of cm.
Inertia > Density Enter Rho.

Graphic > Color Enter HexagonRGB.

4 In the Peg block dialog box, specify these parameters.

Parameter Value

Geometry > Shape Select Cylinder

Geometry > Radius Enter PegR. Select units of cm.
Geometry > Length Enter 2*T.

Inertia > Density Enter Rho.

Graphic > Color Enter PegRGB.

5 In the To Peg block dialog box, specify these parameters.
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Parameter Value

Translation > Method Select Standard Axis.
Translation > Axis Select +Z.

Translation > Offset Enter 3/2*T. Select units of cm.

6 In the To World block dialog box, specify these parameters.

Parameter Value

Rotation > Method Select Standard Axis.
Rotation > Axis Select Y.

Rotation > Angle Enter 90.

Generate Subsystem

You can now generate a subsystem to encapsulate the pivot mount block
diagram. The subsystem mask provides a convenient place to initialize the
MATLAB variables that you defined the block parameters with. To generate
the subsystem:

1 Select all the blocks excluding Solver Configuration.

2 Press Ctrl+G to enclose the blocks in a subsystem. Name the subsystem
block Pivot Mount.

fixy=0 p————F]Conni  Conn2 [£]

Sohver
Configuration

Pivot Mount

3 Select the Pivot Mount block and create a subsystem mask, e.g., by
pressing Ctrl+M.
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4 In the Parameters & Dialog tab of the Mask Editor, drag six edit boxes

into the Parameters group and specify their properties. Click OK.

Prompt Name
Hexagon Outer Radius HexagonR
Hexagon Thickness T

Mass Density Rho
Hexagon Color HexagonRGB
Peg Radius PegR

Peg Color PegRGB

5 In the Pivot Mount block dialog box, specify these parameters.

Parameter Value
Hexagon Outer Radius (m): 4

Hexagon Thickness (m): 0.8

Mass Density (kg/m*3): 2700

Hexagon Color [R G B]: [0.25 0.4 0.7]
Peg Radius (m): 0.4

Peg Color [R G B]: [1 0.6 0.25]

Visualize Model

Update the block diagram. You can do this by pressing Ctrl+D. Mechanics
Explorer opens with a 3-D static display of the pivot mount rigid body.
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Related
Examples

Concepts

Open Reference Model

To view a completed version of the pivot mount model, at the MATLAB
command prompt enter smdoc_pivot_mount.

“Represent Binary Link Frame Tree” on page 1-36
“Model Binary Link” on page 2-53

“Representing Frames” on page 1-7
“Cross-Section Coordinates” on page 2-12
“Specifying Solid Inertia” on page 2-18
“Solid Color” on page 2-26
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e “Joints” on page 3-2

® “Gear Constraints” on page 3-9

* “Viewing Model Information in Model Report” on page 3-18

® “Open Model Report” on page 3-21

* “View Cardan Gear Assembly Status and Statistics” on page 3-22
¢ “Model Double Pendulum” on page 3-26

e “Model Four Bar” on page 3-31

¢ “Find and Fix Aiming-Mechanism Assembly Errors” on page 3-40
e “Model Rack and Pinion” on page 3-50

¢ “Model Planetary Gear Train” on page 3-61

® “Model Planetary Orbit Due to Gravity” on page 3-77
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3-2

Joints

In this section...

“Frames” on page 3-3
“Primitives” on page 3-3
“Joint Primitive Composition” on page 3-5

“Joint Assembly” on page 3-6

“Guiding Joint Assembly” on page 3-7

Joints constrain the mechanical degrees of freedom between two connecting
rigid bodies. The primary purpose of joints is to limit motion of a mechanism
or machine so an end effector can move along a specified path. Rigid bodies
can contain the following degrees of freedom:

¢ Translational — linear displacement of one rigid body frame relative to
another along a common axis.

¢ Rotational — angular displacement of one rigid body frame relative to
another about a common axis

A free rigid body contains exactly six degrees of freedom: three rotational and
three translational. The free rigid body can translate along any combination
of three mutually orthogonal axes, and rotate about any combination of the
same axes. When you connect two rigid bodies with a joint, you remove
degrees of freedom between the two. Depending on the joint, you can remove
anywhere from zero-six degrees of freedom. A joint that removes all six
degrees of freedom is called Weld joint.

Note The Rigid Transform block is similar to the Weld Joint block. Both
blocks remove all six mechanical degrees of freedom between the two
connecting rigid bodies. However, the Rigid Transform block also allows you
to maintain a specified distance and angle between the two rigid bodies.
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Frames

The joint block contains two frame ports, B and F. The ports identify the base
and follower frames of a joint, respectively. You connect the base frame port
to one frame on one rigid body, and the follower frame port to another frame
on a second rigid body. Switching the base and follower frames of a joint block
has no effect on model assembly or simulation.

During simulation, joint blocks apply a time-varying transformation to the
follower frame with respect to the base frame. The transformation depends on
dynamic inputs (forces and torques) and the kinematic configuration of the
model. Transformation components include rotation and translation about or
along the joint primitive axes.

Primitives

Each joint block contains a combination of joint primitives — elementary joint
constructs that make up more advanced joints. The joint primitives represent
the simplest joints you can find in SimMechanics. Three joint primitives
exist: prismatic, revolute, and spherical. The following three sections briefly
describe each primitive. The final section lists the primitives that make up
each joint block.

Prismatic

Joint primitive with one translational degree of freedom. The prismatic
primitive allows the joint base and follower frames to translate relative to
each other along a common axis. Joints with two prismatic primitives allow
translation in a 2-D plane that contains the prismatic axes. Joints with three
prismatic primitives allow translation in 3-D space.

The following figure shows a schematic of the prismatic joint primitive.
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3-4

Revolute

Joint primitive with one rotational degree of freedom. The revolute primitive
allows the joint base and follower frames to rotate relative to each other about
a common axis. Joints with three revolute primitives allow rotation in 3-D
space. The frames must each connect to a non-degenerate mass. The following
figure shows a schematic of the revolute joint primitive.

Spherical

Joint primitive with three rotational degrees of freedom. The spherical joint
allows the joint base and follower frames to rotate about three mutually
orthogonal axes.

The Spherical primitive is not a serial combination of revolute primitives.
Such a combination is susceptible to Gimbal lock — an event in which two
revolute axes align, resulting in the loss of one rotational degree of freedom.



Joints

The Spherical primitive is not susceptible to Gimbal lock at any time. The
following figure shows a schematic of the spherical joint primitive.

Joint Primitive Composition

Joint primitives are the basic elements of joint blocks. Each joint block can
contain multiple joint primitives. The number and type of joint primitives

that a joint block contains defines the degrees of freedom that joint provides.

The table summarizes the joint primitives and degrees of freedom (DOF) for
each joint block.

Joint Degrees of Freedom Joint Primitives
Block | Rotation | Translation Prismatic | Revolute Spherical
6-DOF 3 3 3 0 1
Joint
Bearing 3 1 1 3 0
Joint
Bushing 3 3 3 3 0
Joint
Cartesian | O 3 3 0 0
Joint
Cylindrical | 1 1 1 1 0
Joint
Pin Slot 1 1 1 1 0
Joint
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Joint Degrees of Freedom Joint Primitives
Block | Rotation | Translation Prismatic | Revolute Spherical
Gimbal 3 0 0 3 0
Joint
Planar 1 2 2 1 0
Joint
Prismatic | O 1 1 0 0
Joint
Rectangular O 2 2 0 0
Joint
Revolute 1 0 1 0 0
Joint
Spherical | 3 0 0 0 1
Joint
Telescoping| 3 1 1 0 1
Joint
Universal | 2 0 0 2 0
Joint
Weld Joint | O 0 0 0 0

Joint Assembly

During assembly, joint blocks position and orients base and follower frames
according to rules that depend on the joint type. The table summarizes the

position and orientation constraints that each joint primitive imposes on the
base and follower frames of a joint.
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Joint primitive Constraint

Prismatic ¢ Aligns base and follower frame
prismatic axes. For example, the
7 Prismatic Primitive aligns the
7 axes of the base and follower
frames.

¢ Holds the remaining base and
follower frame axes parallel to
each other. For example, the Z
Prismatic Primitive keeps the
base and follower frame X and Y
axes parallel to each other.

Revolute ® Aligns base and follower frame
revolute axes. For example, the
Z Revolute Primitive aligns the
7 axes of the base and follower
frames.

* Holds base and follower frame
origins coincident.

Spherical e Holds base and follower frame
origins coincident.

Guiding Joint Assembly

Each joint primitive provides the option to specify a state target: the desired
initial state for that joint primitive. You can specify state targets for the
position and velocity of the joint primitive, both of which can be either
rotational (for revolute and spherical joint primitives), or translational (for
prismatic joint primitives). The value of the state target represents the
relative state of the follower port frame with reference to the base port frame.
For example, when you enter a value for the velocity state target of a joint
block, you specify the velocity of the follower port frame relative to the base
port frame.

It is not always possible to set the initial state of a joint to the specified state

target. This is especially true of closed loops containing state targets specified
for multiple joints. However, during assembly, SimMechanics attempts to
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Related
Examples

Concepts

satisfy as many state targets as possible, and with a maximum level of
precision. In the event that all state targets cannot be met, SimMechanics
prioritizes state targets according to the priority level you specify. Joints with
a priority level of High (desired) assemble earlier, followed by joints with a
priority level of Low (approximate).

In the event that it is not possible to set all state targets to their exact values,
SimMechanics relaxes the low-priority state targets, and searches for the
best-fit approximate values that still allow assembly. Should assembly still
fail, SimMechanics begins to relax high-priority state targets, searching

for the nearest approximate values that allow for successful assembly. If
assembly fails, check that the model is kinematically valid. Check also that
closed-loop systems do not contain state targets for every joint in the loop,
which by default causes an assembly error.

¢ “Model Double Pendulum” on page 3-26
¢ “Model Four Bar” on page 3-31
¢ “Find and Fix Aiming-Mechanism Assembly Errors” on page 3-40

* “Viewing Model Information in Model Report” on page 3-18
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Gear Constraints

In this section...

“Gear Types” on page 3-9

“Featured Examples” on page 3-10

“Inertia, Geometry, and Efficiency” on page 3-10

“Using Gear Blocks” on page 3-11

“Assembling Rigid Bodies with Gear Constraints” on page 3-12
“Common Gear Assembly and Simulation” on page 3-13

“Rack and Pinion Assembly and Simulation” on page 3-16

You can represent gear constraints in a multibody model. To do this,
SimMechanics provides a Gears and Couplings library. This library contains
gear blocks that you can use to constrain the motion of two rigid body frames.
The figure shows the gear blocks that the library provides.

.
e al e af . Je
- &

Bewel Gear Common Gear Radk and Pinicn
Constraint Constraint Constraint

Gear Types

The Gears and Couplings > Gears library provides blocks for modeling
gears. The table summarizes the gears you can model with these blocks.
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Block Description

Common Gear Constraint Transfer rotational motion between
two frames spinning about parallel
axes

Rack and Pinion Constraint Transfer rotational motion at a

pinion into translational motion at a
rack and vice-versa.

Bevel Gear Constraint Transfer rotational motion between
two frames spinning about
arbitrarily aligned axes.

Featured Examples

SimMechanics provides two featured examples that highlight the use of gear
blocks. The table lists these examples. To open an example model, at the
MATLAB command line, enter the model name, e.g., sm_cardan_gear.

Featured Example Model Name Gear Blocks Used

Cardan gear sm_cardan_gear Common Gear
Constraint

Windshield wiper sm_windshield wiper | Rack and Pinion
Constraint

Robotic wrist sm_robotic_wrist Bevel Gear Constraint

Open the models and examine the blocks for examples of how to connect the
gear blocks and specify their parameters.

Inertia, Geometry, and Efficiency

Each gear block represents a kinematic constraint between two rigid body
frames. This constraint does not account for the effects of inertia or power
transmission losses. It also does not provide gear visualization. If necessary,
consider modeling these effects using other SimMechanics and Simscape
blocks. To represent gear inertia and geometry, use the Solid block.
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Using Gear Blocks

To apply a gear constraint between two rigid bodies, connect the base and
follower frames of the gear block to the rigid body frames that you want
to constrain. Then, open the gear block dialog box and specify the gear
parameters. Parameters can include gear dimensions and ratio.

Featured example sm_cardan_gear illustrates an application of the Common
Gear block. In this model, two Common Gear blocks connect three gear
rigid bodies. Subsystems Planet Gear A, Planet B and Link, and Sun Gear
represent these rigid bodies. One Common Gear block constrains the motion
of subsystem Planet Gear A with respect to subsystem Sun Gear. The other
Common Gear block constrains the motion of subsystem Planet B and Link
with respect to subsystem Planet Gear A. The figure shows the block diagram
of this model.

Solver
Configuration

Sun Joint

v'}

S W

]

‘World Frame

o

Mechanism
Configuration

Sun

Using the Common Gear Block - Cardan G ear Mechanism

This example shows the Cardan Gear mechanis m that conver s rotational motion into reciprocating
linear maotion without using linkages or slidewsys. The machanism uses three gears - onesun and
two planet gears. The sun gear is twice a5 large as the planet gears [which are of the samesize).
The red pointer on the link treces a streight line as the gears rotate.

So that the three gear subsystems can rotate with respect to each other,
the model includes three Revolute Joint blocks. Each Revolute Joint block
provides one rotational degree of freedom between one gear subsystem and
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the gear carrier—a rigid body that holds the three rotating gears. The figure
shows the Mechanics Explorer display of this model.

Assembling Rigid Bodies with Gear Constraints

To assemble successfully, a model must satisfy the constraints that a gear
block imposes. These include distance and orientation constraints that are
specific to each block. The table summarize these constraints.

Gear Constraint Description

Frame Distance The model must maintain a fixed
distance between the base and
follower gear frames. The value of
this distance depends on the gear
block that you use.

Frame Orientation The model must orient the base and
follower gear frames according to
rules that are specific to each block.
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The rigid body frames that the gear block connects must have the proper
number and type of degrees of freedom. For a Common Gear block, the frames
must have two rotational degrees of freedom with respect to each other. For
a Rack and Pinion block, the frames must have one translational and one
rotational degree of freedom with respect to each other. You provide these
degrees of freedom using joint blocks.

e Use joint blocks with revolute primitives to provide the rotational degrees
of freedom.

e Use joint blocks with prismatic primitives to provide the translational
degrees of freedom.

Common Gear Assembly and Simulation

During assembly, the Common Gear block requires that the base and follower
frame Z axes align. These are the rotation axes of the two gear frames.
Failure to align the Z axes of the two gear frames results in assembly failure
during model update. The figure illustrates the common gear rigid bodies,
frames, and distance constraints.

H_

d - Canter-fo-canter distanca ® X Axis
R_B - Base gear pitch circle ® Y Axis
F_F - Foliower gear pitch circle ® 7 Axis

Connect the gear rigid bodies to joints possessing one (or more) revolute joint
primitives. The rotational axis of the revolute primitive must align with the Z
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axis of the gear frame that it connects to. This ensures that the gear frames
possess a rotational degree of freedom about the correct axis (Z).

Common Gear Types

With the Common Gear block, you can represent internal and external gear
constraints. If the gear constraint is internal, the gear frames rotate in the
same direction. If it is external, the gear frames rotate in opposite directions.
The figure illustrates the two common gear types that you can represent and
their relative rotation senses.

Gear Dimensions

In the block dialog box, you specify the gear dimensions. Depending on the
specification method that you choose, you can specify the center-to-center
distance between gears or the pitch circle radii. During model assembly, the
Common Gear block imposes this distance constraint between the two gear
frames. This ensures that the gear assembles properly or, if issues arise, that
you can correct any assembly issues early on.

You specify the gear relative sizes in the block dialog box. If you select the
Center Distance and Ratio specification method, the gear ratio specifies
which of the two gears is the larger one. If the gear ratio is greater than one,
the follower gear is the larger gear. If the gear ratio is smaller than one, the
base gear is the larger gear.



Gear Constraints

If you specify an internal gear type, the larger gear is the ring gear. A gear
ratio greater than unity makes the follower gear the ring gear. A gear ratio
smaller than unity makes the base gear the ring gear.

Gear Pitch Circles

The pitch circle of a gear is an imaginary circle that passes through the
contact point between gears. The pitch radius of a gear is the radius of this
imaginary circle. The figure illustrates the pitch circles of two meshing gears
and their pitch radii. These are the gear radii that you enter in the block
dialog box when you select the Pitch Circle Radii specification method.

Fitch Circle

d1 - First gear pilch radius d2 - Second gear pilch radius

Simulation

During simulation, the Common Gear block requires that the model maintain
the proper distance between gear frames. This distance must equal either the
center-to-center distance or the sum of base and follower gear pitch radii that
you specify in the block dialog box. The structure of the model must be such
that the gears maintain this distance between them. Failure to maintain this
distance results in an error during simulation.

In the Cardan Gear example, the Carrier rigid body fixes the distances
between the three gears. As long as these distances match the gear
dimensions that you specify in the block dialog box, the model should simulate
without an issue.
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Rack and Pinion Assembly and Simulation

The base frame of the Rack and Pinion block represents the pinion. It can
rotate about its Z axis. The follower frame of the same block represents the
rack. It can translate along its Z axis. During assembly, the Rack and Pinion
block requires that the base and follower frame Z axes be mutually orthogonal.

When the gear is in its zero configuration—a configuration in which the angle
and displacement between base and follower frames are taken as zero—the
follower frame Z axis is also parallel to the base frame X axis, and base and
follower frame Y axes are parallel to each other. The follower frame origin
lies along the base frame -Y axis, at a distance equal to the base gear pitch
radius. The figure illustrates these constraints.

'

d - Center-to-center Distance LI
R_B - Pinion Radius ® ¥ Axis
® 7 Axis

To ensure the rack and pinion can move with respect to each other, you must
connect the rack and pinion rigid bodies to joints blocks. The joint block on
the rack side must have one (or more) prismatic primitives. At least one
primitive axis must align with the Z axis of the follower gear frame. The joint
block on the pinion side must have one (or more) revolute primitives. At least
one revolute axis must align with the Z axis of the base gear frame.



Gear Constraints

Gear Pitch Circles

The pitch circle of a rack and pinion gear is the imaginary circle that passes
through the contact point between the pinion and the rack. The pitch radius
is the radius of this imaginary circle. The figure illustrates the pitch circle
for a rack and pinion. This is the circle whose radius you enter in the block
dialog box.

Simulation

During simulation, the Rack and Pinion block requires that the model
maintain the proper distance between gear frames. The distance between
the base frame origin (pinion) and the follower frame Z axis must equal the
pinion radius. Failure to maintain this distance between gear frames results
in a simulation error.
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Viewing Model Information in Model Report

In this section...

“Model Report Overview” on page 3-18
“Graphical User Interface” on page 3-18
“Assembly Status Icons” on page 3-19

“Simscape Statistics and Variable Viewer Utilities” on page 3-20

Model Report Overview

Model Report is a diagnostic utility that helps you to identify assembly issues
in a SimMechanics multibody model. This utility, accessible from Mechanics
Explorer upon model update, provides joint and constraint assembly data as
well as pertinent model statistics. If a model contains joint blocks with state
targets, Model Report identifies the discrepancy, if any, between the specified
and actual joint states.

Graphical User Interface

Model Report contains one header section and three tabs. The header
section identifies the overall assembly status of the model, its joints, and its
constraints using icons. The three tabs provide more focused information on
joint assembly, constraint assembly, and model statistics. The image shows
the Joints tab of Model Report for a double-pendulum model.
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o

+| Model Report - smdoc_double_pendulum

Assembly status: 0
Joints: Q
Constraints: o

Joints | Constraints | Statistics

Position Velocity
Joint Assemnbled Primitive

Actual Specified Unit Priomty Status Actual Specified Units Priority Status
Revolute_Joint o Rz +30 +30 deg  High o ] deg/s
Revolute_lointl o Rz -75 -75 deg  High Q -0 degs

E=SScR )

Assembly Status Icons

Model Report identifies the model, joint, and constraint assembly status using
three icon types. The table summarizes the meaning of each icon type.

Icon

Q

Meaning

Assembly successful. Used in the
joint position and velocity status
fields, this icon indicates that the
joint state targets have been met
precisely.

Assembly successful with issues.
Used in the joint position and
velocity status fields, this icon
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Icon Meaning

indicates that the joint state targets
have been met approximately.

@ Assembly failed. Used in the joint
position and velocity status fields,
this icon indicates that the joint
state targets have not been met.

Simscape Statistics and Variable Viewer Utilities

In addition to Model Report, you can access model statistics and assembly
status information using two Simscape utilities: Statistics Viewer and
Variable Viewer. Combined, these utilities provide the same information
content of Model Report, with additional data for 1-D model components
belonging to other physical domains—e.g., hydraulic, pneumatic, or electrical.
For more information about the Simscape viewers, see:

* “Variable Viewer”

* “Simscape Model Statistics”
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Open Model Report

You can open Model Report from Mechanics Explorer following model update.
To do this:

1 In the Simulink Editor menu bar, selectSimulation > Update Diagram.
Mechanics Explorer opens a static 3-D view of the model in its initial
configuration.

2 In the Mechanics Explorer menu bar, select Tools > Model Report. Model
Report opens with assembly data and model statistics.

[ d\ Mechanics Explorers - Mechanics Explorer-sm_cardan_gear - ]

Model Report
Animation Settings

Create Video
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View Cardan Gear Assembly Status and Statistics

In this section...

“Open Model Report” on page 3-22

“View Joint Assembly Status” on page 3-23
“View Constraint Assembly Status” on page 3-23
“View Model Statistics” on page 3-24

Open Model Report

To explore the Model Report interface, try opening one of the MATLAB
featured examples. At the MATLAB command prompt, enter the featured
example name, e.g.,

sm_cardan_gear

Then, update the block diagram (by selecting Simulation > Update
Diagram. Mechanics Explorer opens with a static 3-D view of the model
in its initial configuration.
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You can now open Model Report using the Mechanics Explorer menu bar. Do
this by selecting Tools > Model Report.

View Joint Assembly Status

In the Model Report header, three green circles indicate that the model,

its joints, and its constraints have assembled successfully. In the

Position > Status field of the Joints tab, an additional green circle indicates
that the position state target of the Planet_A_Joint has been successfully
met during model assembly.

ﬂ Model Report - sm_cardan_gear EI@
Assembly status: Q

Inints: Q

Constraints: Q

EJUiﬂtSE Constraintsl Statistics|

Position Velocity
Joint Assembled  Primitive
Actual Specified Unit Priority Status Actual Specified Units  Priority  Status
Planet_A_loint Q Rz +9 +9 deg  High Q +0 deg/s
Planet_B_leint @] Rz +0 deg +0 deg/s
Sun_loint O Rz +0 deg +0 deg/s

View Constraint Assembly Status

To view the assembly status of the gear constraint blocks, select the
Constraints tab. Two green circles indicate that two gear constraints,
PlanetA_PlanetB_Gear and Sun_PlanetA_Gear have also been successfully
assembled.
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ﬂ Model Report - sm_cardan_gear EI@
Assembly status: Q

Inints: Q

Constraints: Q

| Joints || Constraints || Statistics|

Constraint Assemnbled
PlanetA_PlanetB_Gear
Sun_Planetd_Gear

o0

View Model Statistics

Finally, to view various model statistics, select the Statistics tab. This tab
provides model data such as the number of rigid components (excluding
ground), the number of joints, and the number of constraints. The reported
numbers match the number of rigid body subsystem blocks (excluding one
connected to the world frame), the number of joint blocks, and the number of
gear constraint blocks—3, 3, and 2.



View Cardan Gear Assembly Status and Statistics

Mumber of rigidly connected components (excluding ground]
Mumber of joints (total)

Mumber of explicit tree joints

Mumber of implicit 6-DOF tree joints

Mumber of cut joints

Mumber of constraints

Mumber of tree degrees of freedom

Mumber of position constraint equations (total)

Mumber of pesition constraint equatiens (nen-redundant)
Mumber of mechanism degrees of freedem (minimum)
State vector size

Average kinematic leop length

Assembly status: Q
Joints: @
Constraints: @
Joints | Constraints| Statitics
Jype Value

mmm‘

[T
[
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Model Double Pendulum

In this section...

“Model Overview” on page 3-26

“Build Model” on page 3-27

“Guide Model Assembly” on page 3-28

“Visualize Model and Check Assembly Status” on page 3-29
“Simulate Model” on page 3-30

“Open Reference Model” on page 3-30

Model Overview

The double pendulum is a simple multibody system. It contains two links
and a pivot mount that connect with joints. This system is nonlinear and
does under certain conditions exhibit chaos. In this example, you assemble a
double pendulum using custom blocks for the links and the pivot mount. You
can later use this model to study the chaotic motion of a double pendulum.

To model the double pendulum, you represent each physical component
and constraint using a SimMechanics block. The double pendulum system
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contains three rigid bodies—one pivot mount and two binary links— that
connect 1n series through a pair of revolute joints. You represent the pivot
mount and the binary links using the custom library blocks that you created
in previous examples. You represent the two joints using two Revolute Joint
blocks from the Joints library.

You can guide model assembly. By specifying joint state targets, you can
instruct SimMechanics to assemble a joint in the configuration you want.
State targets that you can specify include position and velocity. At times,

a state target may conflict with other state targets, or even with other
kinematic constraints in the model. In these cases, you can prioritize the
most important state targets by assigning them a high priority level. During
assembly, if two targets conflict with each other, SimMechanics assembles
the high priority target first. To specify both state target values and priority
levels, you use the State Targets menu of the joint block dialog boxes.

Build Model

1 Start a new model.

2 Drag these blocks into the model. The two Revolute Joint blocks provide
the double pendulum two rotational degrees of freedom.

Library Block Quantity
Simscape > Utilities | Solver Configuration 1
SimMechanics > Secondechanism 1

Generation > Utilities Configuration

SimMechanics > Secon®orld Frame 1
Generation > Frames
and Transforms

SimMechanics > Seconldlevolute Joint 2
Generation > Joints

3 At the MATLAB command prompt, enter smdoc_compound_rigid_bodies.
A custom block library with the same name opens up.
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4 Drag these custom blocks into the model. Each block represents a rigid
body in the double pendulum. See the tutorials in the table for detailed
instructions on how to create the blocks.

Block Quantity Modeling Tutorial

Pivot Mount 1 “Model Pivot Mount”
on page 2-67

Binary Link A 2 “Model Binary Link”
on page 2-53

5 Connect the blocks as shown in the figure.

Mechanism [ |
Configuration "%

~ w3 Conni1 ConnZ [H——H]B j,lL [4—+F] Connt ConnZ [H—] B }E—El Connl ConnZ [H]
L & &
Revolute Joint Revolute Joint1
Pivot Mount Binary Link &

Waorld Frame

Binary Link A1

=0

Soblver
Configuration

Guide Model Assembly

1 In the Revolute Joint block dialog boxes, select State Targets > Specify
Position Target. You can now specify the desired starting positions
of the two joints.

2 In Value, enter these joint angles.
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Revolute Joint 30
Revolute Joint1 -75

Visualize Model and Check Assembly Status

To visualize the model, update the block diagram. You can do this from the
menu bar by selecting Simulation > Update Diagram. Mechanics Explorer
opens with a 3-D view of the double pendulum assembly. Click the isometric
view button to obtain the perspective in the figure.

To check the assembly status of the revolute joints, use the Model Report
utility. You can open this utility from the Mechanics Explorer menu bar by
selecting Tools > Model Report. The figure shows the assembly information
for the double pendulum.

3-29



3 Multibody Systems

ﬂ Model Report - double_pendulum_moedel EI@
Assembly status: @]

Joints: Q

Constraints: Q

EJDi"tSE Constraintsl Statisticsl

Position Velocity
loint Asze..  Primit..

Actual  Specif.. Unit Priority ~ Status  Actual  Specif.. Units Priority  Status
Revaolute_Joint Q Rz +30 +30 deg High Q +0 deg/s
Revaolute Jointl Q Rz -75 -75 deg High Q +0 deg/s

Simulate Model

Run the simulation, e.g., by selecting Simulation > Run. Mechanics
Explorer shows a 3-D animation of the double pendulum assembly. The

assembly moves due to gravity, specified in the Mechanism Configuration
block.

Open Reference Model

To see a complete model of the double pendulum assembly, at the MATLAB
command prompt enter:

® smdoc_double_pendulum
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Model Four Bar

In this section...

“Model Overview” on page 3-31

“Modeling Approach” on page 3-32

“Build Model” on page 3-32

“Specify Block Parameters” on page 3-35

“Guide Assembly and Visualize Model” on page 3-36
“Simulate Model” on page 3-39

“Open Reference Model” on page 3-39

Model Overview

The four-bar linkage is a planar closed-loop linkage used extensively in
mechanical machinery. This linkage has four coplanar bars that connect
end-to-end with four revolute joints. In this example, you model a four-bar
linkage using the Binary Link and Pivot Mount custom blocks that you created
in previous examples. For an advanced application of the four-bar linkage,
see the bucket actuating mechanism of the Backhoe featured example.
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Modeling Approach

To model the four-bar linkage, you represent each physical component with a
SimMechanics block. The linkage in this example has five rigid bodies—three
binary links and two pivot mounts—that connect in a closed loop through
four revolute joints. Two of the binary links have one peg and one hole. The
third binary link has two holes. The fourth link is implicit: the fixed distance
between the two coplanar pivot mounts represents this link.

You represent the binary links and pivot mounts using the custom library
blocks that you created in previous examples. You represent the four revolute
joints using four Revolute Joint blocks from the SimMechanics Joints library.

The two pivot mounts connect rigidly to the world frame. For this reason, the
implicit link acts as the ground link. Two Rigid Transform blocks provide
the rigid connection between the two pivot mounts and the World frame.

A translation offset in each Rigid Transform block displaces the two pivot
mounts symmetrically along the world frame Y axis.

-Li2 L2
[ I |

e o

To guide model assembly, you can specify the desired initial state for one or
more joints in the model. To do this, you use the State Targets menu of the
joint blocks. The state targets that you can specify are the joint position and
velocity. These are angular quantities in revolute joints. You can specify state
targets for all but one of the joints in a closed loop.

Build Model

To model the four-bar linkage:

1 Start a new model.



Model Four Bar

2 Drag these blocks to the model. The Rigid Transform blocks specify the
distance between the two pivot mounts. This distance is the length of the

implicit ground link.

Library Block Quantity
Simscape > Utilities | Solver Configuration 1
SimMechanics > Secondechanism 1
Generation > Utilities Configuration

SimMechanics > SeconWorld Frame 1
Generation > Frames

and Transforms

SimMechanics > Seconldigid Transform 2

Generation > Frames

and Transforms

3 Connect and name the blocks as shown in the figure. The base frame ports
of the Rigid Transform blocks must connect to World Frame block.

Mechanis m

" : Sohver
Configur ation Configur ation
—
2 fix) = 0
B
[] []
B 753 5 /@
J )=
Crank-Base Rocker-Base
Transform Transform
2l
=
o World Frame
brrrd

4 From the SimMechanics > Second Generation > Joints library, drag
four Revolute Joint blocks into the model.
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5 At the MATLAB command prompt, enter smdoc_compound_rigid bodies.
A custom library with compound rigid body blocks opens up.

6 From the smdoc_compound_rigid_bodies library, drag these blocks. Each
block represents a rigid body present in the four bar assembly. See the
tutorials in the table for instructions on how to create the blocks.

Block Quantity Modeling Tutorial

Pivot Mount 2 “Model Pivot Mount”
on page 2-67

Binary Link A 2 “Model Binary Link”
on page 2-53

Binary Link B 1 “Model Two-Hole

Binary Link” on page
2-61

7 Connect and name the blocks as shown in the figure. You must position the
frame ports of the custom rigid body blocks exactly as shown.



Model Four Bar

2| Conni ConnZ [

|

™ Binary Link B ™
[ | crank-Coupler Coupler-Roder /
/| Revolute Joint Revolute Joint s
E ji
o ('}
c [ =
= =
a a
— Binary Link A Binary Link A1 —
E E
o (=]
[ [
Ll
E Mechanism Soher
|’ Configuration : ; L
/ | Basecrank !_E" Configur aticn BaseRoder /
/ | Revolute Joint > Revolute Joint J
P W c[H fix)=0 P
[ .
[] [l
.-"'{ .-"J‘
L[l ConnZ Connd |5 R /B[S 5 </ 5[3—F]Conni ConnZ
e P
Crank-Base Rocker-Base
Pivot Mount Transform Transform Pivot Mournt1
[
=
o World Frame
e

Specify Block Parameters

1 In the Rigid Transform block dialog boxes, specify the offset between the
pivot mounts and the world frame.
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Parameter Crank-Base Rocker-Base
Transform Transform

Translation > Method Standard Axis Standard Axis

Translation > Axis -Y +Y

Translation > Offset | 15 in units of cm 15 in units of cm

2 In each binary link block dialog box, specify the length parameter.

Block Length (cm)
Binary Link A 10
Binary Link B 35
Binary Link Al 20

Guide Assembly and Visualize Model

The model is now complete. You can now specify the desired initial state for
one or more joints in the model. In this example, you specify an initial angle
of 30° for the Base-Crank joint. To do this:

1 Double-click the Base-Crank Revolute Joint block.

2 In the block dialog box, expand State Targets and select Position.

3 In Value, enter -30 and press OK.

4 In the menu bar, select Simulation > Update Diagram

Mechanics Explorer opens with a static display of the four-bar linkage in
its initial configuration. If the joint state targets that you specified are
valid and compatible, the initial configuration matches those state targets.
The figure shows the static display that you see in Mechanics Explorer

after updating the model.



Model Four Bar

You can guide assembly so that the four-bar linkage assembles in an open
configuration instead. To do this, you must specify a position state target
for at least one more joint. You do not have to specify this target precisely.
If you have a general idea of what the target should be, you can enter an
approximate value and select a low priority level for that target. The figure
shows the open initial configuration that results when you add a position
state target of 0 degrees at the Base-Rocker Revolute Joint block.
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Closed-loop kinematic chains like the four-bar linkage are especially
vulnerable to assembly issues. Even when the model assembles,
SimMechanics may fail to meet one or more state targets. You can check the
assembly status of the model and of the joints using the Model Report utility:

1 In the Mechanics Explorer menu bar, select Tools > Model Report.

2 Examine the model report for red squares or yellow triangles. These shapes
identify issues in the assembly or in the joint state targets.

The figure shows the model report for the four bar linkage in the open
configuration. A green circle indicates that SimMechanics satisfied the
Base-Crank Revolute Joint state target precisely. A yellow circle indicates
that SimMechanics satisfied the Base-Rocker Revolute Joint state target
approximately.
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ﬂ Model Report - four_bar EI@
Assembly status:
loints:
Constraints:
EJUin'ﬁSE Constraints I Statistics|
Pasition Welocity
laint Assemnbled  Primitive
Actual Specified  Unit Priority Status Actual Specified  Units Priority Status
Base_Cran... O Rz -30 -30 deg High O +0 deg/s
Base_Rack... @] Rz -5.33164 +0 deg Lo i +0 degfs
Connecto,., o Rz +103.423 deg +0 degfs
Crank_Co... O Rz -78.7548 deg +0 deg/s

El
=

Simulate Model

Run the simulation, e.g., by selecting Simulation > Run. Mechanics
Explorer shows a 3-D animation of the four bar assembly. The assembly
moves due to gravity, specified in the Mechanism Configuration block.

Open Reference Model
To see a complete model of the double pendulum assembly, at the MATLAB

command prompt enter:

e smdoc_four_bar
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Find and Fix Aiming-Mechanism Assembly Errors

In this section...

“Model Overview” on page 3-40

“Explore Model” on page 3-41

“Update Model” on page 3-44

“Troubleshoot Assembly Error” on page 3-44
“Correct Assembly Error” on page 3-47
“Simulate Model” on page 3-47

“Save Model” on page 3-49

Model Overview

In closed-loop systems, joints and constraints must be mutually compatible.
For example, in a four-bar linkage, all revolute joints must spin about parallel
axes. If one of the joints spins about a different axis, assembly fails and the
model does not simulate.

To simplify the troubleshooting process, SimMechanics provides Model
Report. This tool helps you pinpoint the joints and constraints that caused
assembly to fail. Once you identify these joints and constraints, you can then
determine which of their frames to correct—and how to correct them.

In this example, you identify the assembly error source in an aiming
mechanism model using Model Report. Then, using Mechanics

Explorer, you determine how to correct that error source. The
sm_dcrankaim_assembly with_error featured example provides the basis
for this example.
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Explore Model

To open the model, at the MATLAB command line, enter
sm_dcrankaim_assembly with_error. The model opens in a new window.

The figure shows a schematic of the system that the model represents. This
system contains four rigid bodies, labeled A-D. These rigid bodies connect in a
closed loop via four joints, labeled Ri, Ro, Rg, and Pg. When connected to each
other, these components form a system with one degree of freedom.
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The model represents the components of this system using blocks. Each block
represents a physical component. A World Frame block provides the ultimate
reference frame in the model. The figure shows the block diagram that the
model uses to represent the double-crank aiming mechanism.
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Rg
Rigid Body A Rigid Body C
Mechanism Assembly
This model shows the sssembly ot the mechamsm trom the individusl rigid bodies . Joints .
“’{ are Lsed to establish relations hips between the frames attached to the rigid bodies. Rigid Body B
@) JRo
P Rigid Body D
: & }
= B &
gd -
World
Frame
Soler fix) = 0

Schematic of Full Mechansm

To represent the rigid bodies, the model contains four subsystem blocks,
labeled Rigid Body A-D. Each subsystem contains one Solid block and
multiple Rigid Transform blocks. The Solid block provides geometry, inertia,
and color to the rigid body subsystem. The Rigid Transform blocks provide
the frames that you connect the joints to. A Reference Frame block identifies
the ultimate reference frame in the subsystem block.

The model labels the rigid body subsystem blocks Rigid Body A-D. To examine
the block diagram for a rigid body subsystem, right-click the subsystem block
and select Mask > Look Under Mask. The figure shows the block diagram
for Rigid Body A.
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Feference Frame

Fad 3 /h] |-__L Eli_ IA:: Fac
ﬂ i

Hole Frame Slide Frame
Components that make up rigid body A

"

Transform Transform

To represent the joints, the model contains four joint blocks. Three joints
provide one rotational degree of freedom between a pair of rigid bodies. You
represent each of these joints with a Revolute Joint block. A fourth joint
provides one translational degree of freedom between a pair of rigid bodies.
You represent this joint with a Prismatic Joint block. The model labels the
revolute joint blocks Ro, Rg, and Ri, and the prismatic joint block Pg.

Update Model

As the model name suggests, this model contains an error. The error prevents
the model from assembling successfully, which causes simulation to fail. To
update the model and investigate the assembly error:

¢ On the Simulink menu bar, select Simulation > Update Diagram.

Mechanics Explorer opens with a static display of your model in its initial
state. Because the model contains an assembly error, SimMechanics issues
an error message. Ignore that message for now.

Troubleshoot Assembly Error

Mechanics Explorer provides access to Model Report, a SimMechanics utility
that summarizes the assembly status of each joint and constraint in a model.
Open this utility to determine which joint has failed to assemble. To do this,
in the Mechanics Explorer menu bar, select Tools > Model Report.
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Model Report opens in a new window. A red square indicates that the model,
as expected, has failed to assemble. A second red square indicates that an
unassembled joint, Pg, is the only contributing factor in the model assembly
error. This information enables you to concentrate your troubleshooting
efforts on a small block diagram region—that surrounding the Pg joint block.

ﬂ Model Report - sm_dcrankaim_assembly_with_error EI@
Assembly status: @ Unassembled

Joints: @ Unable to asserble all Joints

Constraints: O

eints ! Constraintsl Statistics|

Position Position Velocity
Joint Assernbled  Primitive
Actual Specified  Unit Pricrity Status Actual Specified  Units Pricrity Status
Pg a Pz MN/A m N/A m/s
Rg @] Rz -0.00442103 deg +0 deg/s
Ri @] Rz +0.00773987 deg +0 deg/s
Re @] Rz +0.00331709 deg +0 deg/s

Identifying Error Root Cause

The error message that SimMechanics issued during model update identifies
position violation as the root cause of assembly failure. This suggests that
the frames connected by joint Pg are improperly aligned. To confirm this
hypothesis, check the orientation of these frames in Mechanics Explorer.

1 In the Mechanics Explorer tree pane, select Pg.
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4 emn_dcrankaim_assernbly_with_emor
- Pigid Body A

H-"5 Rigid_Body_B

H-"g Rigid_Body C

H-"5 Rigid_Body D

il Mech anism_Configuration
8-k World_Frame

o4 A

H- 4 Rg

- Ri

H- 2 Ro

il Connection Frames

2 In the Mechanics Explorer visualization pane, examine the position and
orientation of the highlighted frames. These are the frames that appear in
a light turquoise blue color.

The two frames are offset along the Z axis. This offset is valid, since joint
Pg contains a prismatic primitive aligned with the Z axis, providing the
frames with one translational degree of freedom along that axis. However,
the two frames are also rotated with respect to each other about the common
7 axis. This offset is invalid, since joint Pg contains no Revolute or Spherical
primitives, and hence no rotational degrees of freedom about any axis. To
correct the model assembly error, you must rotate either of the two frames
so that all of their axes are parallel to each other.
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Correct Assembly Error

In this example, you apply a rotation transform to the follower frame so that
its axes lie parallel to the base frame axes. Alternatively, you could apply an
equivalent rotation transform to the base frame. This step enables joint Pg,
and hence the model itself, to assemble successfully.

1 Right-click the Rigid Body C subsystem block and select Mask > Look
Under Mask.

2 Double-click the Slide Frame Transform block and select the new
parameter values that the table provides.

Parameter New Value
Rotation > Pair 2 > Follower +X
Rotation > Pair 2 > Base +Y

3 Click OK.

Simulate Model

You can now simulate the model. On the Simulink menu bar, select
Simulation > Run. Mechanics Explorer opens with a 3-D animation of your
model. The figure shows a snapshot of the animation. Rotate, pan, and

zoom to explore.
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You can use the Model Report tool to verify the assembly status. To do
this, in the Mechanics Explorer menu bar, select Tools > Model Report.
In Model Report, check that the assembly status icons for the model and

its joints are green circles. The green circles indicate that the model has
assembled correctly.
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ﬂ Model Report - sm_dcrankaim_assembly_with_error EI@
Assembly status: Q

Joints: Q

Constraints: O

‘Joints! Constraintsl Statistics|

Position Position Velocity
Joint Assernbled  Primitive
Actual Specified  Unit Pricrity Status Actual Specified  Units Pricrity Status
Pg O Pz +0.3 m +0 m/s
Rg @] Rz +0 deg +0 deg/s
Ri o Rz +0 deg +0 deg/s
Ro O Rz +0 deg +0 deg/s

Save Model

Save the model as aiming_mechanism in a convenient folder. In a subsequent
example, you prescribe a joint trajectory using this model.

Related e “Model Double Pendulum” on page 3-26
Examples “Model Four Bar” on page 3-31

Concepts ¢ “Viewing Model Information in Model Report” on page 3-18
e “Joints” on page 3-2
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Model Rack and Pinion

In this section...

“Model Overview” on page 3-50

“Model Pinion” on page 3-52

“Model Rack” on page 3-55

“Add Rack and Pinion Constraint” on page 3-57
“Actuate Model” on page 3-58

“Simulate Model” on page 3-60

“Open Complete Model” on page 3-60

Model Overview
In this tutorial, you model a kinematic constraint between rack and pinion
components. The constraint causes the two components to move in sync such
that a pinion rotation corresponds to a rack translation:

VF = a)B 'RB 5
where:
® V. is the rack translational velocity.

® wp is the pinion rotational velocity.

® Rjis the radius of the pinion pitch circle, an imaginary circle intersecting
the contact point between rack and pinion teeth.
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The model uses three key blocks:

e Solid — Specify rack and pinion geometry, inertia, and color

¢ Joint — Provide motion degrees of freedom to the rack and pinion
components. These degrees of freedom enable the rack to translate and the
pinion to rotate with respect to the world frame.

¢ Rack and Pinion Constraint — Constrain the motion of the rack and pinion
components so that they move in a meshed configuration.

The figure shows how these blocks connect in the model.

Rigid Rack and Pinion
Transform Consfraint

P v
Y &

gl T o

I
Joint

[

B

]

© ©

[#y}
=)
=

i "}}*3
|

Wiorld
Frame
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For simplicity, the rack has a brick shape and the pinion has a cylinder shape.
These shapes depend on several dimensions, shown in the figure. You specify
each dimension using a variable. After model assembly, you can add detail
to the component shapes. For example, you can specify an involute tooth
profile for the rack and pinion.

REack T = FPinion T

Pinion. R

Fack.H

Fack |

Rack and Pinion Dimensions

Model Pinion

1 Start a new model.

2 Add these blocks to the model.

Library Block

Simscape > Utilities Solver Configuration

SimMechanics > Second World Frame
Generation > Frames and
Transforms

SimMechanics > Second Mechanism Configuration
Generation > Utilities
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Library

Block

SimMechanics > Second
Generation > Joints

Revolute Joint

SimMechanics > Second

Generation > Body Elements

Solid

The Solid block specifies the component geometry, inertia, and color. The
joint block provides the component its motion degrees of freedom—in this
case, one rotational degree of freedom with respect to the world frame.

3 Connect and name the blocks as shown in the figure. Port frames joined by
a connection line are coincident in space.

flx)=10
Sohver
‘Configur ation
WL =
Waorld Frame Revolute
Joint
e
Mechanis m Configuration

Pinizn

4 In the Pinion block dialog box, specify geometry, inertia, and color.

Parameter

Enter or Select

Geometry > Shape

Cylinder

Geometry > Radius

Pinion.R, units of cm

Geometry > Length

Pinion.T, units of cm
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Inertia > Density Rho

Graphic > Visual Pinion.RGB
Properties > Color

5 In the model workspace, initialize the MATLAB variables you entered in
the block dialog boxes:

% Common Parameters
Rho = 2700; % Mass density of both rack and pinion components

% Pinion Parameters
Pinion.R = 10;

Pinion.T = 4;

Pinion.RGB = [0.8 0.4 0]

6 Update the block diagram. You can do this by selecting
Simulation > Update Diagram. Mechanics Explorer opens with a 3-D
view of the pinion gear. Examine the gear from different viewpoints and
verify it is accurate.
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Model Rack

1 Add these blocks to the model.

Library Block
SimMechanics > Second Rigid Transform
Generation > Frames and

Transforms

SimMechanics > Second Prismatic Joint

Generation > Joints

SimMechanics > Second Solid
Generation > Body Elements

The Rigid Transform block sets the rack position and pose with respect to
the pinion. These quantities must satisfy the assembly conditions later
imposed by the Rack and Pinion Constraint block.

2 Connect and name the blocks as shown in the figure.

Pris matic
Joint Radk
1 E\lF J4—-4o=F]7 '
'
fx)=0 2l
L [
Rigid| _-%
Trerlsfcfrn 1
Configur ation P
|
[ -] B ::; 4——H]= '
brrr il
Waorld Frame R evolute Pinion
Joint
@ cfa
B
Mechanis m Configuration
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3 In the Rack block dialog box, specify geometry, inertia, and color.

Parameter Select or Enter

Geometry > Shape Brick

Geometry > Dimensions [Rack.T Rack.H Rack.L], units of
cm

Inertia > Density Rho

Graphic > Visual Rack.RGB

Properties > Color

4 In the Rigid Transform block dialog box, specify the rack position and pose
with respect to the pinion.

Parameter Select or Enter
Rotation > Method Standard Axis
Rotation > Axis +Y

Rotation > Angle 90

Translation > Method Standard Axis
Translation > Axis -Y

Translation > Offset Pinion.R in units of cm

The rotation transform makes the rack and pinion Z axes mutually
orthogonal while keeping the Y axes parallel. The translation transform
separates the rack and pinion frame origins by a distance equal to the
pinion pitch radius. These transforms satisfy the assembly conditions
imposed by the Rack and Pinion Constraint block.

5 In the model workspace, initialize the new MATLAB variables entered in
the block dialog boxes:

% Rack Parameters

Rack.L = 80;

Rack.H = 2;

Rack.T = Pinion.T;
Rack.RGB = [0.2 0.4 0.7];
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6 Update the block diagram. Mechanics Explorer displays a 3-D view of the
rack and pinion assembly. Examine the assembly from different viewpoints
and verify it is accurate. You can view the rack and pinion frames by

clicking the frame button F in the Mechanics Explorer tool bar.

Add Rack and Pinion Constraint

The model is nearly complete. It remains to constrain the motion of the rack

and pinion components. You add this kinematic constraint using the Rack
and Pinion Constraint block.

1 From the Gears and Couplings > Gears library, drag a Rack and Pinion
Constraint block to the model.

2 Connect the block as shown in the figure. The follower frame port connects
to the Rack block, while the base frame port connects to the Pinion block.
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Mechanism Configuration

3 In the dialog box of the Rack and Pinion Constraint block, enter Pinion.R
in Pinion Radius. Select units of cm.

4 Update the block diagram. Mechanics Explorer shows a 3-D display of the
updated rack and pinion assembly. Assembly errors due to gear constraints
become evident at this stage. If SimMechanics issues an error message,
correct the model before attempting to run the simulation.

Actuate Model

1 In the Revolute Joint block dialog box, for Z Revolute Primitive
(Rz) > Actuation > Torque, select Provided by Input.

The block exposes a physical signal input port. You use this port to specify
a driving torque acting on the pinion. During simulation, this torque will
be the source of motion in the model.

2 Drag these blocks to specify and process the input torque signal.

Library Block
Simulink > Sources Signal Builder
Simscape > Utilities Simulink-PS Converter
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The Simulink-PS Converter block converts the Simulink input signal into
a physical signal compatible with SimMechanics blocks. It also provides
signal filtering, which enables you to smooth discontinuous signals.

3 In the Signal Builder block dialog box, draw the input signal as shown in
the figure. This signal starts with a positive torque followed by a negative
torque. The positive torque causes the pinion to rotate counterclockwise
about the base frame +Z axis and the rack to translate along the follower
frame +7 axis.

'I}.'DE 2 e e T e e e e N
| signalt_i i i i

) S S SN R A L S S
e e R R e
0 1 2 K 4 5 [ T 8 9 10

4 In the Simulink-PS Converter block dialog box, in the Input Handling
tab, specify second-order filtering with a time constant of 0.1 s. This filter
helps to smooth the discontinuities of the input signal.

Parameter Select or Enter
Filtering and derivatives Filter input

Input filtering order Second-order filtering
Input filtering time constant 0.1

(in seconds)
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Simulate Model

Run the simulation. You can do this by selecting Simulation > Run.
Mechanics Explorer plays a physics-based animation of the rack and pinion

assembly. To better see motion during playback, select the frame button =
in the Mechanics Explorer tool bar.

Open Complete Model

To view a complete model of the rack and pinion mechanism, at the MATLAB
command prompt enter:

smdoc_rack_pinion_c

For an example using a helper function to generate a rough involute tooth
profile, enter

smdoc_rack_pinion_d
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Model Planetary Gear Train

In this section...

“Model Overview” on page 3-61

“Model Sun-Planet Gear Set” on page 3-62
“Constrain Sun-Planet Gear Motion” on page 3-65
“Add Ring Gear” on page 3-67

“Add Gear Carrier” on page 3-70

“Add More Planet Gears” on page 3-75

Model Overview

Planetary gear trains are common in industrial, automotive, and aerospace
systems. A typical application is the automatic transmission system of car.
From a kinematic point of view, what sets this mechanism apart is the
kinematic constraint set between gear pairs. These constraints fix the angular
velocity ratios of the gear pairs, causing the gears in each pair to move in sync.

In SimMechanics, you represent the kinematic constraint between meshed
gears using blocks from the Gears sublibrary. This tutorial shows you how
to use these blocks to model a planetary gear train. The gear train contains
four rigid bodies:

® Sun gear

Planet gear

¢ Ring gear

Planet carrier

Each rigid body, including the planet carrier, can spin about its central axis.
In addition, each planet gear can revolve about the sun gear. Joint blocks
provide the required degrees of freedom, while gear constraint blocks ensure
the gears move as if they were meshed.
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Model Sun-Planet Gear Set

Model the gear rigid bodies and connect them with the proper degrees of
freedom. In a later step, you add gear constraints to this model.

1 Drag these blocks to a new model.

Library Block Quantity

Body Elements Solid 2

Joints Revolute Joint

Joints Planar Joint 1

Frames and Rigid Transform 1

Transforms

Frames and World Frame 1

Transforms

Utilities Mechanism 1
Configuration

Simscape > Utilities | Solver Configuration 1

2 Connect and name the blocks as shown.
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Planar Rigid
FPlanst Gear Joint Transform
[
- A
'E dreEE—Hl7 EE——
'} -

il
Sun Gear R evolute

Joint

fix) =

Sohver

‘Configur ation
ol 0]
= |werd |07 |Mechanism

1| Frame "~._.\“} Configur ation

3 In the Sun Gear block dialog box, specify these parameters.

Parameter Setting
Geometry > Shape Select General Extrusion.
Geometry > Cross-Section Enter

simmechanics.demohelpers.gear_profile(2*:
Select units of cm.
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Parameter Setting

Geometry > Length Enter T. Select units of cm.
Inertia > Density Enter Rho.

Graphic > Visual Enter Sun.RGB.
Properties > Color

The function simmechanics.demohelpers.gear_profile produces a rough
approximation of an involute gear profile.

4 In the Planet Gear block dialog box, specify these parameters.

Parameter Setting
Geometry > Shape Select General Extrusion.
Geometry > Cross-Section Enter

simmechanics.demohelpers.gear_profile(2*|
Select units of cm.

Geometry > Length Enter T. Select units of cm.
Inertia > Density Enter Rho.
Graphic > Visual Enter Planet.RGB.

Properties > Color

5 In the Rigid Transform block dialog box, specify these parameters.

Parameter Setting

Translation > Method Select Standard Axis.

Translation > Axis Select +Y.

Translation > Offset Enter Sun.R + Planet.R. Select
units of cm.

6 In the model workspace, define the block parameters using MATLAB code:

% Common Parameters
ho = 2700;

> -
1

3;
0.8; % Gear Addendum
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% Sun Gear Parameters
Sun.RGB = [0.75 0.75 0.75];
Sun.R = 15;

Sun.N = 40;

% Planet Gear Parameters
Planet.RGB = [0.65 0.65 0.65];
Planet.R = 7.5;

Planet.N = Planet.R/Sun.R*Sun.N;

7 Simulate the model. To induce motion, try adjusting the velocity state
targets in the joint block dialog boxes. Notice that the sun and planet gears
move independently of each other. To constrain gear motion, you must add
a gear constraint block between the gear solid blocks.

=
k.
b

You can open a copy of the resulting model. At the MATLAB command line,
enter smdoc_planetary_gear_a.

Constrain Sun-Planet Gear Motion

Specify the kinematic constraints acting between the sun and planet gears.
These constraints ensure that the gears move in a meshed fashion.

1 Drag these blocks to the sun-planet gear model.
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Library Block
Constraints Distance Constraint
Gears and Couplings > Gears Common Gear Constraint

2 Connect the blocks as shown. The new blocks are highlighted.

Planar Rigid
Planet Gear Joint Transform
R A
E |rede@—Fl7 Th[H
# I

|:_ EE

Common
L3 Distance

2]
T Constraint

Sun Gear Rewolute
Joint
flx)=10
Soher
Configuration
1 1
" g [ -_\I'H. )
L Waorld ] Mechanis m
’ rriy | Frame \"} Configuration

3 In the Common Gear Constraint block dialog box, specify these parameters.
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Parameter

Setting

Specification Method

Select Pitch Circle Radii.

Specification Method > Base
Gear Radius

Enter Sun.R. Select units of cm.

Specification
Method > Follower Gear
Radius

Enter Planet.R. Select units of cm.

4 In the Distance Constraint block dialog box, specify this parameter:

¢ Distance — Enter Sun.R + Planet.R. Select units of cm.

5 Simulate the model. To induce motion, try adjusting the velocity state
targets in the joint block dialog boxes. Notice that the sun and planet gears

now move in sync.

You can open a copy of the resulting model. At the MATLAB command line,

enter smdoc_planetary_gear_b.

Add Ring Gear

Model the ring gear rigid body, connect it with the proper degrees of freedom,
and constrain its motion with respect to the planet gear.

1 Add these blocks to the sun-planet gear model.

Library

Block

Body Elements

Solid

Joints

Revolute Joint

Gears and Couplings > Gears

Common Gear Constraint

2 Connect and name the blocks as shown. The new blocks are highlighted.
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3 In the Ring Gear block dialog box, specify these parameters.

Parameter Setting

Geometry > Shape Select General Extrusion.
Geometry > Cross-Section Enter Ring.CS. Select units of cm.
Geometry > Length Enter T.

Inertia > Density Enter Rho.

Graphic > Visual Enter Ring.RGB.

Properties > Color

4 In the Common Gear Constraintl block dialog box, specify these
parameters.

Parameter Setting

Type Select Internal.

Specification Method Select Pitch Circle Radii.
Specification Method > Base Enter Planet.R. Select units of cm.
Gear Radius

Specification Enter Ring.R. Select units of cm.
Method > Follower Gear

Radius

5 In the model workspace, define the Ring Gear block parameters using
MATLAB code:

% Ring Gear Parameters

Ring.RGB = [0.85 0.45 0];

Ring.R = Sun.R + 2*Planet.R;
Ring.N = Ring.R/Planet.R*Planet.N;

Ring.Theta = linspace(-pi/Ring.N,2*pi-pi/Ring.N,100)"';

Ring.RO = 1.1*Ring.R;

Ring.CSO [Ring.RO*cos(Ring.Theta) Ring.RO*sin(Ring.Theta)];
Ring.CSI = simmechanics.demohelpers.gear_profile(2*Ring.R,Ring.N,A);
Ring.CSI [Ring.CSI; Ring.CSI(1,:)];
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Ring.CS = [Ring.CSO; flipud(Ring.CSI)];

6 Simulate the model. To induce motion, try adjusting the velocity state
targets in the joint block dialog boxes. Notice that the sun, planet, and
ring gears move in a meshed fashion.

=
k.
b

You can open a copy of the resulting model. At the MATLAB command line,
enter smdoc_planetary_gear_c.

Add Gear Carrier

Up to now, you have kept the sun and planet gears at a fixed distance using
a Distance Constraint block. In an actual planetary gear, a gear carrier
enforces this constraint. Model the gear carrier and connect it between the

sun and planet gears.

1 Remove these blocks from the planetary gear model:
¢ Planar Joint
¢ Rigid Transform

e Distance Constraint
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2 Add these blocks to the planetary gear model.

Library Block Quantity
Body Elements Solid 1
Joints Revolute Joint 2
Frames and Rigid Transform 2

Transforms

3 Connect and name the blocks as shown.

Pay close attention to the Rigid Transform block orientation: the B frame
ports should face the Solid block. The new blocks are highlighted.
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4 In the Carrier block dialog box, specify these parameters.
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Parameter Setting

Geometry > Shape Select General Extrusion.

Geometry > Cross-Section Enter Carrier.CS. Select units of
cm.

Geometry > Length Enter Carrier.T.

Inertia > Density Enter Rho.

Graphic > Visual Enter Carrier.RGB.

Properties > Color

5 In the Rigid Transform block dialog box, specify these parameters.

Parameter Setting
Translation > Method Select Cartesian.
Translation > Offset Enter [Carrier.L/2 0
- (Carrier.T+T)/2]. Select
units of cm.

6 In the Rigid Transform1 block dialog box, specify these parameters.

Parameter Setting

Translation > Method Select Cartesian.

Translation > Offset Enter [-Carrier.L/2 0
-(Carrier.T+T)/2]. Select
units of cm.

7 In the model workspace, define the Carrier block parameters using
MATLAB code:

% Gear Carrier Parameters
Carrier.RGB = [0.25 0.4 0.7];
Carrier.L = Sun.R + Planet.R;
Carrier.w 2*T;

Carrier.T = T/2;

Theta = (90:1:270) '*pi/180;
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Beta = (-90:1:90) '*pi/180;

Carrier.CS = [-Carrier.L/2 + Carrier.W/2*cos(Theta)
Carrier.W/2*sin(Theta); Carrier.L/2 + Carrier.W/2*cos(Beta),
Carrier.W/2*sin(Beta)];

8 Simulate the model. To induce motion, try adjusting the velocity state
targets in the joint block dialog boxes. Notice that the gear carrier now
performs the task of the Distance Constraint block.

=
k.
b

You can open a copy of the resulting model. At the MATLAB command line,
enter smdoc_planetary_gear_d

Add More Planet Gears

Experiment with the model by adding more planet gears. Remember that you
must change the Carrier rigid body to accommodate any additional planet
gears. To see an example with four planet gears, at the MATLAB command
line enter smdoc_planetary gear_e.
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Model Planetary Orbit Due to Gravity

In this section...

“Model Overview” on page 3-77
“Build Model” on page 3-79
“Configure Simulation and Animation Parameters” on page 3-85

“Simulate Model” on page 3-85

“Add Remaining Planets” on page 3-87

Model Overview

In this tutorial, you model planet orbit in our solar system due to gravity.
The planets are treated as spheres, each with three translational and zero
rotational degrees of freedom with respect to a fixed world frame. Cartesian
Joint blocks provide these degrees of freedom. Gravitational Field blocks
generate the attractive forces that keep the planets in orbit.

For simplicity, the tutorial assumes that each planet is at aphelion at
simulation time zero. Aphelion is the point of greatest distance from the sun.
It corresponds to the minimum orbital velocity of a given planet.
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Placing the planets simultaneously at aphelion while neglecting orbital
parameters such as inclination and longitude of ascension node causes them to
align on a single axis. In the tutorial, aphelion lies on the X axis at a distance
Px from the sun. The planet velocity at aphelion is orthogonal to the line
joining the planet to the sun. It points along the Y axis with magnitude Vy.

vy

Perihelion -5 Aphelion
Px f

.-"//:

The procedure in this tutorial shows how you can model the gravitational
interaction between Earth and the sun. In this procedure, you add two
Cartesian Joint blocks. One block, connected between the Earth reference
frame and the World frame, provides three translational degrees of freedom
to Earth. The other block, connected between the Sun reference frame and
the World frame, provides the same to the sun, allowing it too to move under
the gravitational pull of Earth. Planet spin is ignored.

Similarly, you add two Gravitational Field blocks to the model. One block,
connected to the sun reference frame, represents the gravitational field of the
sun. This field exerts an attractive pull on Earth, but it has no effect on the
sun itself. To represent the attractive pull of Earth on the sun, you connect
the second Gravitational Field block to the Earth reference frame.

When using the Gravitational Field block, you must set the Uniform Gravity
parameter of the Mechanism Configuration block to None. This step prevents
conflicting gravity sources in your model. If you forget to take this step,
SimMechanics throws an error and the model does not simulate.
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The figure shows the key blocks in this model and their connections. Note
that you must add other blocks, such as Solver Configuration, for the model

to simulate.

Field

- n—:"

World Frame

Gravitationa

Sobd Properias!
Referance Frame

3 Translational
E E Degrees of
s Freedom

Build Model

Start by modeling the gravitational interaction between the sun and the
earth. This model shows the approach to use when you add the remaining
planets to the model. Except where noted, the blocks you use are from the

SimMechanics Second Generation library.

Start Model

1 Start a new model.

2 Add these blocks to the model.
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Library

Block

Utilities

Mechanism Configuration

Frames and Transforms

World Frame

Simscape Utilities

Solver Configuration

3 Connect the blocks as shown.

fx)=10

Sohver
Configur ation

T

Waorld Frame

L[l

- N

Mechanism I\(ﬁ 1
Configur ation _\5

Add Sun

1 Add these blocks to the model. The blocks represent the sun: its solid
properties, its gravitational pull on other bodies, and its degrees of freedom
with respect to the (fixed) World frame.

Library

Block

Body Elements

Solid

Forces and Torques

Gravitational Field

Joints

Cartesian Joint

2 Connect the blocks as shown. Note that each line joining two or more frame
ports represents a single frame. The R, B, and F port frames of the Sun,
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Sun Gravity, and Sun Translational DOFs blocks are coincident with

each other.

fx)=0

Soher
Configuration

Sun
Trans latiznal
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.
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Waorld Frame

iEl|

- N

Mechanism |47 )
Configur ation _\5

3 In the Sun block dialog box, specify these parameters. These variables are
the solid properties of the sun. You define their numerical values later in

the model workspace.

Parameter Select or Enter
Geometry > Shape Sphere
Geometry > Radius Sun.R

Inertia > Based on Mass

Inertia > Mass Sun.M

Graphic > Visual Sun.RGB

Properties > Color

3-81



3 Multibody Systems

3-82

4 In the Sun Gravity block dialog box, for Mass, enter Sun.M. The block uses
this mass to calculate the gravitational force on the planets as a function

of distance.

In the previous two steps, you specified the sun mass in two blocks, Sun
and Sun Gravity, using a single variable, Sun.M. This approach ensures the
two blocks, both of which represent the sun, use the same mass.

Add Earth

1 Add these blocks to the model. The blocks represent Earth: its solid
properties, its gravitational pull on other bodies, and its degrees of freedom
with respect to the (fixed) World frame.

Library

Block

Body Elements

Solid

Forces and Torques

Gravitational Field

Joints

Cartesian Joint

2 Connect the blocks as shown. The R, B, and F port frames of the Earth,
Earth Gravity, and Earth Translational DOFs blocks are coincident with

each other.
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3 In the Earth block dialog box, specify these parameters. These variables
are the solid properties of Earth. You define their numerical values later in
the model workspace.

Parameter Select or Enter
Geometry > Shape Sphere
Geometry > Radius Earth.R
Inertia > Based on Mass

Inertia > Mass Earth.Mm
Graphic > Visual Earth.RGB
Properties > Color

4 In the Earth Gravity block dialog box, for Mass, enter Earth.M. This
variable is the earth mass you specified in the Earth block. The block uses
this mass to calculate the gravitational force as a function of distance.

5 In the Earth Translational DOFs block dialog box, specify these
parameters. The state target variables set the initial position and velocity

of Earth with respect to the initial position of the sun (originally coincident
with the fixed World frame).
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Parameter Select or Enter
X Prismatic Primitive 1 Select the Specify Position
(Px) > State Targets check box.

2 In Value, enter Earth.Px.

3 Select the Specify Velocity
check box.

4 In Value, enter Earth.Vx.

Y Prismatic Primitive 1 Select the Specify Position

(Py) > Specify Position Target check box.

2 In Value, enter Earth.Py.

3 Select the Specify Velocity
check box.

4 In Value, enter Earth.Vy.

Define Model Variables

1 In the Simulink editor, select Tools > Model Explorer.

2 In the Model Hierarchy pane of Model Explorer, expand the node for your
model and select Model Workspace.

3 In the Model Workspace pane, in Data Source, select MATLAB Code.
4 In the MATLAB Code field, enter:

%% Sun Parameters
% Scale sun size for visualization purposes
SunScaling = 1e2;

% Specify the solid properties of the sun
Sun.M = 1.99e30;

Sun.R = 6.96e8*SunScaling;

Sun.RGB = [1 0.8 0.6];

%% Earth Parameters

% Scale Earth size for visualization purposes
TerrestrialPlanetScaling = 1.2e3; % Scale the size of Earth
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% Specify the solid properties of Earth
Earth.M = 5.97e24;

Earth.R = 6.05e6*TerrestrialPlanetScaling;
Earth.RGB = [0.8 0.8 0.8];

% Specify initial position and velocity of Earth
Earth.Px = 1.52e11;

Earth.Py = 0;
Earth.Vx = 0;
Earth.Vy = 2.93e4;

The scaling factors impact visualization only. They have no impact on
model dynamics. These factors become more important as you add planets
to the solar system model. As the distances between the sun and the outer
planets increase, the apparent sizes of these bodies decrease, sometimes
to just a few pixels. The scaling factors artificially increase the apparent
sizes of the sun and the planets so that they remain visible in Mechanics
Explorer.

5 Click Reinitialize from Source.

Configure Simulation and Animation Parameters

Large gravitational systems such as the Earth-sun pair typically have
large periods of revolution. To capture multiple Earth revolutions during
simulation, increase the simulation stop time to several years. To ensure an
adequate balance between simulation speed and accuracy, adjust the solver
step sizes.

1 In the Simulink editor, select Simulation > Model Configuration
Parameters.

2 In Stop time, enter 10*365*24*60*60. This value equals 10 years in
seconds. It allows simulation to run for 10 consecutive Earth revolutions
about the sun.

3 In Max step size, enter 24*60*60. This value equals one day in seconds.

Simulate Model

Update the block diagram, e.g., by pressing Ctrl+D with the model window
active. Mechanics Explorer opens with a static 3-D display of the model in its
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initial state. Adjust the viewpoint and zoom level to optimize visualization
on your screen.

Run the simulation, e.g., by pressing Ctrl+T. Mechanics Explorer plays a
physics-based animation of the solar system. At the default value of the base
playback speed, planet motion is hardly noticeable. Increase this value to
watch revolve about the sun in 10 seconds:

1 In Mechanics Explorer, select Tools > Animation Settings.

2 In Base(1X) Playback Speed, enter 3153600. This number equals one
tenth of a year in seconds.

3 Click Pause and then Play. Mechanics Explorer applies the previous

changes. You can now watch Earth revolve about the sun once every ten
seconds.
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Add Remaining Planets

Complete the solar system model by adding the remaining planets. Follow the
approach that you used to model the Earth-sun system.

The table shows the relevant parameters for each planet. To better visualize
the planets, consider scaling the radius parameters. For example, you

can multiply the terrestrial planet radii by a common scaling factor (e.g.,
TreestrialPlanetScaling), and the gas giant planets by another common
scaling factor (e.g., GasGianScaling)

Planet Radius Mass X X Y Y
(m) (kg) Position Velocity Position  Velocity
Target Target Target Target
(m) (m/s) (m) (m/s)
Mercury 2.44e6 3.30e23 6.98¢10 O 0 3.89¢4
Venus 6.05e6 4.87e24 1.09ell1 O 0 3.48e4
Mars 3.39e6 6.42e23  2.49el1l 0 0 2.2e4
Jupiter 6.99¢7 1.90e27 8.17¢e11 O 0 1.24e4
Saturn 5.82e7 5.68¢26 1.51el12 O 0 9.09e3
Uranus  2.54e7 8.68e¢25 3.00e12 O 0 6.49e3
Neptune 2.46e7 1.02e26  4.55e12 O 0 5.37e3

If you struggle with the remaining planets, you can open a completed model of
the solar system. At the MATLAB command prompt, enter:

e smdoc_solar_system wfield a — Model of the inner solar system. This
model includes the sun and terrestrial planets only.
e smdoc_solar_system wfield b — Model of the complete solar system.

This model adds to the previous model the gas giant planets.

These models include Rigid Transform blocks to account for orbit inclination
and longitude of ascension node.

Note that gravity is an inverse-square law force. That is, the force magnitude

decays with the square distance between a body and the field source mass.
As such, you can model the gravitational force between two bodies using
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the Inverse Square Law Force block. However, this block applies a force
only between its two port frames. Use this approach to neglect secondary
gravitational interactions, e.g., if orbital perturbations due to planet-planet
Interactions are irrelevant to your application.

Open these models to see how to model the solar system using the Inverse
Square Law Force block instead:

® smdoc_solar_system wforce_a — Model of the solar system with
terrestrial planets.
® smdoc_solar_system wforce b — Model of the solar system with

terrestrial and gas-giant planets.

These models account only for the gravitational interactions between
sun-planet pairs.
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Joint Actuation

= 7 Revolute Primitive (Rz)

In this section...

“Actuation Modes” on page 4-2
“Motion Input” on page 4-5
“Input Handling” on page 4-7

“Assembly and Simulation” on page 4-8

Actuation Modes

Joint blocks provide two actuation parameters. These parameters,
Force/Torque and Motion, govern how the joint behaves during simulation.
Depending on the parameter settings you select, a joint block can accept
either actuation parameter as input or automatically compute its value
during simulation.

An additional setting (None) allows you to set actuation force/torque directly
to zero. The joint primitive is free to move during simulation, but it has no
actuator input. Motion is due indirectly to forces and torques acting elsewhere
in the model, or directly to velocity state targets.

= Z Revolute Primitive (Rz)
[ State Targets

4-2

I+ State Targets
Intemal Mechanics @ Internal Mechanics
= Actuation =) Actuation _
q Autorpatically Computed - Torque I_&_I:J_tomatically Computed -
Motion Mone Automatically Computed -
Sensing Provided by Input i# Sensing Provided by Input
Automatically Computed __|

Like all joint block parameters, you select the actuation parameter settings
for each joint primitive separately. Different joint primitives in the same
block need not share the same actuation settings. Using a Pin Slot Joint
block, for example, you can provide motion input and have actuation torque
automatically computed for the Z Revolute Primitive (Rz), while having
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motion automatically computed with no actuation force for the X Prismatic
Primitive (Px).

= X Prismatic Primitive (Px)

Mone
Automatically Computed

Automatically Computed
Provided by Input

By combining different Force/Torque and Motion actuation settings, you
can achieve different joint actuation modes. Forward dynamics and inverse
dynamics modes are two common examples. You actuate a joint primitive in
forward dynamics mode by providing actuation force/torque as input while
having motion automatically computed. Conversely, you actuate a joint
primitive in inverse dynamics mode by providing motion as input while
having actuation force/torque automatically computed.

Other joint actuation modes, including fully computed and fully specified
modes, are possible. The table summarizes the different actuation modes that
you can obtain by manipulating the actuation parameter settings.
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Actuator Motion
Provided Automatically
by Input Computed
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|_
3 Provided Fully Forward
@ by Input Specified Dynamics
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!:ﬁ Automatically Inverse Fully
E Computed Dynamics Computed

Joint Actuation Modes

More generally, thinking of joint actuation in terms of the specified or
calculated quantities—i.e., force/torque and motion—provides a more
practical modeling approach. You may not always know the appropriate mode
for a joint but, having planned the model beforehand, you should always
know the answers to two questions:

¢ [s the joint primitive mechanically actuated?
e [s the desired trajectory of the joint primitive known?
By selecting the joint actuation settings based on the answers to these

questions, you can ensure that each joint is properly set for your application.
The figure shows the proper settings depending on your answers.
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Actuation — Force/Torgque

Is the joint primitive mechanically actuated?

No —J» Select Hone.

Yes

L’ Is the joint primitive actuation forceftorque known?

Mo —» Select Automatically Computed

Yes —b Select Provided by Input.

Actuation — Motion

Iz the desired trajectory of the joint primitive known?

Mo —'- Select Automatically Computed.

Yies —b- Select Provided by Input.

Selecting Joint Primitive Actuation Settings

Motion Input

The motion input of a joint primitive is a timeseries object specifying that
primitive’s trajectory. For a prismatic primitive, that trajectory is the
position coordinate along the primitive axis, given as a function of time. The
coordinate provides the position of the follower frame origin with respect to
the base frame origin. The primitive axis is resolved in the base frame.

For a revolute primitive, the trajectory is the angle about the primitive axis,
given as a function of time. This angle provides the rotation of the follower
frame with respect to the base frame about the primitive axis. The axis is
resolved in the base frame.

Spherical joint primitives provide no motion actuation options. You can
specify actuation torque for these primitives, but you cannot prescribe their
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trajectories. Those trajectories are always automatically computed from the
model dynamics during simulation.

Zero Motion Prescription

Unlike Actuation > Force/Torque, the Actuation > Motion parameter
provides no zero input option, corresponding to a fixed joint primitive during
simulation. You can, however, prescribe zero motion the same way you
prescribe all other types of motion: using Simscape and Simulink blocks.

In SimMechanics, motion input signals are position-centric. You specify the
joint primitive position and, if filtered to the second-order, the Simulink-PS
Converter block smooths the signal while providing its two time-derivatives
automatically. This behavior makes zero motion prescription straightforward:
just provide a constant signal to the motion actuation input port of the joint
primitive and simulate.

The figure shows an example of zero-motion prescription. A Simulink
Constant block provides a constant position value. A Simulink-PS Converter
block converts this Simulink signal into a Simscape signal compatible with the
motion actuation input port of the Base-Crank Revolute Joint block. Assuming
that assembly and simulation are successful, this joint will maintain a fixed
angle of 30 degrees, corresponding to the value set in the Simulink Constant
block and the units set in the Simulink-PS Converter block.
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Input Handling

When prescribing a joint primitive trajectory, it is practical to specify a single
input, the position, and filter that input using a Simulink-PS Converter
block. This filter, which must of second-order, automatically provides the
two time derivatives of the motion input. Because it also smooths the input
signal, the filter can help prevent simulation issues due to sudden changes or
discontinuities, such as those present when using a Simulink Step block.

Filtering smooths the input signal over a time scale of the order of the input
filtering time constant. The larger the time constant, the greater the signal
smoothing, and the more distorted the signal tends to become. The smaller
the time constant, the closer the filtered signal is to the input signal, but also
the greater the model stiffness—and, hence, the slower the simulation.

As a guideline, the input filtering time constant should be only as small as the
smallest relevant time scale in a model. By default, its value is 0.001 s. While
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appropriate for many models, this value is often too small for SimMechanics
models. For faster simulation, start with a value of 0.01 s. Decrease this
value for greater accuracy.

If you know the two time derivatives of the motion input signal, you can
specify them directly. This approach is most convenient for simple trajectories
with simple derivatives. You must, however, ensure that the two derivative
signals are compatible with the position signal. If they are not, even when
simulation proceeds, results may be inaccurate.

Assembly and Simulation

SimMechanics joints with motion inputs start simulation (Ctrl+T) at the
initial position dictated by the input signal. This initial position may differ
from the assembled state, which is governed by an assembly algorithm
optimized to meet the joint state targets, if any. Even in the absence of joint
state targets, the assembled state may differ from that at simulation time
Zero.

Note You obtain the assembled state each time you update the block
diagram, e.g., by pressing Ctrl+D. You obtain the initial simulation state
each time you run the simulation, e.g., by pressing Ctrl+T, and pausing at
time zero.

Due to the discrepancy between the two states, Model Report provides
accurate initial state data only for models lacking motion inputs. For models
possessing motion inputs, that data is accurate only when the initial position
prescribed by the motion input signal exactly matches the initial position
prescribed in the joint state targets.

Similarly, Mechanics Explorer displays the initial joint states accurately only
for models lacking motion inputs. As it transitions from the assembled state
to the initial simulation state, Mechanics Explorer may show a sudden jump
if a model contains motion inputs that are incompatible with the joint state
targets. You can eliminate the sudden change by making the initial position
prescribed by joint motion inputs equal to the initial position prescribed by
the joint state targets.
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Related ® “Prescribe Joint Motion in Planar Manipulator Model” on page 4-105
Examples e “Prescribe Joint Motion in Four-Bar Model” on page 4-96
e “Specify Motion Input Derivatives” on page 4-10
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Specify Motion Input Derivatives

Related
Examples

Concepts

If filtering the input signal using the Simulink-PS Converter block, you need
only to provide the position signal. The block automatically computes the

derivatives. You must, however, select second-order filtering in the block
dialog box:

1 Open the dialog box of the Simulink-PS Converter block and click Input
Handling.

2 In Filtering and derivatives, select Filter input.
3 In Input filtering order, select Second-order filtering.
4 In Input filtering time constant (in seconds), enter the characteristic

time over which filter smooths the signal. A good starting value is 0.01
seconds.

If providing the input derivatives directly, you must first compute those
derivatives. Then, using the Simulink-PS Converter block, you can provide
them to the target joint block. To specify the input derivatives directly:

1 Open the Simulink-PS Converter block receiving the input signal and click
the Input Handling tab.

2 In Filtering and derivatives, select Provide input derivative(s).

3 To specify both derivatives, in Input derivatives, select Provide first
and second derivatives.

The block displays two additional physical signal ports, one for each
derivative.

e “Prescribe Joint Motion in Planar Manipulator Model” on page 4-105
e “Prescribe Joint Motion in Four-Bar Model” on page 4-96

e “Joint Actuation” on page 4-2
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Joint Actuation Limitations

In this section...

“Closed Loop Restriction” on page 4-11

“Motion Actuation Not Available in Spherical Primitives” on page 4-11
“Redundant Actuation Mode Not Supported” on page 4-12

“Model Report and Mechanics Explorer Restrictions” on page 4-12

“Motion-Controlled DOF Restriction” on page 4-12

Closed Loop Restriction

Each closed kinematic loop must contain at least one joint block without
motion inputs or computed actuation force/torque. This condition applies
even if one of the joints acts as a virtual joint, e.g., the bushing joint in the
“Prescribe Joint Motion in Planar Manipulator Model” on page 4-105 example.
The joint without motion inputs or automatically computed actuation
forces/torques can still accept actuation forces/torques from input.

In models not meeting this condition, you can replace a rigid connection line
between two Solid blocks with a Weld Joint block. Since the Weld Joint
block represents a rigid connection, this approach leaves the model dynamics
unchanged. The advantage of this approach lies in its ability to satisfy the
SimMechanics closed-loop requirement without altering model dynamics.

Motion Actuation Not Available in Spherical
Primitives

Spherical joint primitives provide no motion actuation parameters. You can
prescribe the actuation torque acting on the spherical primitive, but not

its desired trajectory. For models requiring motion prescription for three
concurrent rotational degrees of freedom, use joint blocks with three revolute
primitives instead. These blocks include Gimbal Joint, Bearing Joint, and
Bushing Joint.
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Related
Examples

Concepts

Redundant Actuation Mode Not Supported

Redundant actuation, in which the end effector trajectory of a
high-degree-of-freedom linkage is prescribed, is not allowed. Such linkages
possess more degrees of freedom than are necessary to uniquely position the
end effector and, as such, have no single solution. Models that have more
degrees of freedom with automatically computed actuation forces/torques
than with prescribed motion inputs cause simulation errors.

Model Report and Mechanics Explorer Restrictions

In models with motion input, the assembled state achieved by updating the
block diagram (Ctrl+D) does not generally match the initial simulation state
at time zero (Ctrl+T). This discrepancy is visible in Mechanics Explorer,
where it can cause a sudden state change at time zero when simulating a
model after updating it. It is also reflected in Model Report, whose initial
state data does not generally apply to the simulation time zero when a model
has motion inputs.

Motion-Controlled DOF Restriction

The number of degrees of freedom with prescribed trajectories must equal the
number of degrees of freedom with automatically computed force or torque. In
models not meeting this condition, simulation fails with an error.

® “Prescribe Joint Motion in Planar Manipulator Model” on page 4-105
e “Prescribe Joint Motion in Four-Bar Model” on page 4-96
e “Specify Motion Input Derivatives” on page 4-10

e “Joint Actuation” on page 4-2
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Actuating and Sensing Using Physical Signals

In this section...

“Exposing Physical Signal Ports” on page 4-13
“Providing Actuation Signals” on page 4-13

“Extracting Sensing Signals” on page 4-14

Some SimMechanics blocks provide physical signal ports for actuation input or
sensing output. These ports accept or output only Simscape physical signals.
If you wish to connect these ports to Simulink blocks, you must use the
Simscape converter blocks. The table summarizes the converter blocks that
Simscape provides. You can find both blocks in the Simscape Utilities library.

Block Summary

PS-Simulink Converter Convert Simscape physical signal
into Simulink signal

Simulink-PS Converter Convert Simulink signal into
Simscape physical signal

Exposing Physical Signal Ports

In SimMechanics, most physical signal ports are hidden by default. To expose
them, you must select an actuation input or sensing output from the block
dialog box. Blocks that provide physical signal ports include certain Forces
and Torques blocks as well as Joint blocks. Each port has a unique label
that identifies the actuation/sensing parameter. For the ports that a block
provides, see the reference page for that block.

Providing Actuation Signals

To provide an actuation signal based on Simulink blocks, you use the
Simulink-PS Converter block:

1 Build the Simulink block diagram to represent the actuation signal

This diagram can be as simple as a single block.
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2 Connect the Simulink signal from the block diagram to the input port of a
Simulink-PS Converter block.

3 Connect the output port of the Simulink-PS Converter block to the input
port of the block that you want to provide the actuation signal to.

In the figure, the connection line that connects to the input port of the
Simulink-PS Converter block represents the original Simulink signal. The
connection line that connects to the output port of the same block represents
the converted physical signal. This is the signal that you must connect to the
actuation ports in SimMechanics blocks.

Qriginal

Simulink Signal

Exterrml Fooe
B Toroues

L)

l : -
Simulink-PS Signal Builder
Converter

Converted

Physical Signal

Extracting Sensing Signals

To connect the sensing signal of a SimMechanics block to a Simulink block,
you use the PS-Simulink Converter block:

1 Connect the SimMechanics sensing port to the input port of a PS-Simulink
Converter block.

2 Connect the output port of the PS-Simulink Converter block to the
Simulink block of your choice.

The figure shows how you can connect a SimMechanics sensing signal to a
Simulink Scope block.
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Forces and Torques Between Arbitrary Bodies

In this section...

“Actuating Rigid Bodies” on page 4-16

“Force and Torque Blocks” on page 4-16

Force and Torque Blocks

You can apply different forces and torques to a model. The table summarizes
the different forces and torques that you can represent using SimMechanics
blocks. For detailed information about these blocks, see the block reference

pages.

Block

Description

External Force and Torque

General force and torque arising
outside a model

Gravitational Field

Gravitational field of a point mass,
which exerts on every other rigid
body an attractive force as a function
of distance

Internal Force

General force acting between two
rigid bodies in a model

Inverse Square Law Force

Internal force, acting between two
rigid bodies in a model, with a 1/R*2
dependence. Examples include
gravity and Coulomb forces.

Spring and Damper Force

Internal force, acting between two
rigid bodies in a model, that accounts
for energy storage and dissipation in
your model

Actuating Rigid Bodies

You can actuate a rigid body directly using blocks from the Forces and
Torques library. Use the External Force and Torque block to represent an
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System

actuation input that arises outside your model. Use the remaining blocks to
represent forces that are internal to your model.

The figure illustrates external and internal forces acting on a mechanical
system. An external force provides the actuation input to the system. This
can be a constant or a general time-dependent input. A spring and damper
force acting between the two bodies in the system accounts for energy storage
and dissipation. You represent the actuation input using the External Force
and Torque block. You represent the internal spring and damper force using
the Spring and Damper Force block.

Reprasant With Block

External External Force and Torgue

Acluation Force IE

e =Tl d ner Force
. Interma .':.i:-.lrlrl':.l znd ._'|F| i g ang Lampear =orce

Damper Force JZZ
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The Forces and Torques blocks contain frame ports. These ports identify the
rigid body frames the forces/torques act on. If the block represents an internal
force, the block contains two frame ports. Connect these ports to the two rigid
bodies the force/torque acts on. If the block represents an external force or
torque, the block contains one frame port. Connect this port to the rigid body
frame the external force or torque acts on.

The frame origin identifies the point of application for a force or torque.

The frame axes identify the directions of the X, Y, and Z force/torque vector
components that you specify. Changing the frame position changes also the
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force/torque application point. Likewise, changing the frame orientation
changes also the force/torque direction.

The figure shows three external forces that you can apply to the rocker link
of a four-bar mechanism—F1, F2, and F3. Forces F1 and F3 act at the ends
of the link, while force F2 acts at its mass center.

F1 F2 F3

To represent one of these forces in a SimMechanics model, you first define the
frame to apply that force to. Example “Represent Binary Link Frame Tree”
on page 1-36 shows you how to do this. Then, in the block diagram for your
model, connect the frame port of an External Force and Torque block to the
frame entity that represents that frame—frame port, line, or node. For more
information, see “Representing Frames” on page 1-7.

Finally, in the block dialog box, select the force component(s) that you want to
specify. For example, to specify a force acting along the -Y axis of the frame it
connects to, select Force > Force (Y). Then, use the physical signal port that
the block exposes to input the value of that force component. That value 1s
negative for a force acting along the -Y axis.



Forces and Torques Between Arbitrary Bodies

The figure shows the modified block diagram of a four-bar model that is
present in your SimMechanics installation. You can open the original model
by typing sm_four_bar at the MATLAB command line.
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The rectangular frame in the image highlights the blocks that you can use to
apply an external force. The frame port that the External Force and Torque

block connects to represents the binary link mass center. The block diagram
of the binary link subsystem provides this frame. The figure shows the block
diagram.
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In the External Force and Torque block, physical signal port fy identifies
the force component that the block represents—in this case, a force in the Y
direction of the frame that the block connects to.
Related e “Actuate Joint in Four-Bar Model” on page 4-57
Examples
Concepts e “Joint Actuation” on page 4-2

e “Actuating and Sensing Using Physical Signals” on page 4-13
e “Representing Frames” on page 1-7
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Sensing

In this section...

“Sensing Overview” on page 4-21

“Variables You Can Sense” on page 4-22
“Blocks with Sensing Capability” on page 4-22
“Sensing Output Format” on page 4-23

“SimMechanics Sensing Recap” on page 4-23

Sensing Overview

Sensing enables you to perform analytical tasks on a model. For example, you
can perform inverse dynamic analysis on a robotic manipulator model. By
prescribing the end-effector trajectory and sensing the joint actuation forces
and torques, you can obtain the time-varying profile of each joint actuation
input.

The variables you prescribe, the model inputs, and those you sense, the model
outputs, determine which types of analysis you can perform. By changing
the model inputs and outputs, you can perform numerous other analysis
types. For example, to perform forward kinematic analysis on the robotic
manipulator model, you can prescribe the manipulator joint trajectories and
sense the resulting end-effector trajectory.
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Variables You Can Sense

To support various analytical tasks, SimMechanics software provides a wide
range of variables that you can sense. Each variable belongs to either of two
categories:

e Motion variables — Linear and angular position, velocity, and acceleration.
Linear variables are available in different coordinate systems, including
Cartesian, spherical, and cylindrical. Angular variables are available in
different formats, including quaternion, axis-angle, and transform matrix.

¢ Force and torque variables — Actuation, constraint, and total forces and
torques acting at a joint, as well as certain forces and torques acting
outside of a joint.

Blocks with Sensing Capability

The entire sensing capability spans multiple SimMechanics blocks. Two types
of blocks provide motion sensing:

¢ Joint blocks — Motion sensing between the base and follower port frames of
a joint block. Variables that you can sense are organized by joint primitive
(prismatic, revolute, or spherical).
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® Transform Sensor block — Motion sensing between any two frames in
a model. This block provides the most comprehensive motion sensing
capability in SimMechanics.

Two types of blocks provide force and torque sensing:

® Joint blocks — Force and torque sensing between the base and follower
port frames of a joint block. Variables that you can sense are organized by
joint primitive.

e (Certain Forces and Torques blocks — Force and torque sensing between
any two frames interacting through parameterized Forces and Torques
blocks. These blocks include Spring and Damper Force and Inverse Square
Law Force, which compute the force magnitude from parameters that you
specify, e.g., spring stiffness.

Sensing Output Format

Each sensing output is in a physical signal format. You can convert physical
signals into Simulink signals using Simscape converter blocks, e.g., for
plotting purposes using the Scope block. For information on how to use
physical signals in SimMechanics models, see “Actuating and Sensing Using
Physical Signals” on page 4-13.

SimMechanics Sensing Recap

The figure summarizes the SimMechanics sensing capability. Variables p, v,
and a denote linear position, velocity, and acceleration. Variables 6, w, and a
denote angular position, velocity, and acceleration.
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Force and Torque Sensing

In this section...

“Blocks with Force and Torque Sensing” on page 4-25
“Joint Forces and Torques You can Sense” on page 4-26

“Force and Torque Measurement Direction” on page 4-28

Blocks with Force and Torque Sensing

Blocks with force and torque sensing appear in two SimMechanics libraries:

® Forces and Torques — Sense the magnitude of certain forces not explicitly
provided by input. Blocks with force sensing include Inverse Square
Law Force and Spring and Damper Force. Each block can sense only the
magnitude of its own force.

* Joints — Sense various forces and torques acting directly at a joint. All joint
blocks provide force and torque sensing. However, the specific force and
torque types that you can sense vary from joint to joint. Force and torque
sensing 1s available strictly between the rigid bodies the joint connects.
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Force and Torque Sensing in SimMechanics™

Joint Forces and Torques You can Sense

Forces and torques that you can sense at a joint fall into two categories:

¢ Joint primitive forces and torques. Each such force or torque is individually
computed for a given joint primitive. Joint actuator forces and torques
belong to this category.

® Composite forces and torques. Each such force or torque is computed
in aggregate for an entire joint. Constraint and total forces and torques
belong to this category.

The table summarizes the different joint forces and torques.
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Force/Torque Type

Actuator

Constraint

Total

Acts On

Individual joint
primitives

Entire joints

Entire joints

Measures

Force or torque driving
an individual joint
primitive. The sensed
force or torque can be
provided by input or it
can be automatically
computed based on
joint motion inputs in a
model.

Aggregate constraint
force or torque opposing
motion normal to

the joint degrees of
freedom. By definition,
these forces and torques
act orthogonally to the
joint primitive axes.

Net sum of all forces or
torques acting between
the joint port frames.
These include actuator,
internal, and constraint
forces and torques.

The figure shows a basic example of these forces acting on a crank-slider

piston.
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In the figure:

e [, is the actuator force, which drives the piston toward the crank link.

¢ [ is the internal spring and damper force, which resists motion of the
piston with respect to the chamber.

® [, is the constraint force, which opposes the effect of gravity on the piston,
preventing it from falling.

The total force equals the net sum of F,, F, and F.

Force and Torque Measurement Direction

In accordance with Newton’s third law of motion, a force or torque acting
between two joint port frames accompanies an equal and opposite force or
torque. If the base port frame of a Prismatic Joint block exerts a force on the
follower port frame, then the follower port frame exerts an equal force on the
base frame. When sensing composite forces and torques in joint blocks, you
can specify which of the two to sense:

¢ Follower on base — Sense the force or torque that the follower port frame
exerts on the base port frame.
® Base on follower — Sense the force or torque that the base port frame

exerts on the follower port frame.

The figure shows the effect of reversing the measurement direction. Reversing
this direction changes the measurement sign.
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Motion Sensing

In this section...

“Sensing Spatial Relationship Between Joint Frames” on page 4-29

“Sensing Spatial Relationship Between Arbitrary Frames” on page 4-31

In SimMechanics, you can sense the spatial relationship between two frames
using two types of blocks:

¢ Transform Sensor — Sense the spatial relationship between any two
frames in a model. Parameters that you can sense with this block include
position, velocity, and acceleration of the linear and angular types.
This block provides the most extensive motion sensing capability in the
SimMechanics libraries.

® Joint blocks — Sense the spatial relationship between the base and
follower frames of a Joint block. Parameters that you can sense with a
Joint block include the position and its first two time derivatives (velocity
and acceleration) for each joint primitive.

These blocks output a physical signal for each measurement that you specify.
You can use the sensing output of these blocks for analysis or as input to
a control system in a model.

Sensing Spatial Relationship Between Joint Frames

To sense the spatial relationship between the base and follower frames of a
Joint block, you can use the Joint block itself. For each joint primitive, the
dialog box provides a Sensing menu with basic parameters that you can
measure. These parameters include the position, velocity, and acceleration of
the follower frame with respect to the base frame. If the sensing menu of the
dialog box does not provide the parameters that you wish to sense, use the
Transform Sensor block instead. See “Sensing Spatial Relationship Between
Arbitrary Frames” on page 4-31.

The sensing capability of a joint block is limited to the base and follower
frames of that joint block. Every measurement provides the value of a
parameter for the joint follower frame with respect to the joint base frame.
If sensing the spatial relationship with a spherical joint primitive, you can
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also select the frame to resolve the measurement in. To sense the spatial
relationship between any other two frames, use the Transform Sensor block
instead.

If the joint primitive is of the revolute or spherical type, the parameters
correspond to the rotation angle, angular velocity, and angular acceleration,
respectively. If the joint primitive is of the prismatic type, the parameters
correspond to the offset distance, linear velocity, and linear acceleration,
respectively.

Regardless of joint primitive type, each parameter that you select applies only
to the joint primitive it belongs to. For example, selecting Position in the Z
Revolute Primitive (Rz) > Sensing menu exposes a physical signal port
that outputs the rotation angle of the follower frame with respect to the base
frame about the base frame Z axis.

The table lists the port label for each parameter that you can sense using a
joint block. The first column of the table identifies the parameters that you
can select. The remaining three columns identify the port labels for the three
joint primitive menus that the dialog box can contain: Spherical, Revolute,
and Prismatic.

Note For parameter descriptions, see the reference pages for Spherical Joint,
Revolute Joint, and Prismatic Joint blocks.

Parameter Spherical Revolute Prismatic
Position Q q p

Velocity \'4 \'4 v

Velocity (X/Y/Z) wWx/Wylwz N/A N/A
Acceleration b b a
Acceleration bx/by/bz N/A N/A
X/Y/Z)

A joint block can contain multiple revolute and prismatic joint primitives. For
blocks with multiple primitives of the same type, the port labels include an
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extra letter identifying the joint primitive axis. For example, the Position
port label for the Z prismatic primitive of a Cartesian Joint block is pz.

Select Joint Parameters To Sense
To select the spatial relationship parameters that you wish to sense:

1 Open the dialog box for the joint block to sense the spatial relationship
across.

2 In the Sensing menu of the block dialog box, select the parameters to sense.

The block exposes one physical signal port for each parameter that you select.
The label of each port identifies the parameter that port outputs.

Sensing Spatial Relationship Between Arbitrary
Frames

To sense the spatial relationship between two arbitrary frames in a model, you
use the Transform Sensor block. The dialog box of this block provides a set of
menus that you can use to select the parameters to sense. These parameters
include position, velocity, and acceleration of the linear and angular types.

Every measurement provides the value of a parameter for the follower frame
with respect to the base frame, resolved in the measurement frame that you
choose. You can connect the base and follower frame ports of the Transform
Sensor block to any two frames in a model. To measure a parameter for a
different frame, connect the follower frame port to the frame line or port that
identifies that frame. Likewise, to measure a parameter for the same frame
but with respect to a different frame, connect the base frame port to the frame
line or port that identifies that frame. Finally, to resolve a measurement in
a different frame, select a different measurement frame in the block dialog
box. For more information about measurement frames, see “Measurement
Frames” on page 4-47. For more information about frame lines and ports, see
“Representing Frames” on page 1-7.

Selecting a parameter from the block dialog box exposes the corresponding
physical signal port in the block. Use this port to output the measurement
for that parameter. To identify the port associated with each parameter,
each port uses a unique label.
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The table lists the port labels for each angular parameter that you can sense.
The first column of the table identifies the parameters that you can select.
The remaining three columns identify the port labels for the three angular
parameter menus in the dialog box: Rotation, Angular Velocity, and
Angular Acceleration. Certain parameters belong to one menu but not to
others. N/A identifies the parameters that don’t belong to a given menu—e.g.
Angle, which 1s absent from the Angular Velocity.

Note For parameter descriptions, see the Transform Sensor reference page.

Rotation Angular Angular
Parameter Velocity Acceleration
Angle q N/A N/A
Axis axs N/A N/A
Quaternion Q Qd Qdd
Transform R Rd Rdd
Omega X/Omega | N/A WX/Wy/Wz N/A
Y/Omega Z
Alpha X/Alpha N/A N/A bx/by/bz
Y/Alpha Z

The table lists the port labels for each linear parameter that you can sense.
As in the previous table, the first column identifies the parameters that you
can select. The remaining three columns identify the port labels for the
three linear parameter menus in the dialog box: Translation, Velocity,
and Acceleration.

Rotation Port | Angular Angular
Velocity Port Acceleration
Parameter Port
XNY/Z x/ylz vx/vylvz ax/ay/az
Radius rad vrad arad
Azimuth azm vazm aazm
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Related
Examples

Concepts

Rotation Port | Angular Angular
Velocity Port Acceleration
Parameter Port
Distance dst vdst adst
Inclination inc vinc ainc

Select Transform Sensor Parameters To Sense

To select the spatial relationship parameters that you wish to sense:

1 Open the Transform Sensor dialog box.

2 Expand the menu for the parameter group that parameter belongs to.

E.g. Rotation for parameter Angle.

3 Select the check box for that parameter.

The block exposes one physical signal port for each parameter that you select.

The label of each port identifies the parameter that port outputs.

“Sense Motion in Double-Pendulum Model” on page 4-50
“Actuate Joint in Four-Bar Model” on page 4-57

¢ “Rotational Measurements” on page 4-34
* “Translational Measurements” on page 4-39

“Measurement Frames” on page 4-47
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Rotational Measurements

In this section...

“Rotation Sensing Overview” on page 4-34
“Measuring Rotation” on page 4-34
“Axis-Angle Measurements” on page 4-34
“Quaternion Measurements” on page 4-36

“Transform Measurements” on page 4-37

Rotation Sensing Overview

You can measure frame rotation in different formats. These include
axis-angle, quaternion, and transform. The different formats are available
through the Transform Sensor block and, to a limited extent, in joint blocks '.
The choice of measurement format depends on the model. Select the format
that is most convenient for the application.

Measuring Rotation

Rotation is a relative quantity. The rotation of one frame is meaningful only
with respect to another frame. As such, blocks with rotation sensing capability
require two frames to make a measurement: measured and reference frames.
In these blocks, the follower frame port identifies the measured frame; the
base frame port identifies the reference frame of the measurement.

SimMechanics defines the rotation formats according to standard conventions.
In some cases, more than one convention exists. This is the case, for example,
of the quaternion. To properly interpret rotation measurements, review the
definitions of the rotation formats.

Axis-Angle Measurements

Axis-angle is one of the simpler rotation measurement formats. This format
uses two parameters to completely describe a rotation: axis vector and angle.
The usefulness of the axis-angle format follows directly from Euler’s rotation

1.

Weld Joint is an exception
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theorem. According to the theorem, any 3—D rotation or rotation sequence can
be described as a pure rotation about a single fixed axis.

o
M
a
[¥a]

To measure frame rotation in axis-angle format, use the Transform Sensor
block. The block dialog box contains separate Axis and Angle parameters
that you can select to expose the corresponding physical signal (PS) ports
(labeled axs and q, respectively). Because the axis-angle parameters are listed
separately, you can choose to measure the axis, the angle, or both.

Angle

Aois
Cuaternion
Transform

The axis output is a 3—D unit vector in the form [a,, a, a,]. This unit vector
encodes the rotation direction according to the right-hand rule. For example,
a frame spinning in a counterclockwise direction about the +X axis has
rotation axis [1 0 0]. A frame spinning in a clockwise direction about the
same axis has rotation axis [-1 0 0].

The angle output is a scalar number in the range O—m1. This number encodes
the extent of rotation about the measured axis. By default, the angle is
measured in radians. You can change the angle units in the PS-Simulink
Converter block used to interface with Simulink blocks.
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Quaternion Measurements

The quaternion is a rotation representation based on hypercomplex numbers.
This representation uses a 4-vector containing one scalar (S) and three vector
components (V,, Vy, V,). The scalar component encodes the rotation angle.
The vector components encode the rotation axis.

A key advantage of quaternions is the singularity-free parameter space.
Mathematical singularities, present in Euler angle sequences, result in the
loss of rotational degrees of freedom. This phenomenon is known as gimbal
lock. In SimMechanics, gimbal lock causes numerical errors that lead to
simulation failure. The absence of singularities means that quaternions are
more robust for simulation purposes.

To measure frame rotation in quaternion format, use:

¢ Transform Sensor block, if measuring rotation between two general frames.
The Rotation menu of the dialog box contains a Quaternion option that
you can select to expose the corresponding physical signal port (labeled Q).

Angle

Axis
Quaternion
Transform

¢ Joint block possessing spherical primitive, if measuring 3-D rotation
between the two joint frames. The Sensing menu of the dialog box contains
a Position option that you can select to expose the corresponding physical
signal port (also labeled Q). For more information, see Spherical Joint block
reference page.
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= Sensing
Position
Velocity (]
Velocity (Y]
Velocity (Z)
Velocity
Acceleration (X
Acceleration ()
Acceleration (£)
Acceleration

Note The Transform Sensor block provides a quaternion option for rotation
and 1its first two time-derivatives (angular velocity and acceleration). On the
other hand, the Spherical Joint block provides a quaternion option only for
rotation — angular velocity and acceleration are measured only in terms of
rotation axis and angle.

The quaternion output is a 4-element row vector Q=5 ) , where:

S =cos (%)

and

V=V,V,V,]sin o
2%

0 is the rotation angle. The angle can take any value between 0-m. [V, Vy, V]
1s the rotation axis. Axis components can take any value between 0-1.

Transform Measurements

The rotation transform is a 3X3 matrix that encodes frame rotation. In terms
of base frame axes (X, Y, and Z), the follower frame axes (X’, Y’, and Z’) are:
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The transform describes the rotation required to bring one frame into
coincidence with another frame. In terms of Transform Sensor port frames,
the rotation transform describes the rotation that brings the base port frame
into coincidence with the follower port frame.

Each matrix column contains the coordinates of a follower frame axis resolved
in the base frame. For example, the first column contains the coordinates

of the follower frame X-axis, as measured in the base frame. Similarly,

the second and third columns contain the coordinates of the Y and Z-axes,
respectively. Operating on a vector with the rotation matrix transforms the
vector coordinates from the base frame to the follower frame.

To measure frame rotation in transform format, use the Transform Sensor
block. The block dialog box contains a Transform option that you can select
to expose the corresponding physical signal port (labeled R). The transform
output is a nine-element matrix with elements valued between 0-1.

Angle

Axis
Quaternion
Transform

“Sense Motion in Double-Pendulum Model” on page 4-50
“Actuate Joint in Four-Bar Model” on page 4-57

* “Motion Sensing” on page 4-29
* “Translational Measurements” on page 4-39
® “Measurement Frames” on page 4-47
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Translational Measurements

In this section...

“Translation Sensing Overview” on page 4-39
“Measuring Translation” on page 4-39
“Cartesian Measurements” on page 4-40

“Cylindrical Measurements” on page 4-43

“Spherical Measurements” on page 4-44

Translation Sensing Overview

You can measure frame translation in different coordinate systems. These
include Cartesian, cylindrical, and spherical systems. The different coordinate
systems are available through the Transform Sensor block and, to a limited
extent, in joint blocks 2. The choice of coordinate system depends on the model.
Select the coordinate system that is most convenient for the application.

Measuring Translation

Translation is a relative quantity. The translation of one frame is meaningful
only with respect to another frame. As such, blocks with translation sensing
capability require two frames to make a measurement: measured and
reference frames. In these blocks, the follower frame port identifies the
measured frame; the base frame port identifies the reference frame of the
measurement.

Some measurements are common to multiple coordinate systems. One
example is the Z-coordinate, which exists in both Cartesian and cylindrical
systems. In the Transform Sensor dialog box, coordinates that make up more
than one coordinate system appear only once. Selecting Z outputs translation
along the Z-axis in both Cartesian and cylindrical coordinate systems.

Other measurements are different but share the same name. For example,
radius is a coordinate in both spherical and cylindrical systems. The spherical
radius is different from the cylindrical radius: the former is the distance

2. Weld Joint is an exception

4-39



4 inierndl Mechanics, Actuation and Sensing

between two frame origins; the latter is the distance between one frame origin
and a frame Z-axis.

To differentiate between the two radial coordinates, SimMechanics uses the
following convention:

¢ Radius — Cylindrical radial coordinate

¢ Distance — Spherical radial coordinate

Cartesian Measurements

The Cartesian coordinate system uses three linear coordinates—X, Y, and
Z—corresponding to three mutually orthogonal axes. Cartesian translation
measurements have units of distance, with meter being the default. You
can use the PS-Simulink Converter block to select a different physical unit
when interfacing with Simulink blocks.
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Transform Sensor

You can select any of the Cartesian axes in the Transform Sensor for
translation sensing. This is true even if translation is constrained along any
of the Cartesian axes. Selecting the Cartesian axes exposes physical signal
ports X, y, and z, respectively.

The figure shows a simple model using a Transform Sensor block to measure
frame translation along all three Cartesian axes. The measurement gives the
relative translation of the follower port frame with respect to the base port
frame. These frames are, respectively, the Solid1l and Solid2 reference port
frames. For more information, see “Representing Frames” on page 1-7.

,L% T Sensor: T Sensor Ii“ﬂl[é]

Description

Measures time-dependent relationship between two frames. A
Transform Sensor passively senses this 3-D time-varying
transformation, and its derivatives, between the two frames.

In the expandible nodes under Properties, select which rotational
and translational relationships, induding velocities and
accelerations, you want to measure. After you apply these
settings, the block displays the corresponding output physical

signal ports. PS-Simulinc

Converter Scope
Ports B and F are frame ports that represent the base and
follower frames, respectively. The sensor measures the D@—.E
transformation and its derivatives as follower frame relative to E
base frame. The transformation components can be projected
into one of several frames. ;}@_ﬁ

Properties

Measurement Fr... |World

Soler
& Rotation Configuration

& Angular Velocity

& Angular Acceleration
E Translation

Jaint

Radius
Aziruth
Distance

Mechanism Configur ation

Inclination

B Acceleration

Apply

Joints

With joint blocks, you can sense translation along each prismatic primitive
axis. Selecting a sensing parameter from a prismatic primitive menu exposes
the corresponding physical signal port. For example, if you select Position
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from the Z Prismatic Primitive (Pz) of a Cartesian Joint block, the block
exposes physical signal port z.

The figure shows a simple model using a Cartesian Joint block to sense frame
translation along the three Cartesian axes. The measurement gives the
relative translation of the follower port frame with respect to the base port
frame. These frames coincide with the Solid1l and Solid reference port frames.

=} Cartesian Joint : Cartesian Joint

Description

Represents a cartesian joint between two frames, This joint has
three translational degrees of freedom represented by three
prismatic primitives along a set of mutually orthogonal axes. This
joint constrains the axes of these frames remain aligned, while
allowing unconstrained 3-D translation.

In the expandible nodes under Properties, specify the state,
actuation method, sensing capabilites, and internal mechanics of
the primitives of this joint. After vou apply these settings, the
block displays the corresponding physical signal ports.

follower frames, respectively, The joint direction is defined by

Ports B and F are frame ports that represent the base and ﬂ
lid2
motion of the follower frame relative to the base frame. —

Properties
1+| State Targets
Internal Mechanics
1+ Actuation
1= Sensing
Position
Velocity
Acceleration

][]

Actuator Force =
State Targets -
1+ Internal Mechanics
1+ Actuation e
I=! Sensing
Position
Velocity
Acceleration
Actuator Force [
11! State Targets
1# Internal Mechanics
1# Actuation
I=I Sensing
Position
Velocity
Acceleration

PS-Simulink Scope
Canverter

Mechanism Configurtion

IOE)

| ENsS]

Actuator Force
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Cylindrical Measurements

The cylindrical coordinate system uses one angular and two linear
coordinates. The linear coordinates are the cylinder radius, R, and length,

Z. The angular coordinate is the azimuth, ¢, about the length axis. Linear
coordinates have units of distance, with meter being the default. The angular
coordinate has units of angle, with radian being the default. You can use
the PS-Simulink Converter block to select a different physical unit when
interfacing with Simulink blocks.

),

Z

N

Transform Sensor

Only the Transform Sensor block can sense frame translation in cylindrical
coordinates. In the dialog box of this block, you can select one or more
cylindrical coordinates to measure. The cylindrical coordinates are named Z,
Radius, and Azimuth. Selecting the cylindrical coordinates exposes physical
signal ports z, rad, and azm, respectively.

Note Z belongs to both Cartesian and cylindrical systems.

The figure shows a simple model using a Transform Sensor block to measure
frame translation along all three cylindrical axes. The measurement gives
the relative translation of the follower port frame with respect to the base
port frame. These frames are, respectively, the Solid1l and Solid2 reference
port frames.
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& Transform Sensor : Transform Sensor E’

Description

Measures time-dependent relationship between two frames, A
Transform Sensor passively senses this 3-D time-varying
transformation, and its derivatives, between the two frames.

In the expandible nodes under Properties, select which rotational
and translational relationships, induding velocities and
accelerations, you want to measure, After you apply these
settings, the block displays the corresponding output physical
signal ports.

PS-Simulink
Converter Scope

B —0
=
fz—0

Ports B and F are frame ports that represent the base and
follower frames, respectively. The sensor measures the
transformation and its derivatives as follower frame relative to
base frame. The transformation components can be projected
into one of several frames.

e Iy

Transform
Sensar

Sohvar
Carfiguration

Properties

Measurement Fr... |Waorld -+ |
£l Rotation
Angular Velocity

B Angular Acceleration
B Translation

~
(=[]

OS]

Radius - Mecharis m Configurstion
Azimuth
Distance
Inclination
B Velocity
B Acceleration

]

Spherical Measurements

The spherical coordinate system uses two angular and one linear coordinates.
The linear coordinate is the spherical radius, R. The angular coordinates are
the azimuth, @, and inclination, 6. The linear coordinate has units of distance,
with meter being the default. The angular coordinates have units of angle,
with radian being the default. You can use the PS-Simulink Converter block
to select a different physical unit when interfacing with Simulink blocks.
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~

[

Transform Sensor

Only the Transform Sensor block can sense frame translation in spherical
coordinates. In the dialog box of this block, you can select one or more
spherical coordinates to measure. The spherical coordinates are named
Azimuth, Distance, and Inclination. Selecting the spherical coordinates
exposes physical signal ports azm, dst, and inc, respectively.

Note Azimuth belongs to both cylindrical and spherical systems. Distance
is the spherical radius.

The figure shows a simple model using a Transform Sensor block to measure
frame translation along all three spherical axes. The measurement gives the
relative translation of the follower port frame with respect to the base port
frame. These frames are, respectively, the Solid1l and Solid2 reference port
frames.
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23

Description

Measures time-dependent relationship between two frames, A
Transform Sensor passively senses this 3-D time-varying
transformation, and its derivatives, between the two frames.

In the expandible nodes under Properties, select which rotational
and translational relationships, incduding velodties and
accelerations, you want to measure. After you apply these
settings, the block displays the corresponding output physical
signal ports.

Ports B and F are frame ports that reprezent the base and
follower frames, respectively, The sensor measures the
transformation and its derivatives as follower frame relative to
base frame. The transformation companents can be projected
into one of several frames,

Properties

Measurement Fr... ‘World - i

Rotation

Angular Velocity

2 Angular Acceleration
B Translation

Radius

[y ] ) o

Azimuth yar

Distance
Inclination

1 =

B Velocrty
Acceleration

Concepts

Solver
Configuration

PS-Simulink

2T
77|

World Frame

Mechanism Corfiguration

“Motion Sensing” on page 4-29
“Rotational Measurements” on page 4-34
“Measurement Frames” on page 4-47

Related ® “Sense Motion in Double-Pendulum Model” on page 4-50
Exclmples o “Actuate Joint in Four-Bar Model” on page 4-57



Measurement Frames

Measurement Frames

In this section...

“Measurement Frame Purpose” on page 4-47

“Measurement Frame Types” on page 4-48

You can sense the spatial relationship between two frames. When you do
so, SimMechanics resolves the measurement in a measurement frame. For
most joint blocks, the measurement frame is the base frame. However, if
you use either Transform Sensor or a joint block with a spherical primitive,
you can select a different measurement frame. Measurement frames that
you can select includes Base, Follower, and World. The Transform Sensor
block adds the choice between rotating and non-rotating versions of the base
and follower frames.

Measurement Frame Purpose

The measurement frame defines the axes that SimMechanics uses to resolve
a measurement. The measurement still describes the relationship between
base and follower frames. However, the X, Y, and Z components of that
measurement refer to the axes of the measurement frame. SimMechanics
takes the measurement and projects it onto the axes of the measurement
frame that you select. The figure illustrates the measurement frame concept.

Measuremant Frame: Base Measurerment Frame: World

/ i
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The arrow connecting base and follower frame origins is the translation
vector. If you select the base frame as the measurement frame, SimMechanics
resolves that translation vector along the axes of the base frame. If you
select the World frame as the measurement frame, SimMechanics instead
resolves the translation vector along the axes of the World frame. The
translation vector remains the same, but the frame SimMechanics expresses
that measurement in changes.

Note that you can select the measurement frame only with certain blocks.
Among joint blocks, only those with a spherical primitive offer a selection
of measurement frames. All other joint blocks resolve their measurements
in the base frame. The Transform Sensor block offers the most extensive
selection of measurement frames.

Measurement Frame Types

SimMechanics offers five different measurement frames. These include World
as well as rotating and non-rotating versions of the base and follower frames.
The table describes these measurement frames.

Measurement Frame Description

World Inertial frame at absolute rest.
World is the ultimate reference
frame in a model. The World Frame
block identifies this frame in a
model.

Base Frame that connects to the B port of
the sensing block. Unless you rigidly
connect it to World, Base is generally
non-inertial.




Measurement Frames

Related
Examples

Concepts

Measurement Frame

Description

Follower

Frame that connects to the F port
of the sensing block. Unless you
rigidly connect it to World, Follower
is generally non-inertial.

Non-Rotating Base/Follower

Non-rotating versions of the Base
and follower frames.

A non-rotating frame is a virtual
frame which, at every point in time,
SimMechanics holds coincident with
the rotating frame, but which has
zero angular velocity with respect to
the World frame.

Measurements that can differ
between rotating and non-rotating
frames are the linear velocity and
linear acceleration.

® “Sense Motion in Double-Pendulum Model” on page 4-50
e “Actuate Joint in Four-Bar Model” on page 4-57

e “Motion Sensing” on page 4-29

¢ “Rotational Measurements” on page 4-34

“Translational Measurements” on page 4-39
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Sense Motion in Double-Pendulum Model

In this section...

“Model Overview” on page 4-50
“Modeling Approach” on page 4-51
“Build Model” on page 4-52

“Guide Model Assembly” on page 4-53
“Simulate Model” on page 4-53

“Save Model” on page 4-56

Model Overview

The Transform Sensor block provides the broadest motion-sensing capability
in SimMechanics models. Using this block, you can sense motion variables
between any two frames in a model. These variables can include translational
and rotational position, velocity, and acceleration.

In this example, you use a Transform Sensor block to sense the lower link
translational position with respect to the World frame. You output the
position coordinates directly to the model workspace, and then plot these
coordinates using MATLAB commands. By varying the joint state targets you
can analyze the lower-link motion under quasi-periodic and chaotic conditions.



Sense Motion in Double-Pendulum Model

Modeling Approach

In this example, you rely on gravity to cause the double pendulum to move.
You displace the links from equilibrium and then let gravity act on them. To
displace the links at time zero, you use the State Targets section of the
Revolute Joint block dialog box. You can specify position or velocity. When
you are ready, you simulate the model to analyze its motion.

To sense motion, you use the Transform Sensor block. First, you connect the
base and follower frame ports to the World Frame and lower link subsystem
blocks. By connecting the ports to these blocks, you can sense motion in the
lower link with respect to the World frame. Then, you select the translation
parameters to sense. By selecting Y and Z, you can sense translation along
the Y and Z axes, respectively. You can plot these coordinates with respect to
each other and analyze the motion that they reveal.
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Build Model

1 At the MATLAB command prompt, enter smdoc_double pendulum. A
double pendulum model opens up. For instructions on how to create this
model, see “Model Double Pendulum” on page 3-26.

2 Drag these blocks into the model to sense motion.

Library Block Quantity

SimMechanics > Seconbransform Sensor 1
Generation > Frames
and Transforms

SimMechanics > SeconWorld Frame 1
Generation > Frames
and Transforms

Simscape > Utilities | PS-Simulink 2
Converter
Simulink > Sinks To Workspace 2

3 In the Transform Sensor block dialog box, select Translation > Y and
Translation > Z. The block exposes two physical signal output ports,
labeled y and z.

4 In the PS-Simulink Converter blocks, specify units of cm.
5 In the To Workspace blocks, enter the variable names 'y link and z_1link.

6 Connect the blocks to the model as shown in the figure. You must connect
the base frame port of the Transform Sensor block to the World Frame
block. The new blocks are shaded gray.
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Guide Model Assembly

Specify the initial state of each joint. Later, you can modify this state to
explore different motion types. For the first iteration, rotate only the top
link by a small angle.

1 In the Revolute Joint block dialog box, select State Targets > Specify
Position Target.

2 Set Value to 10 deg.

3 In the Revolute Jointl block dialog box, check that State
Targets > Specify Position Target is cleared.

Simulate Model

Run the simulation. Mechanics Explorer plays a physics-based animation
of the double pendulum assembly.
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You can now plot the position coordinates of the lower link. To do this, at
the MATLAB command line, enter:

figure;

plot(y_link.data, z_link.data, 'color', [60 100 175]/255);
xlabel('Y Coordinate (cm)');

ylabel('Z Coordinate (cm)');

grid on;

The figure shows the plot that opens. This plot shows that the lower link path
varies only slightly with each oscillation. This behavior is characteristic of
quasi-periodic systems.



Sense Motion in Double-Pendulum Model

-0.585 T T T T

B o

Z Coordinate (cm)

V1) S A Lo

______________________________

____________________

0.05
Y Coordinate {cm)

6 i
-0.2 -0.15 0.1

Simulate Chaotic Motion

By adjusting the revolute joint state targets, you can simulate the model
under chaotic conditions. One way to obtain chaotic motion is to rotate the top
revolute joint by a large angle. To do this, in the Revolute Joint dialog box,
change State Targets > Position > Value to 90 and click OK.

Simulate the model with the new joint state target. To plot the position
coordinates of the lower pendulum link with respect to the world frame, at the

MATLAB command line enter this code:

figure;

plot(y_link.data, z_link.data,
xlabel('Y Coordinate (cm)');
ylabel('Z Coordinate (cm)');
grid on;

'color',

[60 100 175]/255);
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The figure shows the plot that opens. This plot shows that lower link path is
very different with each oscillation. This behavior is characteristic of chaotic
systems.

- : : : : : :

Z Coordinate (cm)

Y Coordinate {cm)

Save Model

Save the model in a convenient folder under the name
double pendulum_sensing. You reuse this model in a subsequent
tutorial, “Prescribe Joint Motion in Planar Manipulator Model” on page 4-105.

4-56



Actuate Joint in Four-Bar Model

Actuate Joint in Four-Bar Model

In this section...

“Model Overview” on page 4-57
“Four-Bar Linkages” on page 4-58
“Modeling Approach” on page 4-61
“Build Model” on page 4-62

“Simulate Model” on page 4-65

Model Overview

In SimMechanics, you actuate a joint directly using the joint block. Depending
on the application, the joint actuation inputs can include force/torque or
motion variables. In this example, you prescribe the actuation torque for a
revolute joint in a four-bar linkage model.

Transform Sensor blocks add motion sensing to the model. You can plot the
sensed variables and use the plots for kinematic analysis. In this example,
you plot the coupler curves of three four-bar linkage types: crank-rocker,
double-crank, and double-rocker.
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Four-Bar Linkages

The four-bar linkage contains four links that interconnect with four revolute
joints to form a planar closed loop. This linkage converts the motion of an
input link into the motion of an output link. Depending on the relative
lengths of the four links, a four-bar linkage can convert rotation into rotation,
rotation into oscillation, or oscillation into oscillation.

Links

Links go by different names according to their functions in the four-bar
linkage. For example, coupler links transmit motion between crank and
rocker links. The table summarizes the different link types that you may find

in a four-bar linkage.

Link

Motion

Crank

Revolves with respect to the ground
link

Rocker

Oscillates with respect to the ground
link
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Link Motion

Coupler Transmits motion between crank
and rocker links

Ground Rigidly connects the four-bar linkage
to the world or another subsystem

It is common for links to have complex shapes. This is especially true of the
ground link, which may be simply the fixture holding the two pivot mounts
that connect to the crank or rocker links. You can identify links with complex
shapes as the rigid span between two adjacent revolute joints. In example
“Model Four Bar” on page 3-31, the rigid span between the two pivot mounts
represents the ground link.

Linkages

The type of motion conversion that a four-bar linkage provides depends on
the types of links that it contains. For example, a four-bar linkage that
contains two crank links converts rotation at the input link into rotation at
the output link. This type of linkage is known as a double-crank linkage.
Other link combinations provide different types of motion conversion. The
table describes the different types of four-bar linkages that you can model.

Linkage Input-Output Motion

Crank-rocker Continuous rotation-oscillation (and
vice-versa)

Double-Crank Continuous rotation-continuous
rotation

Double-rocker Oscillation-oscillation

Grashof Condition

The Grashof theorem provides the basic condition that the four-bar linkage
must satisfy so that at least one link completes a full revolution. According
to this theorem, a four-bar linkage contains one or more crank links if

the combined length of the shortest and longest links does not exceed the
combined length of the two remaining links. Mathematically, the Grashof
condition is:

4-59



4 inierndl Mechanics, Actuation and Sensing

4-60

s+l < p+q
where:

® s 1s the shortest link
¢ 1is the longest link

® p and q are the two remaining links

Grashof Linkages
A Grashof linkage can be of three different types:

¢ Crank-rocker

® Double-crank

® Double-rocker

By changing the ground link, you can change the Grashof linkage type. For
example, by assigning the crank link of a crank-rocker linkage as the ground

link, you obtain a double-crank linkage. The figure shows the four linkages
that you obtain by changing the ground link.
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Crank-Rocker | Crank-Rocker 1l

Double-Crank Double-Rocker

Modeling Approach

In this example, you perform two tasks. First you add a torque actuation input
to the model. Then, you sense the motion of the crank and rocker links with
respect to the World frame. The actuation input is a torque that you apply to
the joint connecting the base to the crank link. Because you apply the torque
at the joint, you can add this torque directly through the joint block. The block
that you add the actuation input to is called Base-Crank Revolute Joint.

You add the actuation input to the joint block through a physical signal input

port. This port is hidden by default. To display it, you must select Provided
by Input from the Actuation > Torque drop-down list.
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You can then specify the torque value using either Simscape or Simulink
blocks. If you use Simulink blocks, you must use the Simulink-PS Converter
block. This block converts the Simulink signal into a physical signal that
SimMechanics can use. For more information, see “Actuating and Sensing
Using Physical Signals” on page 4-13.

To sense crank and rocker link motion, you use the Transform Sensor block.
With this block, you can sense motion between any two frames in a model. In
this example, you use it to sense the [Y Z] coordinates of the crank and rocker
links with respect to the World frame.

The physical signal output ports of the Transform Sensor blocks are hidden
by default. To display them, you must select the appropriate motion outputs.
Using the PS-Simulink Converter, you can convert the physical signal outputs
into Simulink signals. You can then connect the resulting Simulink signals to
other Simulink blocks.

In this example, you output the crank and rocker link coordinates to the
workspace using Simulink To Workspace blocks. The output from these
blocks provide the basis for phase plots showing the different link paths.

Build Model

Provide the joint actuation input, specify the joint internal mechanics, and
sense the position coordinates of the coupler link end frames.

Provide Joint Actuation Input

1 At the MATLAB command prompt, enter smdoc_four_bar. A four bar
model opens up. For instructions on how to create this model, see “Model
Four Bar” on page 3-31.

2 Drag these blocks into the model to specify the actuation torque signal.

Library Block
Simulink > Sources Constant
Simscape > Utilities Simulink-PS Converter
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3 In the Base-Crank Revolute Joint block dialog box, in the
Actuation > Torque drop-down list, select Provided by Input. The
block exposes a physical signal input port, labeled t.

4 Connect the blocks as shown in the figure. The new blocks are shaded gray.
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5 In the Input Signal Unit parameter of the Simulink-PS Converter block
dialog box, enter N*m and click OK.
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Specify Joint Internal Mechanics

Real joints dissipate energy due to damping. You can specify joint damping
directly in the block dialog boxes. In Internal Mechanics > Damping enter
5e-4 and press OK.

Sense Link Position Coordinates
1 Add these blocks to the model.

Block Library Quantity

Transform Sensor SimMechanics > Fram@s
and Transforms

World Frame SimMechanics > Framaés
and Transforms

PS-Simulink Simscape > Utilities | 4
Converter
To Workspace Simulink > Sinks 4

2 In the Transform Sensor block dialog boxes, select Translation > Y and
Translation > Z.

3 In the Input Signal Unit parameters of the PS-Simulink Converter block
dialog boxes, enter cm.

4 In the Variable Name parameters of the To Workspace block dialog boxes,
enter these SimMechanics variables:

® y crank
® z crank
® y rocker

® z rocker

5 Connect and name the blocks as shown in the figure. The new blocks are
shaded gray.



Actuate Joint in Four-Bar Model

Waorld Frame1 —
T
5
= E = El
Transform ;{ Transform f{
Sensor P! Q PS-Simulink Sensart P! @
WL o M Converter To Works pace L x> N
1Y 1t Y
{>PS S | y_crank y_rocker | SPS F
—» -—
{>PS S | z_crank Z_rocker |4 SPS
—» -
Fl-l Conn1 Conn2
| |
[ | crank-Coupler A Coupler-Rodker [
) | Rewlte Joint S Revolute Joint )
L L
o~ o~
c c
g g
= Binary Lirk A Binary Link A1 =
t t
=3 =3
a a
Fl'l SEEIEIE Solver Fl'l
] Configuration Configuration ]
_|'r Base Crank {j\“ BaseRoder ,'r
) | Revolute Joint l-.\ - C[E—a—A fixi=0 Revolute Joint J
L '-'\) ]
[] []
Conn2? Conni mr < B[E 15 </ [H4——|Conni ConnZ
A = )=
Simulink-PS 2 T Crank-Base Transform Rodeer-Base Transform
Comerter| Pheot Mount Pivot Mount
1 el
=
Constant [ 1 s Waorld Frame
Frrad

Simulate Model

Run the simulation. You can do this in the Simulink tool bar by clicking
the run button. Mechanics Explorer plays a physics-based animation of the
four bar assembly.
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Once the simulation ends, you can plot the position coordinates of the coupler
link end frames. At the MATLAB command line, enter this code:

figure;

plot(y_crank.data, z_crank.data, 'color', [60 100 175]/255);
hold;

plot(y_rocker.data, z_rocker.data, 'color', [210 120 0]/255);
axis([-30 30 -30 30]);

xlabel('Y Coordinate (cm)');

ylabel('Z Coordinate (cm)');

axis equal; grid on;

The figure shows the plot that opens. This plots shows that the crank
completes a full revolution, while the rocker completes a partial revolution,
e.g., it oscillates. This behavior is characteristic of crank-rocker systems.
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Simulate Model in Double-Crank Mode

Try simulating the model in double-crank mode. You can change the four-bar
linkage into a double-crank linkage by changing the binary link lengths

according to the table.

Block Parameter Value
Binary Link A Length 0.25
Binary Link B Length 0.20
Binary Link A1l Length 0.30
Crank-Base Transform | Translation > Offset | 0.05
Rocker-Base Transform | Translation > Offset | 0.05

Update and simulate the model. The figure shows the updated visualization

display in Mechanics Explorer.
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Plot the position coordinates of the coupler link end frames. At the MATLAB
command line, enter:

figure;

plot(y_crank.data, z_crank.data, 'color', [60 100 175]/255);
hold;

plot(y_rocker.data, z_rocker.data, 'color', [210 120 0]/255);
axis([-40 40 -40 40]);

xlabel('Y Coordinate (cm)');

ylabel('Z Coordinate (cm)');

axis equal; grid on;

The figure shows the plot that opens. This plots shows that both links
complete a full revolution. This behavior is characteristic of double-crank
linkages.
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Perform Parameter Sweep in Four-Bar Model

In this section...

“Model Overview” on page 4-70
“Build Model” on page 4-71
“Specify Block Parameters” on page 4-73

“Create Simulation Script” on page 4-74

“Run Simulation Script” on page 4-75

Model Overview

In this tutorial, you create a simple MATLAB script to simulate a four-bar
model at various coupler lengths. The script uses the coupler motion
coordinates, obtained using a Transform Sensor block, to plot the resulting
coupler curve at each value of the coupler length. For information on how
to create the four-bar model used in this tutorial, see “Model Four Bar” on
page 3-31.




Perform Parameter Sweep in Four-Bar Model

Build Model

1 At the MATLAB command prompt, enter smdoc_four_bar. A four-bar
model opens up. For instructions on how to create this model, see “Model
Four Bar” on page 3-31.

2 Under the mask of the Binary Link B block, connect a third Outport
block as shown in the figure. You can add an Outport block by copying
and pasting Connl or Conn2. The new block identifies the frame whose
trajectory you plot in this tutorial.

Rigid Transform Rigid Transformi

P i e s s VL i ©
1HDEA. 1h‘hjn 1HDEE

3 Add the following blocks to the model. During simulation, the Transform
Sensor block computes and outputs the coupler trajectory with respect
to the world frame.

Library Block Quantity
Frames and World Frame 1
Transforms

Frames and Transform Sensor 1
Transforms

Simscape Utilities PS-Simulink 2

Converter
Simulink Sinks Outport 2
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4 In the Transform Sensor block dialog box, select these variables:

e Translation>Y

* Translation > Z
The block exposes frame ports y and z, through which it outputs the coupler

trajectory coordinates.

5 Connect the blocks as shown in the figure. Be sure to flip the Transform
Sensor block so that its base frame port, labeled B, connects to the World

Frame block.
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Specify Block Parameters

1 In the Mechanism Configuration block, change Uniform Gravity to None.

2 In the Base-Crank Revolute Joint block, specify the following velocity state
targets. The targets provide an adequate source of motion for the purposes

of this tutorial.
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e Select State Targets > Specify Velocity.
¢ In State Targets > Specify Velocity > Value, enter 2 rev/s.
® Deselect State Target > Specify Position.
3 Specify the following link lengths. The coupler link length is parameterized

in terms of a MATLAB variable, LCoupler, enabling you change its value
iteratively using a simple MATLAB script.

Block Parameter Value
Binary Link B Length LCoupler
Binary Link A1l Length 25

4 Save the model in a convenient folder, naming it smdoc_four_bar_msensing.

Create Simulation Script

Create a MATLAB script to iteratively run simulation at various coupler
link lengths:

1 On the MATLAB toolstrip, click New Seript.
2 In the script, enter the following code:

% Run simulation nine times, each time
% increasing coupler length by 1 cm.
% The original coupler length is 20 cm.
for i = (0:8);

LCoupler = 20+i;

% Simulate model at the current coupler link length (LCoupler),
% saving the Outport block data into variables y and z.
[~, ~, ¥, z] = sim('smdoc_four_bar_msensing');

% Plot the [y, z] coordinates of each coupler curve

% on the x = i plane. i corresponds to the simulation run number.
X = zeros(size(y)) + 1ij;

plot3(x, y, z, 'Color', [1 0.8-0.1*i 0.8-0.1*i]);

view (30, 60); hold on;

end
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The code runs simulation at nine different coupler link lengths. It then
plots the trajectory coordinates of the coupler link center frame with
respect to the world frame. Coupler link lengths range from 20 cm to 28 cm.

3 Save the script as sim_four_bar in the folder containing the four-bar model.

Run Simulation Script
Run the sim_four_bar script. In the MATLAB Editor toolstrip, click the Run
button or, with the editor active, press F5. Mechanics Explorer opens with a

dynamic 3-D view of the four-bar model.

=

k.

SimMechanics iteratively runs each simulation, adding the resulting coupler
link curve to the active plot. The figure shows the final plot.
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You can use the simple approach shown in this tutorial to analyze model
dynamics at various parameter values. For example, you can create a
MATLAB script to simulate a crank-slider model at different coupler link
lengths, plotting for each simulation run the constraint force acting on the
piston.
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Sense Forces and Torques at Joints

In this section...

“Overview” on page 4-77

“Open Model” on page 4-78

“Sense Actuation Torque” on page 4-78
“Sense Constraint Forces” on page 4-81

“Sense Total Forces” on page 4-83

Overview

SimMechanics provides force and torque sensing in joint blocks. You can use
this sensing capability to compute and output various types of forces and
torques acting directly at joints. Force and torque types that you can sense
include those attributable to:

® Joint actuation inputs
® Joint constraints

® Joint actuation inputs, constraints, and internal mechanics combined

In this tutorial, you explore the different types of force and torque sensing
that SimMechanics joint blocks provide.
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Open Model

At the MATLAB command prompt, enter smdoc_rack_pinion_c.
SimMechanics opens a rack and pinion model that you can use to explore the
force and torque sensing capability of joint blocks.
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Sense Actuation Torque

The rack and pinion model contains an actuation torque input that drives
the pinion revolute joint. A Simulink-PS Converter block processes the
input signal using a second-order filter, smoothing any abrupt changes
or discontinuities the signal may have. To sense the actuation torque as
observed at the Revolute Joint block:
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1 In the Revolute Joint block dialog box, select Z Revolute Primitive
(Rz) > Sensing > Actuator Torque. The block exposes a physical signal
port, labeled t. This port outputs the 3-D vector components of the joint
actuator torque in a Simscape physical signal.

2 Drag the following blocks into the model:

¢ PS-Simulink Converter from the Simscape > Utilities library

¢ To Workspace from the Simulink > Sinks library

3 Connect the blocks as shown in the figure.
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4 Simulate the model, e.g., by pressing Ctrl+D. The To Workspace block
outputs the actuator torque signal into a time-series variable, simout,
available in the MATLAB base workspace.

5 At the MATLAB command prompt, enter:

figure;
plot(simout);

MATLAB plots the vector components of the joint actuator torque. All but
the Z component are zero throughout the simulation.

T T T T T T T T T

Compare the actuator torque plot to the original input signal in the Signal
Builder block. Neglecting any signal smoothing due to the second-order
filtering, the two signals are identical. The following figure shows the
original input signal.
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Signal 1

Actuator force and torque sensing enables you to analyze the required forces
and torques to yield a prescribed joint trajectory. Use this feature in your
model to perform inverse dynamic and other types of analysis.

Sense Constraint Forces

Joint constraint forces, which act normal to the joint primitive axes, restrict
motion to the allotted joint degrees of freedom. In the Revolute Joint block,
the constraint forces resist the pull of gravity, keeping the pinion fixed with
respect to the world frame. To sense the constraint forces:

1 In the Mechanism Configuration block, set Uniform Gravity to Constant.
This setting ensures that gravity acts on the rack and pinion system.
Check that the gravity vector is [0 0 -9.80665].

2 In the Revolute Joint block dialog box, select Composite Force/Torque
Sensing > Constraint Force. The block exposes the physical signal port
fc. This port provides the vector components of the joint-wide constraint
force in a Simscape physical signal. By default, this is the constraint force
that the follower port frame exerts on the base port frame, resolved in
the base port frame.
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3 Deselect Z Revolute Primitive (Rz) > Sensing > Actuator Torque.

4 Check that the PS-Simulink Converter block now connects to the physical
signal port fc.

5 Simulate the model. At the MATLAB command prompt, enter:

figure;
plot(simout);

MATLAB plots the constraint force components with respect to time. All
but one component are zero throughout simulation. The Z component,
which opposes the gravity vector, is the only component needed to hold the
joint frames in place.

T T T T T T T T T

Constraint forces ensure that weld joint frames remain fixed with respect to
each other. You can place a Weld Joint block inside a rigid body subsystem
to sense the internal forces and torques acting within that body during
simulation. For an example of how you can do this in a double pendulum
model, see “Sense Internal Forces in Double-Pendulum Link” on page 4-85.



Sense Forces and Torques at Joints

Sense Total Forces

In addition to actuation and constraint forces and torques, joint frames can
also interact by exchanging internal forces and torques. These forces and
torques, which are due to spring and damper elements internal to the joint
itself, enable you to account for mechanical energy dissipation and storage
between the joint frames. You can sense the total composite force and torque
acting at a joint, which includes contributions from actuation, constraint, and
internal forces and torques. To sense the total torque acting between the port
frames of the Revolute Joint block:

1 In the Revolute Joint block dialog box, select Composite Force/Torque
Sensing > Total Torque. The block exposes the physical signal port tt.
This port outputs the total torque acting between the joint frames as a
Simscape physical signal.

2 Deselect Composite Force/Torque Sensing > Constraint Force.
3 Simulate the model.
4 At the MATLAB command prompt, enter:

figure;
plot(simout);

MATLAB plots the vector components of the total torque vector as a
function of time. All but one component are zero throughout simulation.
The nonzero component, a torque directed about the Z axis, contains
torque contributions from actuation and internal torques, but none from
constraint torques.
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The torque peaks correspond to the actuation torque values specified in the
input signal. These peaks decay with time due to the internal damping
torques specified in the Revolute Joint block dialog box. The damping
torques cause the energy dissipation evident in the transient portions of
the total torque plot.

To verify that the total torque excludes any contribution from constraint
torques, try sensing the constraint torques directly. A plot of the constraint
torques will show that they are in fact negligible.



Sense Internal Forces in Double-Pendulum Link

Sense Internal Forces in Double-Pendulum Link

In this section...

“Model Overview” on page 4-85

“Add Weld Joint Block to Model” on page 4-87
“Add Constraint Force Sensing” on page 4-87
“Add Damping to Joints” on page 4-89
“Simulate Model” on page 4-89

“Plot Constraint Forces” on page 4-90

Model Overview

SimMechanics provides various types of force and torque sensing. Using joint
blocks, you can sense the actuation forces and torques driving individual joint
primitives. You can also sense the total and constraint forces acting on an
entire joint.

In this tutorial, you use a Weld Joint block to sense the time-varying
internal forces that hold a rigid body together. A double-pendulum model,
smdoc_double pendulum, provides the starting point for the tutorial. For
information on how to create this model, see “Model Double Pendulum” on
page 3-26.
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By connecting the Weld Joint block between solid elements in a binary link
subsystem, you can sense the constraint forces acting between them. The
following figure shows the constraint forces that you sense in this tutorial.
The longitudinal constraint force aligns with the X axis of the weld joint
frames. The transverse constraint force aligns with the Y axis. The constraint
force along the Z axis is negligible and therefore ignored.

/TN
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The Weld Joint block enables you to sense the constraint force that the
follower frame exerts on the base frame or, alternatively, the constraint
force that the base frame exerts on the follower frame. The two forces have



Sense Internal Forces in Double-Pendulum Link

the same magnitude but, as shown in the binary link schematic, opposite
directions. In this tutorial, you sense the constraint force that the follower
frame exerts on the base frame.

You can also select the frame that you wish to resolve the constraint force
measurement in. The resolution frame can be either the base frame or the
follower frame. Certain joint blocks allow their port frames to have different
orientations, causing the same measurement to differ depending on your
choice of resolution frame. However, because the Weld Joint block provides
zero degrees of freedom, both resolution frames yield the same constraint
force vector components.

Add Weld Joint Block to Model

1 At the MATLAB command prompt, enter smdoc_double pendulum. A
double-pendulum model opens up.

2 Click the Look Inside Mask arrow in the Binary Link A1 subsystem block.

3 From the SimMechanics > Second Generation > Joints library, drag a
Weld Joint block.

4 Connect the Weld Joint block as shown in the figure. This block enables
you to sense the constraint forces that hold the rigid body together during
motion. Because it provides zero degrees of freedom between its port
frames, it has no effect on model dynamics.

Rigid Transform Rigid Transform 1

& I '»-'-’"‘iw 'EJ-'?E ’“‘ir'é.%z
- O I~

J1

Add Constraint Force Sensing

1 In the Weld Joint block dialog box, select Constraint Force. The block
exposes a physical signal output port labeled fe.
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2 Add a Simscape Output port to the subsystem block diagram. Connect the
block as shown in the figure and exit the subsystem view.

Rigid Transform ,»':
. ‘B— 58 7%
' |7 < E— = | )=
S N
Weld Joint
' Haole: ' Main
Conn3

Rigid Transform

=

=3~

3 Drag the following blocks into the main window of the model. These
blocks enable you to output the constraint force signal into the MATLAB

workspace.

Library

Block

Simscape > Utilities

PS-Simulink Converter

Simulink > Sinks

To Workspace

4 Connect the blocks as shown in the figure. Check that the PS-Simulink
Converter block connects to the newly added Simscape port.

Mecharism |,

Configuration |
igur aticn T
Lyl
- Conn [E]
—.wE 2] Conni ConnZ [H—F1B _::LE—E Conni Conn2 [H—F] B _::r:E—E Conni
L il il Carrﬂpl}—[:-FSS | fof w
World Frame Revolute Joint Rewolute Joint1 — ‘
Pivot Mount Binary Link A Binary Link A1 P53 Simulink  To Work
Comverter
fl)=10
Sohver
Configuration
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5 Specify these block parameters.

Block Dialog Box Value
Parameter

PS-Simulink Output signal unit mN

Converter

To Workspace Variable name fcf_weld

Units of mN are appropriate for this model, which contains Aluminum links
roughly 30 cm X 2 ¢cm X 0.8 cm.

Add Damping to Joints

In each Revolute Joint block dialog box, select Internal

Mechanics > Damping Coefficient and enter 1e-5. The

damping coefficient enables you to model energy dissipation during motion, so
that the double-pendulum model eventually comes to rest.

Simulate Model

Run the simulation. You can do this from the Simulink Editor menu bar, by
selecting Simulation > Run. Mechanics Explorer opens with a dynamic view
of the model. In the Mechanics Explorer menu bar, select the Isometric View
button to view the double pendulum from an isometric perspective.
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k.

During simulation, the To Workspace block outputs the constraint force
measurement to the MATLAB base work space in a time-series format. The
To Workspace variable fef_weld contains the measurement.

Plot Constraint Forces
At the MATLAB command prompt, enter the following plot commands:

figure;

grid on;

xlabel('T, s');

ylabel('F_{C,X}, mN'");

zlabel('F_{C,Y}, mN');

plot3(fcf_weld.time, fcf_weld.data(:,1), fcf_weld.data(:,2),...
“.', 'MarkerSize', 1, 'Color', 'r');

MATLAB plots the axial and transverse constraint forces with respect to time
in 3-D. The figure shows the resulting plot.



Sense Internal Forces in Double-Pendulum Link

Change the plot view point to expose hidden detail. You can do this using the
MATLAB view command. For example, to view just the transverse constraint
force, Fy, with respect to time, at the MATLAB command prompt, enter
view(0,0). MATLAB updates the plot as shown below.
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To view just the longitudinal constraint force with respect to time, at the
MATLAB command prompt, enter view(0, 90). As expected, the constraint
forces oscillate in time, gradually decaying until the double-pendulum comes
to rest as a result of joint damping.
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Finally, to view just the transverse and longitudinal force components, at the
MATLAB command prompt, enter view (90, 0).

4-93



4 inierndl Mechanics, Actuation and Sensing

4-94

Note that the longitudinal constraint force component dominates throughout
simulation due to gravity. The transverse constraint force component is
nearly an order of magnitude smaller, and disappears altogether each time
the two binary links become mutually aligned. To verify that this is the case:

1 Use the plot data cursor to obtain the coordinates of any point with a zero
Fy coordinate.

2 Enter the X coordinate, corresponding to the time at which Fy equals
zero, in the Current Animation Time field of the Mechanics Explorer
Animation Control panel.

| ® 1x —_— |Time|4s5

Mechanics Explorer shows the animation frame corresponding to the time
entered. The following figure shows this frame. Note the double-pendulum
configuration, which consists of the two binary links in longitudinal alignment.
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Prescribe Joint Motion in Four-Bar Model

In this section...

“Model Overview” on page 4-96

“Build Model” on page 4-96

“Simulate Model” on page 4-99

“Actuate Model Using Sensed Torque” on page 4-101
“Guide Model Assembly” on page 4-102

“Simulate Updated Model” on page 4-103

Model Overview

In this tutorial, you prescribe the time-varying crank angle of a four-bar
linkage using a Revolute Joint block. Then, during simulation, you sense the
actuation torque at the same joint corresponding to the prescribed motion.

{4}

Build Model

1 At the MATLAB command prompt, enter smdoc_four_bar. A four-bar
model opens. You can see how to create this model in the tutorial “Model
Four Bar” on page 3-31.



Prescribe Joint Motion in Four-Bar Model

2 In the Mechanism Configuration block, set Uniform Gravity to None.

3 In the dialog box of the Base-Crank Revolute Joint block, specify the
following parameters settings.

Parameter Setting

Actuation > Torque Automatically Computed
Actuation > Motion Provided by Input
Sensing > Actuator Torque Selected

The joint block displays two physical signal ports. Input port q accepts the
joint angular position. Output port t provides the joint actuation torque
required to achieve that angular position.

4 In each of the four Revolute Joint block dialog boxes, set Internal
Mechanics > Damping Coefficient to 5¢-4 N*m/ (deg/s). During
simulation, damping forces between the joint frames account for dissipative
losses at the joints.

5 Drag the following blocks into the model.

Block Library

Simulink-PS Converter Simscape > Utilities
PS-Simulink Converter Simscape > Utilities
To Workspace Simulink > Sinks
Scope Simulink > Sinks
Signal Builder Simulink > Sources

6 Connect the bocks as shown in the figure.
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7 Specify the following block parameters.
Block Parameter Value
To Workspace Variable name tcrank
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Input
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Filter input

Input
Handling > Input
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Second-order
filtering




Prescribe Joint Motion in Four-Bar Model

8 In the Signal Builder window, specify the joint angular trajectory as shown
in the figure.

10

o = e W
T

e

Time (sec)

This signal corresponds to a constant angular speed of 1 rad/s from t =
1s onwards.

Simulate Model

Run the simulation, e.g., by selecting Simulation > Run from the Simulink
menu bar. Mechanics Explorer opens with a dynamic display of the four-bar
model.
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Open the Scope window. The scope plot shows the joint actuation torque with
which you can achieve the motion you prescribed.
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o

Time offzet: 0
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Actuate Model Using Sensed Torque

Change actuation mode from motion input to torque input. Then, verify that
the angular velocity of the Base-Crank Revolute Joint block equals 1 rad/s,
corresponding to the original motion input prescribed.

1 Delete the Signal Builder and To Workspace blocks.

2 In the dialog box of the Base-Crank Revolute Joint block, change these
parameter settings.

Parameter Original Setting Change to...
Actuation > Torque | Automatically Provided by Input
computed
Actuation > Motion | Provided by Input Automatically
Computed
Sensing > Velocity Cleared Selected
Sensing > Actuator | Selected Cleared

Torque

3 From the Simulink Sources library, drag a From Workspace block and
connect it as shown in the figure.
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4 In the From Workspace block dialog box, set the Data parameter to
tcrank. This parameter provides the sensed actuation torque of the
original motion-actuated model.

Guide Model Assembly

For the sensed actuation torque to yield the original prescribed motion, the
Initial joint states of the two model versions (one with the original prescribed
motion as input, the other with the sensed actuation torque as input) must
be the same.



Prescribe Joint Motion in Four-Bar Model

When a model has joints with motion inputs, those inputs dictate the initial
joint states. This statement is true even if the joints contain state targets.
The targets serve as guides during initial model assembly, but the motion
inputs override them at simulation time t =0 s.

In this example, to ensure that the sensed actuation torque produces the
original motion input, you set the initial angle of the Base-Crank Revolute
Joint block to zero degrees. This value is the initial angle that the original
motion input prescribes.

1 In the dialog box of the Base-Crank Revolute Joint block, select State
Targets > Specify Position Target.

2 Set Value to 0 and select OK.

Simulate Updated Model

Run the simulation. Mechanics Explorer displays the updated model. Click
the isometric view button for a 3-D viewpoint of the model.

Open the Scope window. The scope plot shows that the angular velocity of
the crank joint is 1 rad/s, which matches the original motion input. For
greater precision, try reducing the filtering time constant in the PS-Simulink
Converter block, e.g., to 0.001 s.
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Time offzet: 0

The angular velocity remains constant at 1 rev/s from t = 1 s onward, as
prescribed in the original motion input.

Related ® “Sense Motion in Double-Pendulum Model” on page 4-50
Exqmples ® “Prescribe Joint Motion in Planar Manipulator Model” on page 4-105
® “Specify Motion Input Derivatives” on page 4-10
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Prescribe Joint Motion in Planar Manipulator Model

In this section...

“Model Overview” on page 4-105

“Add Virtual Joint” on page 4-106

“Prescribe Motion Inputs” on page 4-107
“Sense Joint Actuation Torques” on page 4-110

“Simulate Model” on page 4-111

Model Overview

In this tutorial, you prescribe the time-varying trajectory coordinates of a
planar manipulator end frame with respect to the world frame using a 6-DOF
Joint block. This block provides the requisite degrees of freedom between
the two frames, but it does not represent a real physical connection between
them. The joint it represents is said to be virtual.

The time-varying coordinates trace a square pattern, achieved by
automatically computing and applying actuation torques at the various
manipulator joints. During simulation, you can output the automatically
computed torques and plot them using Simulink blocks or MATLAB
commands, e.g. for analysis purposes.
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Add Virtual Joint

1 At the MATLAB command prompt, enter smdoc_double_pendulum. A
double pendulum model, which in this tutorial you adapt as a simple planar
manipulator model, opens. For instructions on how to create this model,
see “Model Double Pendulum” on page 3-26

2 From the SimMechanics > Second Generation > Joints library, drag
a 6-DOF Joint block and connect it as shown in the figure. This block
represents a virtual joint, which you use to specify the manipulator end
frame with respect to the world frame.



Prescribe Joint Motion in Planar Manipulator Model

[H

Conni Conn2 H——FE1B }E—E-Corr' Conn2 H——F1| B }E—E-Corr' ConnZ 54—
il il
Revelute Joint Revolute Joint1
Piwot Mount Binary Link A Binary Link A1

6-DOF Joint

Note Check that the base port frame (B) connects to the world frame.
The base port frame functions as the reference frame for any joint motion
input that you provide. Switching the base and follower port frames causes
the block to interpret any motion input with respect to a different frame,
possibly altering the manipulator end frame trajectory.

Prescribe Motion Inputs

1 In the 6-DOF Joint block dialog box, specify these parameters settings.

Parameter Select

Y Prismatic Primitive Provided by Input
(Py) > Actuation > Motion

Z Prismatic Primitive Provided by Input

(Pz) > Actuation > Motion

The block exposes two physical signal ports through which you can provide
the joint motion inputs.
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2 Drag these blocks into the model.

Library Block Quantity

Simscape > Utilities Simulink-PS 2
Converter

Simulink > Sources  Signal Builder 2

The Signal Builder blocks provide the motion inputs as Simulink signals.
The Simulink-PS Converter blocks convert the Simulink signals into
Simscape physical signals compatible with SimMechanics blocks.

3 Connect the blocks as shown in the figure.

World Frame

fx)=0

Configuration

L] Connl Conn2 [H——H] Eb’.} [—F]Conn1 ConnZ [H———F] Eb’.} [H—F] Connt ConnZ [9—
Revolute Joint Rewolute Joint1
Pivot Mount Binary Link A Binary Link A1

Comerter

4 Open the dialog box of the Signal Builder block connected to port py of the
6-DOF Joint block. Specify this signal, the time-varying Y coordinate of the
square trajectory the manipulator end frame is to follow.



Prescribe Joint Motion in Planar Manipulator Model

Time (sec)

5 Open the dialog box of the Signal Builder block connected to port pz of the
6-DOF Joint block. Specify this signal, the time-varying Z coordinate of
the square trajectory the manipulator end frame is to follow.

50

40

Time (sec)

6 In the dialog boxes of the Simulink-PS Converter blocks, specify the input
signal units and filtering settings. SimMechanics requires that you either
specify second-order filtering or provide the first two time derivatives of

the trajectory coordinates.
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Parameter Value

Units > Input signal unit cm

Input Handling > Filtering and | Filter input
derivatives

Input Handling > Input Second-order filtering
filtering order

Input Handling > Input 0.1

filtering time constant (in

seconds)

Small filtering constants can slow simulation significantly. For most
SimMechanics models, a value of 0.1 seconds is a good choice. In this
tutorial, this value suffices.

Sense Joint Actuation Torques

1 In the dialog boxes of the two Revolute Joint blocks, set the following
actuation and sensing parameters.

Parameter Setting
Actuation > Torque Automatically Computed
Sensing > Actuation Torque Selected

SimMechanics requires the number of joint primitive degrees of freedom
with motion inputs to equal the number with automatically computed joint
actuation forces and torques. If the model does not meet this condition,
simulation fails with an error.

2 Drag these blocks into the model.

Library Block Quantity

Simscape > Utilities | PS-Simulink 2
Converter

Simulink > Sinks To Workspace 2

The PS-Simulink Converter blocks convert the physical signal outputs into
Simulink signals compatible with other Simulink blocks.
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3 In the two To Workspace block dialog boxes, enter the variable names t1
and t2.

4 Connect the blocks as shown in the figure.
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Converter

Simulate Model

Attempt to run the simulation. You can do this in the Simulink Editor
menu bar, by selecting Simulation > Run. Simulation fails with an error
arising from the closed kinematic loop present in the model. SimMechanics
requires this loop to contain at least one joint block without motion inputs or
automatically computed actuation forces or torques.

1 From the SimMechanics > Second Generation > Joints library, drag a
Weld Joint block and connect it inside one of the Binary Link A subsystems.
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Adding the Weld Joint block ensures that the now-closed-loop system

contains at least one joint block without motion inputs or computed
actuation torques.

‘Weld Joint

Run the simulation once again. Mechanics Explorer opens with a dynamic
3-D display of the two-bar linkage.

=
k.
M

Plot the computed actuation torques acting at the two revolute joints in the
linkage. At the MATLAB command line, enter this code:

figure; hold on;

plot(t1.time, t1.data, 'color', [60 100 175]/255);
plot(t2.time, t2.data, 'color', [210 120 0]/255);
xlabel('Time');

ylabel('Torque (N*m)');

grid on;
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The plot shows the time-varying actuation torques acting at the two revolute

joints. These torques enable the manipulator end frame to trace the

prescribed square trajectory.
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® “Sense Motion in Double-Pendulum Model” on page 4-50
® “Prescribe Joint Motion in Four-Bar Model” on page 4-96

e “Specify Motion Input Derivatives” on page 4-10

Related

Examples

e “Joint Actuation” on page 4-2

Concepts

”»

e “Actuating and Sensing Using Physical Signals” on page 4-13
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Simulation

¢ “Configure Model for Simulation” on page 5-2

¢ “Find and Fix Simulation Issues” on page 5-4



5 Simulation

Configure Model for Simulation

5-2

During simulation, SimMechanics employs a Simulink global solver to
determine the configuration of a model as a function of time. You can select
the best solver for your application from a list of solvers that Simulink
provides. Simulation parameters include the numerical step used to
progress through the simulation and the solver tolerance values. Adjust the
parameters to optimize speed and accuracy of the simulation.

For solver selection and parameter specification, see:

e “Choose a Solver” in the Simulink documentation.

e “Setting Up Solvers for Physical Models” in the Simscape documentation.

Specify Solver Settings

To select a global solver for your model:

1 On the Simulink menu bar, click Simulation > Model Configuration
Parameters.

2 On the Tree View pane, select Solver.

3 In Solver Options, click Type and select Variable-step or Fixed-step.

Note For best performance, select Variable-step. For model deployment,
select Fixed-step.

4 Click Solver and select the appropriate solver for your application. The
default solver is ODE45 (Dormand-Prince).

To modify the global solver parameters for your model:

1 In the Solver options pane of the Model Configuration Parameters
window, enter the desired values for step size and tolerance parameters.
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Related
Examples

Reducing the values of the step size and tolerance parameters enhances
simulation accuracy, but decreases simulation speed. Adjust the parameters
to obtain an optimal trade-off between simulation speed and accuracy.

® “Configure Model for Simulation” on page 5-2

® “Configure Model for Rapid Accelerator Mode” on page 8-8
¢ “Find and Fix Simulation Issues” on page 5-4
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Find and Fix Simulation Issues

5-4

In this section...

“Models with For Each Subsystem blocks have limited visualization” on
page 5-4

“Models with Model blocks have no visualization” on page 5-4

“Simscape local solvers do not work with SimMechanics” on page 5-4

Under certain conditions, a model that you simulate can behave in unexpected
ways. Some issues that you can encounter while simulating a SimMechanics
model include:

e Models with For Each Subsystem blocks have limited visualization
e Models with Model blocks have no visualization

® Simscape local solvers do not work for SimMechanics

Models with For Each Subsystem blocks have limited
visualization

Models with one or more For Each Subsystem blocks simulate with limited
visualization. The Mechanics Explorer visualization utility displays the model
in only one of the instances which the For Each Subsystem block provides.

The visualization limitation does not affect model simulation—SimMechanics
simulates the model for all instances of the block.

Models with Model blocks have no visualization

Models with Model blocks (known as referenced models) simulate with no
visualization. During model simulation, SimMechanics issues a warning at
the MATLAB command line. The Mechanics Explorer visualization utility
does not open.

Simscape local solvers do not work with
SimMechanics

SimMechanics software does not support Simscape local solvers. If you select
a local solver in the Simscape Solver Configuration block, the solver does not
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Related
Examples

apply to the SimMechanics portion of a model. SimMechanics blocks continue
to use the Simulink global solver that you select in Model Configuration
Parameters for your model.

Note SimMechanics requires the Simulink global solver to be continuous.
If the global solver is discrete, SimMechanics issues an error and the model
does not simulate. This requirement applies to both fixed- and variable-step
solvers.

¢ “Configure Model for Simulation” on page 5-2
¢ “Configure Model for Rapid Accelerator Mode” on page 8-8
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Visualization and
Animation

® “Visualization and Analysis in Mechanics Explorer” on page 6-2
® “Open Mechanics Explorer” on page 6-6

® “Suppress Visualization During Simulation” on page 6-7

® “Configure Mechanics Explorer” on page 6-8

® “Rotate, Pan, and Zoom View” on page 6-20

® “Record Animation Video” on page 6-24

® “Adjust Video Playback Speed” on page 6-27

¢ “Find and Fix Visualization Issues” on page 6-31
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Visualization and Analysis in Mechanics Explorer

In this section...

“Mechanics Explorer Overview” on page 6-2
“Graphical User Interface” on page 6-2

“Animation Control Panel” on page 6-3

Mechanics Explorer Overview

Mechanics Explorer is a SimMechanics utility that enables you to view and
analyze a 3-D multibody model. With it, you can check model characteristics
such as rigid body geometry and dimensions, frame position and orientation,
and hierarchical component relationships. In this capacity, Mechanics
Explorer acts as a diagnostic tool, helping you to troubleshoot problems
ranging from geometry specification issues to model assembly failures.
During simulation, Mechanics Explorer plays a physics-based animation of
your model, providing qualitative insight about its dynamic behavior.

Graphical User Interface

Mechanics Explorer contains three panes, each with a dedicated function:

® Tree pane — View the hierarchical tree graph of a multibody model. The
tree graph shows the parent—children relationships that exist between
different model components. For example, a graph might show that the
model contains multiple rigid body subsystems, each in turn containing
multiple Solid and Rigid Transform blocks.

® Property pane — View property data pertaining to a subsystem, block,
or frame within a model. The property data displayed depends on the
component selected, ranging from a short subsystem description, to solid
and transform data, to the frames that a given port frame connects to. Use
the tree pane to select the component for which to display the property data.

e Visualization pane — View a 3-D visual representation of a multibody
model. The visual representation is static when you update the model
and dynamic when you simulate the model. A View menu enables you
to select a standard view point (e.g., isometric view) or rotate, pan, and
zoom the model.



Visualization and Analysis in Mechanics Explorer
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Animation Control Panel
Animation Control Panel

Mechanics Explorer enables you to play back a model animation without
rerunning the simulation. To support this task, Mechanics Explorer provides
a multifunction animation tool bar. From left to right, the tool bar includes

the following

buttons and features, most of which should be familiar from a

typical playback device.

Wisualization Pane

Wsualization Tile
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Button or Feature

Rewind to Start

Step Back

Play/Pause

Step Forward

Simulation Progress Bar

Animation Slider

Toggle Loop

Playback Speed Slider

Current Animation Time

Use To:

Restart the animation from the first
frame.

Pause the animation and return to
the preceding animation frame.

Start animation playback or resume
from the current frame. Click again
to halt the animation at the current
animation frame.

Pause the animation and proceed to
the subsequent animation frame.

View the status of the model
simulation. The progress bar
turns blue from left to right as the
simulation nears completion.

Scroll to any frame within the
animation time span. Click the
slider and use the keyboard arrow
buttons to make fine adjustments to
the slider position.

Automatically restart playback from
the first frame once the animation
reaches the end. Click again to stop
the animation playback after the
current run.

Make small to moderate adjustments
to the animation base playback
speed. The slider enables you to
speed up or slow down the animation
in power-of-two increments by up to
a factor of 256.

View or enter the current animation
time. Use this feature to see the
model configuration at a time of
interest, e.g., corresponding to an
extremum in a constraint force plot.
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The figure shows the animation tool bar buttons.

Rewind Playy Simulation Toggle Current
o Start Pause Progress Bar Loop Animation Time
() () ()| | ) 1 — — | Time 605
Step Step Animation Playback
ack Farward Slicter Speead Slider

You can record a Mechanics Explorer animation, e.g., for sharing or for
analysis purposes outside of SimMechanics. To support this task, the
Mechanics Explorer menu bar provides a Create Video option, which you
can find in the Tools menu. Selecting this option causes Mechanics Explorer
to record the current animation in AVI format at a rate of 30 frames per
second. For more information, see “Record Animation Video” on page 6-24.

Related ® “Open Mechanics Explorer” on page 6-6
Examples ¢ “Configure Mechanics Explorer” on page 6-8
e “Rotate, Pan, and Zoom View” on page 6-20
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Open Mechanics Explorer

Related
Examples

Concepts

By default, Mechanics Explorer opens automatically when you update a block
diagram or run a simulation. You can do this from the Simulink Editor menu
bar, by selecting Simulation > Update Diagram, for model update, or
Simulation > Run, for model simulation.

For Mechanics Explorer to open, the model must contain at least one
SimMechanics component. If you update or simulate several SimMechanics
models, Mechanics Explorer shows each on a different tab.

For examples showing how to visualize a multibody model, see the following
tutorials:

e “Model Double Pendulum” on page 3-26
e “Model Four Bar” on page 3-31

“Suppress Visualization During Simulation” on page 6-7
¢ “Configure Mechanics Explorer” on page 6-8
e “Rotate, Pan, and Zoom View” on page 6-20

® “Visualization and Analysis in Mechanics Explorer” on page 6-2
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Suppress Visualization During Simulation

Related
Examples

Concepts

SimMechanics enables you to suppress visualization upon model update or
simulation. You might choose to suppress visualization if the modeling intent
is strictly to analyze quantitative data from model sensors. To suppress
visualization:

1 In the Simulink Editor menu bar, select Simulation > Model
Configuration Parameters.

2 In the tree pane of the Configuration Parameters window, select
SimMechanics 2G > Explorer.

Note The SimMechanics nodes appear in the Configuration Parameters
window only if the model contains SimMechanics blocks.

3 Clear the Open Mechanics Explorer on model update or simulation
check box.

To reset visualization in SimMechanics, check the Open Mechanics
Explorer on model update or simulation check box before updating or
simulating a model.

® “Open Mechanics Explorer” on page 6-6
e “Configure Mechanics Explorer” on page 6-8

e “Rotate, Pan, and Zoom View” on page 6-20

® “Visualization and Analysis in Mechanics Explorer” on page 6-2
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Configure Mechanics Explorer

In this section...

“Change Background Color” on page 6-8
“Change View Point” on page 6-11
“Change View Convention” on page 6-13

“Display Multiple Screens” on page 6-14

“Toggle Visibility of Frames and Mass Centers” on page 6-17

You can customize the display of Mechanics Explorer. Settings you can
change include:

® Background color

® View point

e View convention

Number of display windows for a model

¢ Vigibility of frames and centers of mass

Change Background Color

To change the background color, use the following procedure. The procedure
uses the sm_four_bar as an example.

1 At the MATLAB command line, enter sm_four_bar.

Note Alternatively, open a SimMechanics model of your choice.

2 In the Simulink Editor window for the model, select Simulation > Update
Diagram.
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Note Mechanics Explorer opens with a display of your model against the
default grey background.
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3 In the Mechanics Explorer toolbar, click the 'a icon.
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4 In the Select a Color dialog box, select a color. Click HSV, HSL, RGB, or
CMYK tabs to specify a color in these formats.

X5

A\ Select a Color
 Swatches:| Hsv | HsL | RB | cmvi

Recent:

[240, 240, 240

Preview
n

D Sample Text Sample Text

[ QK ][ Cancel H Reset ]

5 Click OK.

6 In the Mechanics Explorer toolbar, click the u icon.

Clicking the " icon saves the current Mechanics Explorer configuration to
the SimMechanics model. If you close the Mechanics Explorer window and
update the model, Mechanics Explorer opens with the new configuration.
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Change View Point

Mechanics Explorer provides seven view presets that you can use to change
the perspective of a model. Each preset has an icon in the Mechanics Explorer

toolbarmgm@ﬁlﬁa.

6-11



6 Visualization and Animation

Click an icon to select the corresponding view preset. The following table
describes the seven presets in Mechanics Explorer.

View lcon View Name View Description

= Front view Display model ZX plane
with Y axis pointing
into screen

(i Back view Display model ZX plane
with Y axis pointing out
of screen

T Top view Display model XY plane
with Z axis pointing out
of screen.

g Bottom view Display model XY plane
with Z axis pointing
into screen

5 Left view Display model YZ plane
with X axis pointing
into screen

7 Right view Display model YZ plane
with X axis pointing out
of screen

- Isometric view Display model in 3-D

with axes X, Y, and Z at
120° to each other.

The following figure shows the seven view presets in Mechanics Explorer. The
top row shows the following four presets ordered left to right: front, bottom,
top, bottom. The bottom row shows the following three presets ordered left to
right: left, right, isometric.
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Change View Convention

You can choose from three view conventions:

@‘ i — ‘Time 0

e 7 axis up—displays the model ZX plane in front view
® 7 axis down—displays the model YZ plane in front view

® Y axis up—displays the model XY plane in front view
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To select a view convention, click the View convention drop-down menu,

and select one of the three view conventions. The following figure shows a

four-bar model in front view using the three view conventions. The top row
shows view conventions Z up and Z down ordered left to right. The bottom
row shows view convention Y up.
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Display Multiple Screens

You can divide the Mechanics Explorer screen into multiple screens, each with
an independent view of a model. The Mechanics Explorer toolbar provides
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:

icons to split the active window into two windows vertically

or horizontally.

Each time you split the active window, you generate two smaller windows.
You can split the active window an arbitrary number of times to generate as
many view screens as you need. The following table describes the screen
split icons.

Icon Icon Description

Split the active screen into four
standard views

Display a single screen

5 Split the active screen vertically into
two screens

n Split the active screen horizontally
into two screens

The following image shows Mechanics Explorer with four standard views,
in single screen mode, with two vertically split screens, and with two
horizontally split screens.
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Toggle Visibility of Frames and Mass Centers

The Mechanics Explorer provides icons {L' ":; so that you can display and
hide frames and center-of-mass markers.

To toggle frame visibility, click the - icon.

To toggle the visibility of center-of-mass markers, click the ':;' icon.

The following figure shows a four-bar model that displays frames and
center-of-mass markers.
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Related
Examples

Concepts

“Open Mechanics Explorer” on page 6-6
“Configure Mechanics Explorer” on page 6-8
“Rotate, Pan, and Zoom View” on page 6-20
“Find and Fix Visualization Issues” on page 6-31

® “Visualization and Analysis in Mechanics Explorer” on page 6-2
¢ SimMechanics™ User’s Guide on page 1
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Rotate, Pan, and Zoom View

In this section...

“Rotate, Pan, and Zoom Shortcuts” on page 6-20
“Rotate View” on page 6-20
“Pan View” on page 6-21

“Zoom View” on page 6-22

You can rotate, pan, and zoom your model in Mechanics Explorer. To do this,

Iy ~
you use three buttons in the Mechanics Explorer toolbar: ™+ + "']' Select
the button for the task you want to perform. Then, use the mouse to perform
that task. You can also use mouse shortcuts to rotate, pan, and zoom.

Rotate, Pan, and Zoom Shoritcuts

The following table summarizes the mouse shortcuts that you can use to
rotate, pan, and zoom a model.

Function Mouse Shortcut

Rotate Press Scroll Wheel + Move Mouse

Pan Press Scroll Wheel + Shift + Move
Mouse

Zoom Press Scroll Wheel + Ctrl + Move
Mouse

Rotate View

-,
In the Mechanics Explorer tool bar, click the Rotate view button * . In the
visualization pane, click the mouse to set the rotation pivot point. Then, move
the mouse to rotate about that pivot. A rotation icon denotes the position

of the mouse.




Rotate, Pan, and Zoom View

A

If you use a mouse with a scroll wheel, you can also use a shortcut to rotate
your model. Click and hold the scroll wheel while moving the mouse in the
visualization pane. As you move your mouse, the model rotates.

Click + Hold ~ Move Mouse
' o

Pan View

In the Mechanics Explorer tool bar, click the Pan view button + In the
visualization pane, click and move the mouse to pan the model. A pan icon
denotes the position of the mouse.
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=
L

A

If you use a mouse with a scroll wheel, you can also use a shortcut to pan your
model. In the visualization pane, click and hold the scroll wheel and press
Shift while moving the mouse. As you move the mouse, the model pans.

Click + Hold Press Mowve Mouse
. sl

+ B8+ &

Zoom View

In the Mechanics Explorer tool bar, click the Zoom in/out button *-l In the
visualization pane, click the mouse in the part that you want to zoom. Then,
move the mouse to zoom that part. Move the mouse up to zoom in or down to
zoom out. A zoom icon denotes the position of the mouse.
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Related
Examples

Concepts

=
by

A

If you use a mouse with a scroll wheel, you can also use a shortcut to zoom
your model. In the visualization pane, click and hold the scroll wheel and
press Ctrl while moving the mouse. As you move the mouse, the model zooms.
Move the mouse up to zoom in or down to zoom out.

Click + Hold Press Move Mouse
L ] L ] L ]

“Open Mechanics Explorer” on page 6-6
“Configure Mechanics Explorer” on page 6-8
“Find and Fix Visualization Issues” on page 6-31
“Record Animation Video” on page 6-24

® “Visualization and Analysis in Mechanics Explorer” on page 6-2
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Record Animation Video

With Mechanics Explorer, you can record a 3-D animation of your
SimMechanics simulation. You can then play back the animation video
without running the simulation again—or even opening the original model.

To record an animation, Mechanics Explorer provides a record button, f .
Recorded videos are in AVI format. The video playback speed is 30 frames
per second.

This example shows how you can record a 3-D animation. The model in this
example is sm_four_bar, which accompanies your SimMechanics installation.

1 At the MATLAB command line, enter sm_four_bar.
2 In the Simulink Editor window, select Simulation > Run.

3 In the Mechanics Explorer window, press the Record button.



Record Animation Video
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4 In the Select video file window, specify the name of the file.

5 Press Save.
A new animation window opens when you press Save. The title bar of the

new window provides the recording progress status. When a new window
opens informing you that the recording has finished, click OK
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A\ 105 of 10= captured for sm_four_bar |_|_:|_| = |§§_|
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Related
Examples

“Adjust Video Playback Speed” on page 6-27
“Configure Mechanics Explorer” on page 6-8
“Rotate, Pan, and Zoom View” on page 6-20
“Find and Fix Visualization Issues” on page 6-31
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Adjust Video Playback Speed

In this section...

“Variable-Step Solvers” on page 6-27
“Fixed-Step Solvers” on page 6-29

SimMechanics animation videos play at a fixed speed of 30 frames per second
(fps), with each frame corresponding to a simulation time step. When the
step size differs from the 1/30 second duration of a video frame, the video
speed differs from the simulation speed. To ensure that the two speeds are
equal, you must adjust the configuration parameters for your model. The
exact approach depends on the type of solver that you select: variable-step
or fixed-step.

Variable-Step Solvers

Variable-step solvers are commonly used in SimMechanics simulations. With
a variable-step solver, the step size can vary between minimum and maximum
values that you specify in your model’s Configuration Parameters menu.
Because each video frame corresponds to a simulation step, a variable step
size can introduce time distortion into the video.

For example, when the step size is larger than 1/30 second, it must shrink
to fit the 1/30 second duration of a video frame, causing the video to appear
faster than the simulation. Similarly, when the step size is smaller than
1/30 second, it must expand to fit the 1/30 second duration of a video frame,
causing the video to appear slower than the simulation.

To avoid time distortion in the video, you must sample the simulation at
regularly spaced intervals. By using a 1/30 second sampling time interval,
you can ensure that the resulting video plays at the simulation speed:

1 On the Simulink menu bar, select Simulation > Model Configuration
Parameters.

2 On the Configuration Parameters tree browser, select Data
Import/Export.
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3 In the Output Options drop-down list of the Save options pane, select
Produce specified output only.

4 In Output times, enter (1:N)*dt, replacing N with the number of data
samples, and dt with the sampling time interval in seconds, 1/30. This
array specifies the times at which to record the frames of the video.

In terms of the duration of a simulation 7, the number of samples N equals
T/dt. For example, if the simulation lasts ten seconds (T = 10) and the
sampling time interval is 1/30 second (dt = 1/30), then N = 300. In this case,
the array you enter in Qutput times must be (1:300)*1/30.
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If you change the time interval dt in the array from 1/30, the video playback
speed changes accordingly. Changing df to 1/15 causes the resulting video
to play at twice the simulation speed. Similarly, changing dt to 1/60 second
causes the resulting video to play at half the simulation speed.

Fixed-Step Solvers

Fixed-step solvers are less commonly used in SimMechanics simulations.
With a fixed-step solver, the simulation step size remains constant at a value
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Related
Examples

that you specify in your model’s Configuration Parameters menu. Because
the step size is constant, the resulting video displays no time distortion. It
can, however, play at a different speed than the simulation.

To change the playback speed of the video, you must change the step size of
the simulation. Change the step size to 1/30 second to ensure that the video
plays at the same speed as the simulation:

1 On the Simulink menu bar, select Simulation > Model Configuration
Parameters.

2 On the Solver options pane, check that Type is set to Fixed-step.

3 In Fixed-step size (fundamental sample time), enter 1/30.

Changing the step size from 1/30 causes the animation video to play at a
different speed. The effect of changing the step size is similar to the effect of
changing the sampling time interval for a variable-step solver. Changing the
step size to 2/30 causes the resulting video to play at twice the simulation
speed. Similarly, changing the step size to 1/60 causes the resulting video
to play at half the simulation speed.

Note Model dynamics take precedence over video playback considerations.
Select a solver and step size based on the dynamics of your model. Then, if
possible, adjust the time step to control the video playback speed.

® “Record Animation Video” on page 6-24
¢ “Configure Mechanics Explorer” on page 6-8
¢ “Rotate, Pan, and Zoom View” on page 6-20
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Find and Fix Visualization Issues

In this section...

“Mechanics Explorer Fails to Open” on page 6-31

“Model appears with different orientation in Mechanics Explorer” on page
7-41

“Part appears invisible in Mechanics Explorer” on page 7-43

Under certain conditions, a model that you visualize can behave in unexpected
ways. Some issues that you can encounter while attempting to visualize
a model include:

® Mechanics Explorer fails to open

e Model appears with different orientation in Mechanics Explorer

® Part appears invisible in Mechanics Explorer

Mechanics Explorer Fails to Open

By default, Mechanics Explorer is set to open the first time you update a
model. If a Mechanics Explorer window is already open for your model, the
open window updates the model display. Note, however, that updating a
model does not automatically bring the Mechanics Explorer window to the
front. If the Mechanics Explorer window is hidden during model update, you
must bring that window to the front to see the updated model.

Set Mechanics Explorer to Open on Model Update

If Mechanics Explorer fails to open during model update, check that
Mechanics Explorer is set to open on model update:

1 In the Simulink Editor menu bar, select Simulation > Model
Configuration Parameters.

2 Expand the SimMechanics 2G node.

3 Click Explorer.
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4 Verify that Open Mechanics Explorer on model update or simulation
1s selected.

Model appears with different orientation in
Mechanics Explorer

By default, Mechanics Explorer displays a model with the Z axis of the World
frame pointing up. Using this convention, the default gravity vector [0 O
-9.81] m/s"2 points down, a direction that is practical for most applications.
However, this convention differs from that which CAD platforms commonly
use, Y axis up, causing Mechanics Explorer to display some models sideways.
If this happens, you can manually change the view convention to that used in
the original CAD assembly. The figure shows the default Mechanics Explorer
display of an imported robot arm model.



Find and Fix Visualization Issues

Change View Convention
To change the view convention of a model:

1 In the Mechanics Explorer toolbar, click the View Convention drop-down
menu.

2 Select Y up (ZX Top).
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3 Refresh the Mechanics Explorer display by selecting a view point from the
Mechanics Explorer tool bar.

Mechanics Explorer displays the model using the new view convention.

Part appears invisible in Mechanics Explorer

During CAD import, SimMechanics uses a set of stereolithographic (STL) files
to generate the 3-D surface geometry of each CAD part. If SimMechanics
cannot load the STL file for a part, that part appears invisible in Mechanics
Explorer. This issue does not affect model update or simulation.

The figure shows the Mechanics Explorer display of an imported model
containing an invalid STL file.



Find and Fix Visualization Issues

Correct Visualization Issue

If a part of an imported model appears invisible in Mechanics Explorer:
1 In Mechanics Explorer, identify the name of each invisible part.

2 In the block diagram, open the dialog boxes of the associated Solid blocks.

3 In the Geometry section, check that the name and location of the STL
files are correct.

If either is incorrect, enter the correct information and update the model.

Check that Mechanics Explorer displays the invisible part. If not, check if
the STL files are valid.
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STL File Issues

To visualize a CAD assembly that you import, SimMechanics relies on a set of
STL files that specify the 3-D surface geometry of the CAD parts. Each STL
file specifies the surface geometry of one CAD part as a set of 2-D triangles.
To do this, the STL files contain:

e [X Y Z] coordinates of the triangle vertices

e [XY Z] components of the normal vectors for the triangles.

If an STL file specifies a normal vector with zero length, SimMechanics issues
a warning. The STL file fails to load.

“Open Mechanics Explorer” on page 6-6
¢ “Configure Mechanics Explorer” on page 6-8
¢ “Rotate, Pan, and Zoom View” on page 6-20

e “Visualization and Analysis in Mechanics Explorer” on page 6-2
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¢ “CAD Import” on page 7-5
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¢ “Import Robot Arm Model” on page 7-27

¢ “Import Stewart Platform Model” on page 7-33
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CAD Translation

In this section...

“CAD Translation Steps” on page 7-3

“Software Requirements” on page 7-3

You can translate a CAD assembly into a SimMechanics model for simulation
and analysis. This process is called CAD translation. By translating a CAD
assembly into a SimMechanics model, you leverage the strengths of your CAD
platform with the strengths of SimMechanics software. You can modify any
model that you translate—for example, adding actuators and sensors—to

fit the needs of your application. CAD translation is especially useful for
control system design.

CAD Assembly

SimMechanics Model




CAD Translation

CAD Translation Steps

CAD translation is a two-step process. First, you export a CAD assembly

in XML format. Then, you import the XML file into SimMechanics.
SimMechanics uses the XML file to automatically generate a model that
replicates the original CAD assembly. If the CAD assembly contains only
supported constraints, CAD import requires no additional work on your part.
Once SimMechanics generates your model, you are ready to simulate and
analyze that model. The table summarizes the two CAD translation steps.

Translation Step Description

CAD Export Generate XML import file from CAD
assembly

CAD Import Generate SimMechanics model from
import files

You must export a CAD assembly before you import it into SimMechanics.
The schematic shows the CAD translation step sequence. A CAD assembly
is the starting point of CAD translation. Exporting that assembly in XML

format and importing the resulting XML file into SimMechanics produces

an equivalent SimMechanics model.

CAD Assembly @ 0

Generale Generate

Import File SimMechanics Model

Software Requirements

The table provides the software requirements for CAD translation. The
requirements depend on the CAD translation step—export or import. For
example, a CAD platform is a requirement only for CAD export.
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Software Notes CAD Export CAD Import
CAD Platform v
MATLAB Registration as v v

computing server

required
SimMechanics v
SimMechanics v
Link

The software requirements for CAD translation are optimized for cooperation
between CAD and SimMechanics engineers. A CAD engineer can export

the CAD assembly without an active SimMechanics installation. Likewise,

a SimMechanics engineer can import the CAD assembly without an active
CAD platform installation.

smimport

¢ “CAD Import” on page 7-5

“Install and Register SimMechanics Link Software” on page 7-9
“Import Robot Arm Model” on page 7-27
“Import Stewart Platform Model” on page 7-33
“Find and Fix CAD Import Issues” on page 7-40
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CAD Import

In this section...

“Importing a Model” on page 7-5
“Generating Import Files” on page 7-6

“SimMechanics XML Schema” on page 7-8

CAD Import is the second and final step of CAD translation. During

CAD import, SimMechanics interprets the SimMechanics Import XML file
generated during CAD Export. Then, based on the structure and parameters
that the XML file provides, SimMechanics automatically generates model
that replicates the original CAD assembly.

Importing a Model

CAD Import does not require access to the original CAD assembly or
associated CAD platform. Access to the surface-geometry STL files is not
required for simulation, but it is required for visualization. You can simulate
an imported model that contains no STL files. However, the Mechanics
Explorer visualization utility cannot display a representation of a model

without the STL files.

STL Files

SimMechanics

SimMechanics
Madel

Export
SimMechanics
Import XML

File

In the model, each CAD part maps into a rigid body subsystem. Each
CAD constraint or set of CAD constraints, map into a joint. Block names
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for SimMechanics subsystems are based on the original CAD parts and
subassemblies which the subsystems represent. SimMechanics appends the
suffix RIGID to the stem of a rigid body name. For example, CAD part base
translates into rigid body subsystem base RIGID. The following figure shows
the imported SimMechanics model of a CAD robot assembly.

World
.—._\. [l ]
'Q‘ el ms-’ﬁi[} qrF1 FE i = N = =y LI !
~9 )= ©
Transform base 1_RIGID Spherical upperarm_1_RIGID
=0
L Lok L . L
B efB 5 = e 3 gF Fi[E Els_oF B sl
_atl _atl _atl
Revolute1 forearm_1_RIGID Rewolute wrist_1_RIGID Revolute2 grip_1

Modify SimMechanics model to fit the needs of your application.

Generating Import Files

To import a multibody model into SimMechanics, you must first generate the
SimMechanics Import XML file. You can generate this file automatically,
using the SimMechanics Link utility, or manually, using the XML schema
that MathWorks® provides. The method that you use depends on the type of
model that you want to import. The table summarizes the two methods and
their limitations.



CAD Import

Import File Generation Method

Limitations

SimMechanics Link

Works only for CAD assemblies.
CAD assembly must come from one
of three supported CAD platforms.

XML Schema

Requires knowledge of XML file
generation based on XML schema

Generating

Import
Files

SimMechanics
Link

Generate SimMechanics
ML File for CAD
Assamblies

Generate SimMechanics
Import XML File General
Multibody Models

SimMechanics Link is a free utility that MathWorks provides. Use this utility
to generate the SimMechanics Import XML file that you need to import a CAD
assembly into SimMechanics. For more information about SimMechanics
Link , see “Install and Register SimMechanics Link Software” on page 7-9.
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SimMechanics XML Schema

The XML Schema is a set of files written according to the W3C XML Schema
specification. MathWorks provides these files so that you can generate a
SimMechanics Import XML file manually or using an external application.
Use the XML Schema to generate the SimMechanics Import XML file for a
CAD assembly or other multibody model.

The XSD files describe the elements and attributes that a SimMechanics
Import XML file can contain and the order in which they must appear.
Generating an XML file in accordance with the XML schema ensures that
SimMechanics can successfully import it. Once you have generated the XML
file, validate it against the schema to ensure SimMechanics can import it
without issue.

To access the SimMechanics XML schema, visit the SimMechanics product
website. Follow instructions to download the XSD files.

smimport

“Install and Register SimMechanics Link Software” on page 7-9
“Import Robot Arm Model” on page 7-27

“Import Stewart Platform Model” on page 7-33

“Find and Fix CAD Import Issues” on page 7-40

e “CAD Translation” on page 7-2
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http://www.mathworks.com/products/simmechanics/index.html

Install and Register SimMechanics™ Link Software

Install and Register SimMechanics Link Software

In this section...

“SimMechanics Link Installation Requirements” on page 7-9

“Download SimMechanics Link Software” on page 7-10

“Install SimMechanics Link Software” on page 7-10

“Register SimMechanics Link Utility with CAD Platform” on page 7-11
“Link External Application to SimMechanics Link Software” on page 7-11
“Register MATLAB as Automation Server” on page 7-11

“Unregister SimMechanics Link Software” on page 7-13

SimMechanics Link Installation Requirements

Before installing the SimMechanics Link utility, check that an active
installation of the following software exists on your computer:

e MATLAB

® Supported CAD platform

MATLAB and SimMechanics Link must belong to the same release. For
example, if your MATLAB release is R2012b, then your SimMechanics Link

release must also be R2012b. Combining different release numbers can cause
installation errors.

SimMechanics Link supports three CAD platforms:

e SolidWorks®

¢ Autodesk Inventor®

e PTC® Creo™ (Pro/ENGINEER®

You can use the SimMechanics Link utility to export a CAD assembly from

any of these CAD platforms. Note that MATLAB, SimMechanics Link, and
your CAD platform must share the same architecture (e.g. 64-bit).
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Download SimMechanics Link Software
You can download SimMechanics Link software directly from the MathWorks
website:

1 Visit the SimMechanics Link download website at
http://www.mathworks.com/products/simmechanics/download_smlink.html.

2 Select the software version to install.
3 Click Submit.
4 Save the installation files in a convenient folder.

Do not extract the zip file.

Install SimMechanics Link Software
Install SimMechanics Link software from the MATLAB command line:

1 Start MATLAB.

Note You may need administrator privileges to complete the installation.

2 At the MATLAB command line enter:

path(path, '<installation_file_folder>")

replacing <installation_file_ folder> with the path to the folder with
the installation files.

3 At the MATLAB command line, enter:

install_addon('<zip_file_name>.zip')

replacing <zip_file name> with the name of the zip file that you
downloaded (e.g., smlink.r2012b.win64). The command extracts the zip
archive files to the MATLAB root directory.
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Register SimMechanics Link Utility with CAD Platform

Complete the installation by registering your the SimMechanics Link utility
with your CAD platform. The registration procedure makes SimMechanics
Link available in your CAD platform as an Add-In tool. Once you have
completed the linking procedure, you can use the Add-In tool to export a CAD
assembly directly from your CAD platform.

The registration procedure is different for each supported CAD platform. The
following table provides platform-specific registration information. Click

the link that matches your CAD platform, and complete the registration
procedure.

To register with CAD platform... | ...click here

Autodesk Inventor “Register SimMechanics Link with
Inventor®”

PTC Creo (Pro/ENGINEER) “Register SimMechanics Link with
Creo”

SolidWorks “Register SimMechanics Link with
SolidWorks”

Link External Application to SimMechanics Link
Software

You can link an unsupported CAD platform or other external application
to SimMechanics software. For this task, SimMechanics Link provides an
application programming interface (API) with a set of functions that you
can use to create a C/C++ custom export module. For an overview of custom
export using the API, see “Custom Export with SimMechanics Link APT”.

Register MATLAB as Automation Server

Each time you use the SimMechanics Link utility with a CAD platform or
other external application, the utility attempts to connect to MATLAB.

Registration Requirements
Successful connection requires the following to be true:
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e Matching MATLAB and SimMechanics Link release numbers (e.g. both
release numbers R2012b)

e MATLAB registration as automation server.

Enable Automation Server Mode
You can register MATLAB as an automation server in two ways:

Condition Registration Procedure
MATLAB session open in | At the MATLAB command line, enter
desktop mode regmatlabserver.

The command registers the current MATLAB
session as an automation server.

At the MATLAB command line, enter:

enableservice
('AutomationServer',true)

The command enables the current MATLAB
session as an automation server.

MATLAB session not open | At the operating system command prompt,
enter

matlab -automation -desktop

The prompt starts a new MATLAB session in
automation server mode.

At the operating system command prompt,
enter command matlab -regserver.

The command opens a new MATLAB session

in automation server mode. You can close the
MATLAB session.

A single MATLAB automation server registration can be active at a time. If
multiple MATLAB sessions are open in your system, you must first disable
the active registration and then register the desired MATLAB session as an
automation server using the regmatlabserver command.
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Caution If your system does not have an active MATLAB automation server
registration, SimMechanics Link issues a error when it attempts to connect.
In the event of a connection error, check that a MATLAB automation server
is active in your system. If necessary, register MATLAB as an automation
server.

Connection from External Application to MATLAB Automation
Server

Invoking the SimMechanics Link utility from an external application
produces one of the following results:

Condition Required Action Result

No MATLAB session None e New MATLAB

open session opens in
automation server
mode

e SimMechanics Link

connects to MATLAB
automation server
MATLAB server open None e SimMechanics Link
in automation server connects to MATLAB
mode automation server
MATLAB session open | Register MATLAB ® SimMechanics Link
in desktop mode session as automation connects to MATLAB
server. See “Enable automation server

Automation Server
Mode” on page 7-12.

Unregister SimMechanics Link Software

SimMechanics Link contains no uninstaller. If you no longer wish to use the
SimMechanics Link utility in your CAD platform, you can unregister the
utility. The following table provides information on the unlinking procedure
for each CAD platform. Click the link that matches your CAD platform.
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To link CAD platform... «ooclick here

Autodesk Inventor “Register SimMechanics Link with
Inventor”

PTC Creo (Pro/ENGINEER) “Register SimMechanics Link with
Creo”

SolidWorks “Register SimMechanics Link with
SolidWorks”

To register a different version of SimMechanics Link with your CAD platform,
first unregister any currently registered version you may have. Then, register
the desired version. To register and unregister the utility, follow the links
provided in the previous table.
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SimMechanics Import XML File

In this section...

“Organization of SimMechanics XML Import File” on page 7-15
“Root Assembly” on page 7-16

“Organization of Assemblies” on page 7-21

“Organization of Parts” on page 7-21

The SimMechanics XML import file specifies the hierarchical structure of a
CAD assembly and the physical parameters that describe each CAD part.
SimMechanics imports the file to automatically generate an equivalent
SimMechanics model with little or no additional work on your part.

Each block in a model that you import has a unique name and a complete set
of parameters. The SimMechanics Import XML file provides the name and
parameters of a block based on the original CAD assembly. Once you have
imported a model, you can modify the name and parameters of a block to fit
your needs. You can also add and remove blocks from the model, or replace
one block with another.

Note The following sections describe the structure and parameters of the
SimMechanics Import XML file using a robot arm CAD assembly as an
example. The actual structure and parameters of your SimMechanics Import
XML file can differ from that shown here.

Organization of SimMechanics XML Import File

CAD assemblies are hierarchical systems: a CAD root assembly contains other
CAD subassemblies, each made of CAD parts. The SimMechanics XML import
file mirrors the hierarchical structure of a CAD assembly. The file organizes
CAD assembly information in the order Root Assembly—Assemblies—Parts.

The following figure shows the SimMechanics XML import file for a CAD

assembly with name robot. Content in sections RootAssembly, Assemblies,
and Parts is removed for clarity.
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<SimMechanicsImportXML version="1.0"
<Created by="" on="04/12/12||12:00:36" using="SimMechanics Link Version 4.0" from="SclidWorks 18.0.0"/>
<ModelUnits mass="kilogram" length="centimeter"/>
<Datalnits mass="kilogram" length="metexr"/>

<RootAssenkbly name="rokot" uid="rokot" wversion="29%1">

</Roothssembly>
<hAssembliesr

</hzzemblies>

<Parts>

</Parts»
</5imMechanicsInport¥ML>

Root Assembly

The section RootAssembly of the SimMechanics XML import file organizes
information into two separate subsections:

® InstanceTree

® Constraints

<RootiAzsenbly name="robot™ uid="robot" wversion="291">
<hzsemblyFile name="robot.SLOASH" type="5clidWorks Assembly™/>
<Instancelree>
«/InstanceTree>
<Constraints>
</Constraints>

</HRoothssembly>

InstanceTree

Each part contains one body-fixed reference frame that represents a
unique set of position and orientation coordinates.InstanceTree defines a
reference frame for each assembly found in the root assembly. One frame
provides an ultimate reference frame with origin coordinates (0,0,0). Rigid
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transformations translate and rotate the previous frame in InstanceTree to
obtain the reference frame for another CAD assembly.

Instance sections contain the rigid transformation that defines the reference
frame for a CAD part. The following figure shows an instance section in the
SimMechanics XML import file for a root assembly with name robot.

<Rootissenbly name="robot" uid="rokot" wversion="291">»
<hLssemblyFile name="robot.S5LDASM" type="SolidWorks Assenbly"/>
<Instancelree>
<Instance name="base-1" uid="base-1" grounded="true" entitvyUid="base*:*Default">
<Transform>

<Rotation»l 0 0 0 1 0 0 0 l1</Rotation>
<Translation>0 0 O0</Translation>
</Transform>
</Instance>

The InstanceTree section defines the hierarchical organization of the CAD
assembly. The section organizes CAD assemblies and parts according to
their place in the root assembly hierarchy. The following figure displays a
SimMechanics XML import file for a CAD root assembly with name Robot.
The root assembly contains five assemblies:

® pbase-1

® upperarm-1

e forearm-1

® wrist-1

® grip-1

All assemblies contain a single part, except assembly Grip. The assembly
Grip is a multibody system that connects multiple parts with joints. Grip
contains seven distinct parts:

® metacarples-1

e firstfingerlink-1

e firstfingerlinkL-1

® secondfingerlink-1
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® secondfingerlink-2
e fingertips-1

e fingertips-2

Instance content is removed for clarity.

<RoothAssembly name="robot" uid="rcbot" wversion="291">
<AggsenblyFile name="robot.SLDASM" type="SolidWorks Assemb

g

<InstanceTree>
<Instance name="base-1" uid="base-1" grounded="true" entityUid="base#®:*Default">
</Instance>
<Instance name="upperarm-1" uid="upperarm-1" entityUid="upperarm#:*Defanlt">
</Instance
<Instance name="forearm-1" uid="forearm-1" entityUid="forearm*:*Default">
</Instance>
<Instance name="wrist-1" uid="wrist-1" entityUid="wrist#®:*Defaultc">
</Instance>
<Instance name="grip-1" uid="grip-1" entityUid=" ">
<Instance name="metacarple=s-1" uid="metacarples-1" grounded="true" entityUid="metacarples¥*:*Defaunlt™>
</Instance>

<Instance name="firstfinge 1" entityJid="firstfingerl

</Instance>
<Instance name="firstfingerl

nkL-1" unid="firstfingerlinklL-1" entityUid="firstfinger

</Instance>
<Instance name="secondfingerlink-1" uid="secondfingerlink-1" entityUid="secondfinger]

</Instance>
<Instance name="secondfingerl

entityUid="secondfinge

</Instance
<Instance name="fingertips-1" uid="

gertips-1" entityUid=" wertips*: *Default">

</Instance>
<Instance name="fingertips-2" uwid="fingertips-2" entityUid="fingertips*:*Default">

</Instance>
</Instance>

1kL*:

nk#*:

k*:

k*:*Default">

*Default">

*Defaunlt">

*Default">
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Constraints

CAD constraints define how two CAD parts can move relative to each other.
One CAD constraint connects two CAD parts. Each CAD constraint specifies
the mechanical degrees of freedom present between two CAD parts. Two CAD
parts can translate along, and rotate about, up to three mutually orthogonal
axes.

During CAD import, SimMechanics translates the CAD constraints into
SimMechanics joints. Most CAD constraints have a SimMechanics equivalent,
but the equivalence may not be a one-to-one-correspondence. A single
SimMechanics joint may require a combination of multiple CAD constraints
providing the same degrees of freedom.

Note Not all CAD constraints have a SimMechanics equivalent. CAD gear
constraints are one example. You cannot translate a CAD gear constraint into
SimMechanics Second Generation models.

The Constraints section specifies the position, orientation, and type of joint
that connects each pair of CAD assemblies. Two constraints specify one joint.
The following figure shows the constraints section of the SimMechanics XML
import file for a joint between two CAD parts with names upperarm-1 and
forearm-1. In the figure, two constraints define a revolute joint that connects
the two CAD parts: Concentric and Coincident. Each constraint specifies
the position and orientation of the revolute joint relative to the reference
frame for each CAD part.
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<Constraints>
<Concentric name="Concentric2™>

<ConstraintGeometry geomlype="cylinder">

<InstancePath>
Uidrupperarm—1«/Tid>

</In=ztancePfath>
<Position>0.10033 -0.0449642 0</Position>
<Bxis>0 1 1.6691le-0l6</Axis>

< /ConstraintGeometrys>

<ConstraintGeometry geomlype="cylinder">
<InstancePath>
<Uidsrforearm-1<,/TUid>
</InstancePath>

“<Position>-0.01651 -0.01651 O</Position>
Chwi=z»0 1 O« /Lxi=s>
< /ConstraintGeometry>
< /Concentric>
<Coincident name="Coincident3™»>
<ConstraintGeometry geomlype="plane">
<InstancePath
<UJidrupperarm-1</UJid>
</InstancePath>
<Position>0 -0.001016 O</Position>
<hxis=x0 -1 O</hxis>
< /ConstraintEFeometry>
<ConstraintGeometry geomlype="plane"»
<InstancePath
<Uidxforearm-1<,/Uid>
</InstanceFath>
<Pogition>0 0 0</Position>
thuis>D 1 O</Luxis>
</ConstraintGeometry>
</Coincident>
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Organization of Assemblies

The Assemblies section provides the same information present in
RootAssembly, but with a local non-inertial reference frame acting as the
ultimate reference frame. An InstanceTree section assigns a local reference
frame to each part in an assembly. Each local reference frame appears

in a separate Instance subsection. In the Instance subsection, a rigid
transformation rotates and translates a parent frame to obtain the new local
reference frame.

A Constraints section specifies the kinematic constraints between two parts.
The set of constraints between two parts define the kinematic degrees of
freedom between them, and are equivalent to SimMechanics joints. During
CAD import, SimMechanics interprets each set of CAD constraints, and
replaces them with the appropriate set of joints.

Organization of Parts

Part Names

Each part receives a unique name. By default, part names originate from
the part file names. You can change a part name in SimMechanics, after
CAD import, or in the SimMechanics XML import file, before CAD import.
The following figure displays the part name section of the SimMechanics
XML import file. Colored Boxes highlight part and source file identification
information.
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| <Part name="wrist" uid="wristc*:*Default"” version="323">

<ModelUnits mass="kilogram" ;e:gth=”ce:t;mete:"ﬁﬂ

|<PartFile name="wrizt.SLDPRT" type="5clidWorks Part"/> |

<MassPropertiess>
<Mass>0.151682</Mass>
<Center0OfMass>—0.00457306 3.6667e-009 2.08473e-009</CenterCfMass>
<Inertia»2.71068e-005 4.63034e-005 3.87938e-005 1.54966e-011 -5.65388e-012 -4.38201e-012</Inercia>

</MassProperties>

<GeometryFile name="wrist Default sldprt.S5TL" type="S5TIL"/>

<VisunalProperties>
<Ambient r="1" g="0.T788235" b="0.576471" a="1"/>
<Diffuse r="1" g="0. 35" ph="0.576471" a="1"/>
<Specular r="1" g="0.788235" b="0.5T7&471" a="1"/>
<Emisszive r="0" g="0" h="0" a="iv/s

<Shininess»0.3125</8hininess>
</VisualProperties>
</Part>

Note SimMechanics represents a CAD part as a single rigid body subsystem.
A rigid body subsystem inherits its name from the corresponding CAD part.

Physical Units

The SimMechanics XML input file defines the physical units used to resolve
the values of inertial parameters. Units originate from the exported CAD
assembly file. You can update the physical units in SimMechanics, after
CAD import, or in the SimMechanics XML import file, before CAD import.
The following figure highlights the physical units used to resolve the inertial
properties of CAD part with name Wrist.
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<Part name="wrist" uid="wristc*:*Default"” version="323">

<ModelUnits mass="kilogram" ;e:gth=”ce:t;mete:"ﬁﬂ
<PartFile name="wris=st.SLDPRT" type="S5clidWorks Part"/>

<MassPropertiess>
<Mass>0.151682</Mass>
<Center0OfMass>—0.00457306 3.6667e-009 2.08473e-009</CenterCfMass>
<Inertia»2.71068e-005 4.63034e-005 3.87938e-005 1.54966e-011 -5.65388e-012 -4.38201e-012</Inercia>

</MassProperties>

<GeometryFile name="wrist Default sldprt.S5TL" type="S5TIL"/>

<VisunalProperties>
<Bmbient r="1" 235" L="0.5764T1" a="1"/>
<Diffuse r="1" 35" b="0.576471" a="1"/>
<Specular 1™ g="0.788235" b="0.5T76471" a="1"/>

<Emissive r="0" g="Q" b="0" a="1"/>
<Shininess»0.3125</8hininess>
</VisualProperties>
</Part>

Solid Parameters
Solid parameters include inertia and graphic properties. Inertia governs the

dynamic response of the solid to an applied force or torque. The SimMechanics
XML import file specifies the following inertial parameters:

® Mass

¢ Center of mass

¢ Moments and products of inertia

The following figure displays the solid parameters section of the SimMechanics

XML import file for a CAD part with name Wrist. A box encloses the inertial
properties of the CAD part.
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<Part name="wrist" uid="wristc*:*Default"” version="323">
<ModelUnits mass="kilogram" ;e:gth=”ce:t;mete:"ﬁﬂ

<PartFile name="wris=st.SLDPRT" type="S5clidWorks Part"/>

<MassPropertiess>
<Mass>0.151682</Mass>
<Center0OfMass>—0.00457306 3.6667e-009 2.08473e-009</CenterCfMass>
<Inertia»2.71062e-005 4.63034e-005 3.87938e-005 1.54966e-011 -5.65388e-012 -4.38201e-012</Inercial
</MassProperties>
<GeometryFile name="wrist Default sldprt.S5TL" type="S5TIL"/>
<VisunalProperties>

<Ambient r="1" g="0.788235" b="0.576471" a="1"/>
<Diffuse r="1" g="0 235" .5T764T71" a="1"/>
<Specular r="1" g="0.788235" b="0.576471" a="1"/>
<Emissive r="0" g="0" b="0" a="1n/>

<Shininess»0.3125</8hininess>
</VisualProperties>
</Part>

Graphic properties govern the visual representation of the solid in Mechanics
Explorer. Properties include color and shininess. The following table describes
the graphic properties present in the SimMechanics XML import file.

Graphic Property Type Description

Ambient Color RGBA vector Color of light that hits
the solid surface

Diffuse Color RGBA vector Color of the solid
surface in pure white
light

Specular Color RGBA vector Color of specular

reflection from the
solid surface

Emissive Color RGBA vector Color of solid
self-illumination

Shininess Scalar Intensity of specular
highlights from the
solid surface

The following figure highlights the graphic properties section of the
SimMechanics XML import file.
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<Part name="wrist" uid="wristc*:*Default"” version="323">
<ModelUnits mass="kilogram" ;e:gth=”ce:t;mete:"ﬁﬂ
<PartFile name="wris=st.SLDPRT" type="S5clidWorks Part"/>
<MassPropertiess>
<Mass>0.151682</Mass>
<CenterCfMass>»>—0.00457306 3.6667e-009 2.08473e-009</CenterCfMass>
<Inertia»2.71068e-005 4.63034e-005 3.87938e-005 1.54966e-011 -5.65388e-012 -4.38201e-012</Inercia>
</MassProperties>
<GeometryFile name="wrist Default sldprt.S5TL" type="S5TIL"/>

<VisunalProperties>

<Ambient r="1" g="0.T788235" b="0.576471" a="1"/>
35" b="0.576471" a="1"/>
788235" b="0.576471" a="1"/>
<Emissive r="0" g="Q" b="0" a="iv/>

<Diffuse r="1" g="

<Specular r="1" g="0.

<Shininess»0.3125</8hininess>

</VisualProperties>
</Part>

Geometry File References

A set of STL files specifies the 3-D geometry of the solid surface for each CAD
part. STL files specify only geometry, without reference to other graphic
properties, like color. The SimMechanics XML import file specifies a single
STL geometry file for each part in the CAD assembly. The following figure
highlights the geometry file reference in the SimMechanics XML input file
for a part with name Wrist.

<Part name="wrist" uid="wristc*:*Default"” version="323">
<ModelUnits mass="kilogram" ;e:gth=”ce:t;mete:"ﬁﬂ
<PartFile name="wris=st.SLDPRT" type="S5clidWorks Part"/>
<MassPropertiess>
<Mass>0.151682</Mass>
<CenterCfMass>»>—0.00457306 3.6667e-009 2.08473e-009</CenterCfMass>
<Inertia»2.71068e-005 4.63034e-005 3.87938e-005 1.54966e-011 -5.65388e-012 -4.38201e-012</Inercia>
</MassProperties>

<GeometryFile name="wrist Default sldprt.S5TL" cype="STL" />

<VisunalProperties>
<Ambient r="1" g="0.T788235" b="0.576471" a="1"/>
<Diffuse r="1" g="0 35" ph="0.576471" a="1"/>
235" pB="0.5TE471" a="in/>
<Emissive r="0" g="Q" b="0" a="iv/>

<Specular r="1" g="0.
<Shininess»0.3125</8hininess>

</VisualProperties>
</Part>

See Also smimport
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Related
Examples

Concepts

“Install and Register SimMechanics Link Software” on page 7-9
“Import Robot Arm Model” on page 7-27

“Import Stewart Platform Model” on page 7-33

“Find and Fix CAD Import Issues” on page 7-40

“CAD Translation” on page 7-2

¢ “CAD Import” on page 7-5



Import Robot Arm Model

Import Robot Arm Model

In this section...

“Check Import Files” on page 7-28
“Import Robot Assembly” on page 7-29

“Visualize and Simulate Robot Assembly” on page 7-30

In this example, you import a CAD assembly with name robot into
SimMechanics. SimMechanics provides the smimport command so that you
can import a CAD assembly. The command is the only SimMechanics tool you
need to import a CAD assembly. The CAD import procedure is the same

for all CAD platforms.

Note This example uses an XML file and a set of STL files that are present
in your SimMechanics installation. You can export the XML and STL files
directly from a supported CAD platform, but the names of the files may differ
from the example.

The following figure shows the original CAD assembly inside the SolidWorks
CAD platform.
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Check Import Files

Before you import the sm_robot CAD assembly, check that the import files
exist. The import files include one SimMechanics Import XML file and a set of
STL files that specify the geometry of all CAD parts.
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1 At the MATLAB command line, enter the following command to change
the current working directory to the subdirectory that contains the robot
example files:

cd(fullfile(matlabroot, 'toolbox', 'physmod', 'sm', ‘smdemos’,
"import', 'robot'))

2 At the MATLAB command line, enter 1s or dir to list all files in the
\robot directory.

3 Check that the directory contains XML file sm_robot.xml and a set of STL

files.

Import Robot Assembly
Once you have verified that all required files exist, proceed to import the
assembly.

1 At the MATLAB command line, enter smimport('sm_robot.xml').

2 Confirm that SimMechanics opens a new model with name sm_robot.
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sm_robot
® |[%a|sm_robot » -
@
E
=
=]
’JF FL‘ '_JE '::L' '_IF' FL‘ '_]E }"L' ’JF' FL‘ '_JE }r:l“ '_IF F'L‘ "]E }L' F
gy & i & -
base 1_RIGID Spherical upperam_1_RIGID Revolute! forearm_1_RIGID Revolute wrist_1_RIGID Revolute? grip_1

» |y il
100% oded5

7-29



7 About CAD Import

7-30

Note SimMechanics automatically generates the new model without
extra input on your part. Review the model and check for errors and
inconsistencies in the block diagram.

3 In the Simulink Editor window that contains the model, select File > Save

As.

4 In the Save As dialog box, enter the desired file name and select a

convenient directory in which store the model file.

Visualize and Simulate Robot Assembly

In the Simulink Editor window that contains the robot model, select
Simulation > Update Diagram or press Ctrl+D.

Note When you update the diagram, SimMechanics automatically updates
the model display in Mechanics Explorer. SimMechanics relies on the set
of STL files to represent the 3-D geometry of each CAD part. If the files
are not available, SimMechanics still generates the model, but Mechanics
Explorer cannot display the assembly.

In the Mechanics Explorer toolbar, set View Convention to Y up (XY
Front).

Note Most CAD systems use a Y up default view convention. The
convention differs from the Mechanics Explorer default setting, Z up.
Selecting the Y up view convention causes Mechanics Explorer to display
the assembly with the same orientation used in the CAD platforms.

3 In the toolbar, click the icon for the desired viewpoint.



Import Robot Arm Model

Note Selecting the Y up view convention does not affect the Mechanics
Explorer display until you click a view point. You have the choice between
seven standard viewpoints: front, back, top, down, left, right, and isometric.
Once you select a view point, you can rotate, pan, and zoom to adjust the
display of your model. For more information, see:

e “Configure Mechanics Explorer” on page 6-8

e “Rotate, Pan, and Zoom View” on page 6-20

4 Confirm that a Mechanics Explorer window opens with a static display of
the robot assembly.
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- grip 1
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5 In the Simulink Editor window for the model, select Simulation > Run or
press Ctrl+T to simulate the model.

Tip The model lacks actuation inputs. When you simulate the model, the
robot arm moves strictly due to gravity effects. You can change the gravity
specification in the Mechanism Configuration block.

You can add actuation inputs to the model. Add a block from the Forces &
Torques library to actuate a rigid body. Select an actuation mode in the model
joint blocks to actuate a joint.

See Also smimport
Related ¢ “Install and Register SimMechanics Link Software” on page 7-9
Examples e “Import Stewart Platform Model” on page 7-33

¢ “Find and Fix CAD Import Issues” on page 7-40

Concepts e “CAD Translation” on page 7-2
e “CAD Import” on page 7-5

7-32



Import Stewart Platform Model

Import Stewart Platform Model

In this section...

“Check Import Files” on page 7-34
“Import Model” on page 7-35

“Visualize and Simulate Robot Assembly” on page 7-36

You can import a CAD assembly into a SimMechanics model. To do this, you
use the SimMechanics command smimport. In this example, you import the
CAD assembly for a Stewart platform. All required files are provided with
your SimMechanics installation.
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Check Import Files

To import the CAD assembly, you must have access to the SimMechanics
Import XML and STL files for this assembly. Check that you have these
files before proceeding.

1 Navigate to directory
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Import Stewart Platform Model

<matlabroot>/toolbox/physmod/sm/smdemos/...

...import/stewart_platform

2 Check that the following files exist.

File Quantity Description
SimMechanics Import | One Provides model
XML structure and
parameters
STL Multiple Provides part

geometry

Import Model

If you have access to the import files, you can import the model. To do this,
at the MATLAB command line enter smimport('stewart_platform.xml').
SimMechanics automatically generates a Stewart platform model. This model
replicates the original CAD assembly.
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Visualize and Simulate Robot Assembly

You can now simulate the model that you imported. On the Simulink tool bar,
click the Run button. Alternatively, press Ctrl+T. Mechanics Explorer opens
with a dynamic display of your model.



Import Stewart Platform Model

k.

By default, Mechanics Explorer uses a Z axis up view convention. This
convention differs from that which most CAD platforms use—Y axis up. The
different view conventions cause the Stewart platform to appear sideways
in the visualization pane. To fix this issue, change the Mechanics Explorer
view convention to Y axis up:

® On the Mechanics Explorer tool bar, in the View Convention drop-down
list, select Y Up (XY Front).

To refresh the visualization pane using the new view convention, on the
Mechanics Explorer tool bar, click any standard view button, e.g., Isometric
View.
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L3

Tip Actuate the stewart_platform model with blocks from the Forces and
Torques library. Then, simulate the model and analyze its dynamic behavior
in Mechanics Explorer.
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See Also smimport
Related ® “Install and Register SimMechanics Link Software” on page 7-9
Exqmples ¢ “Import Robot Arm Model” on page 7-27

¢ “Find and Fix CAD Import Issues” on page 7-40

Concepts e “CAD Translation” on page 7-2
® “CAD Import” on page 7-5
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Find and Fix CAD Import Issues

7-40

In this section...

“Model replaces certain CAD constraints with rigid connections” on page
7-40

“Model appears with different orientation in Mechanics Explorer” on page
7-41

“Part appears invisible in Mechanics Explorer” on page 7-43

Under certain conditions, a model that you import can behave in unexpected
ways. Some issues that you can encounter while importing a model include:

® Model replaces certain CAD constraints with rigid connections
e Model appears with different orientation in Mechanics Explorer

® Part appears invisible in Mechanics Explorer

In this section, learn what causes these issues and, if possible, what
approaches you can take to correct them.

Model replaces certain CAD constraints with rigid
connections

SimMechanics supports most, but not all, CAD constraints. If you import a
CAD assembly with a CAD constraint that SimMechanics does not support,
SimMechanics issues a warning message and automatically replaces that
constraint with a rigid connection.

The figure shows the imported model of a CAD assembly that contains an
unsupported gear constraint. Because SimMechanics does not support that
particular gear constraint, it replaces it with a frame line. The frame line
represents a rigid connection.




Find and Fix CAD Import Issues
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Identify and Change Automatic Rigid Connections

The warning message 1dentifies the blocks and ports that connect to the
unsupported constraint. Use this information to identify the new rigid
connection in the model. Then, determine if any combination of SimMechanics
joint, gear, or constraint blocks adequately replaces the unsupported
constraint. If so, replace that rigid connection. Run the simulation to check
that the model behaves as you expect.

Model appears with different orientation in
Mechanics Explorer

By default, Mechanics Explorer displays a model with the Z axis of the World
frame pointing up. Using this convention, the default gravity vector [0 O
-9.81] m/s"2 points down, a direction that is practical for most applications.
However, this convention differs from that which CAD platforms commonly
use, Y axis up, causing Mechanics Explorer to display some models sideways.
If this happens, you can manually change the view convention to that used in
the original CAD assembly. The figure shows the default Mechanics Explorer
display of an imported robot arm model.
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Change View Convention
To change the view convention of a model:

1 In the Mechanics Explorer toolbar, click the View Convention drop-down
menu.

2 Select Y up (ZX Top).

7-42



Find and Fix CAD Import Issues

3 Refresh the Mechanics Explorer display by selecting a view point from the
Mechanics Explorer tool bar.

Mechanics Explorer displays the model using the new view convention.

Part appears invisible in Mechanics Explorer

During CAD import, SimMechanics uses a set of stereolithographic (STL) files
to generate the 3-D surface geometry of each CAD part. If SimMechanics
cannot load the STL file for a part, that part appears invisible in Mechanics
Explorer. This issue does not affect model update or simulation.

The figure shows the Mechanics Explorer display of an imported model
containing an invalid STL file.
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Correct Visualization Issue

If a part of an imported model appears invisible in Mechanics Explorer:
1 In Mechanics Explorer, identify the name of each invisible part.

2 In the block diagram, open the dialog boxes of the associated Solid blocks.

3 In the Geometry section, check that the name and location of the STL
files are correct.

If either is incorrect, enter the correct information and update the model.

Check that Mechanics Explorer displays the invisible part. If not, check if
the STL files are valid.
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See Also

Related
Examples

Concepts

STL File Issues

To visualize a CAD assembly that you import, SimMechanics relies on a set of
STL files that specify the 3-D surface geometry of the CAD parts. Each STL
file specifies the surface geometry of one CAD part as a set of 2-D triangles.
To do this, the STL files contain:

e [X Y Z] coordinates of the triangle vertices

e [XY Z] components of the normal vectors for the triangles.

If an STL file specifies a normal vector with zero length, SimMechanics issues
a warning. The STL file fails to load.

smimport

“Install and Register SimMechanics Link Software” on page 7-9
* “Import Robot Arm Model” on page 7-27
e “Import Stewart Platform Model” on page 7-33

e “CAD Translation” on page 7-2
¢ “CAD Import” on page 7-5
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8 Code Generation

About Code Generation

In this section...

“Simulation Accelerator Modes” on page 8-3

“Model Deployment” on page 8-3

SimMechanics supports code generation with Simulink Coder™. You can
generate C/C++ code from a SimMechanics model to accelerate simulation
or to deploy a model.

Generate
Code
Ta..,

Accelerate
Simulation
With.

Rapid Hardware -
Accelerator Accelerator Rapid

Mode Mode Lg:]p Prototyping

Software

In
Loop
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Simulation Accelerator Modes

Simulink can generate C/C++ executable code to shorten simulation time.
Two simulation modes generate code:

e Accelerator

e Rapid Accelerator

SimMechanics supports the two accelerator modes. You can access the
simulation accelerator modes in the Simulink Editor window for your model.
Click Simulation > Mode, and select Accelerator or Rapid Accelerator.
Accelerator modes do not require additional Simulink code generation
products.

Note Simulation accelerator modes do not support model visualization.
When you simulate a SimMechanics model in Accelerator or Rapid
Accelerator modes, Mechanics Explorer does not open with a 3-D display of
your model.

Model Deployment

With Simulink Coder, you can generate standalone C/C++ code for
deployment outside the Simulink environment. The code replicates the source
SimMechanics model. You can use the stand-alone code for applications that
include:

¢ Hardware-In-Loop (HIL) testing

® Software-In-Loop (SIL) testing

¢ Rapid prototyping

Note SimMechanics supports, but does not perform, code generation for
model deployment. Code generation for model deployment requires the
Simulink Coder product.
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Related e “Configure Four-Bar Model for Code Generation” on page 8-5
Examples ® “Configure Model for Rapid Accelerator Mode” on page 8-8
* “Find and Fix Code Generation Issues” on page 8-12



Configure Four-Bar Model for Code Generation

Configure Four-Bar Model for Code Generation

You can generate code from a SimMechanics model for deployment outside
the MATLAB environment. This example shows how to configure a four-bar
model for code generation using a variable-step solver with the objective of
execution efficiency. The example uses the default Simulink solver ode45
(Dormand-Prince).

The four-bar model is present in your SimMechanics installation. To open the

model, at the MATLAB command line type sm_four_bar. A new Simulink
Editor window opens with the block diagram of the four-bar model.
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Configure Model

To configure the model for code generation:

1 In the Simulink Editor window for your model, select Simulation > Model
Configuration Parameters.

2 In the Model Configuration Parameters dialog box, select Code
Generation.



Configure Four-Bar Model for Code Generation

3 In Target Selection, enter rsim.tlc.

Note You must use the rsim.tlc target each time you use a variable-step
solver. You can change the solver type in the Solver section of the Model
Configuration Parameters window.

4 In Code Generation Advisor, select Execution Efficiency.
5 Click Apply.

6 To generate C code for your model, click Build.

Related ® “Configure Model for Rapid Accelerator Mode” on page 8-8
Exqmples * “Find and Fix Code Generation Issues” on page 8-12
Concepts ® “About Code Generation” on page 8-2
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Configure Model for Rapid Accelerator Mode

8-8

In this section...

“Model Overview” on page 8-8

“Configure Model” on page 8-9

Model Overview

You can run a SimMechanics model in Accelerator and Rapid Accelerator
modes. When you select an accelerator mode, SimMechanics generates
executable code that accelerates the model simulation. This example shows
how to configure a four-bar model for Rapid Accelerator simulation mode. The
simulation uses the default Simulink solver ode45 (Dormand-Prince).

The four-bar model is present in your SimMechanics installation. To open the
model, at the MATLAB command line type sm_four_bar. A new Simulink
Editor window opens with the block diagram of the four-bar model.
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Configure Model

To configure the model for Rapid Acceleration simulation mode, follow these

steps:

1 In the Simulink Editor window for your model, select Simulation.

2 In the drop-down menu, select Mode > Rapid Accelerator.
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3 Select Simulation > Model Configuration Parameters.

4 In Code Generation, under System target file, enter rsim.tlc.

Note You must use the rsim.tlc target each time you generate code
with a variable-step solver. Both Accelerator and Rapid Accelerator modes
generate executable code that requires the rsim.tlc target to be used
with variable-step solvers.

5 Expand the SimMechanics 2G node.
6 Select Explorer.

7 Clear the Open Mechanics Explorer on model update or simulation
check box.

Note Clearing the Open Mechanics Explorer on model update or
simulation check box disables visualization with Mechanics Explorer.
Disabling visualization prevents SimMechanics from issuing a warning
message when you simulate a model in Accelerator or Rapid Accelerator
mode.

8 Press Ctrl+T to simulate the model.

Note The Rapid Accelerator mode incurs an initial time cost to generate
the executable code. Once the code is generated, the simulation proceeds
more rapidly. Rapid Accelerator mode is suggested for large or complex
SimMechanics models with long simulation times.

The Rapid Accelerator mode does not support visualization. Mechanics
Explorer does not open, and you can not view a dynamic simulation of the
model. All other simulation capabilities remain functional, including graphics
and scopes.



Configure Model for Rapid Accelerator Mode

Related e “Configure Four-Bar Model for Code Generation” on page 8-5
Exqmples ¢ “Find and Fix Code Generation Issues” on page 8-12
Concepts ® “About Code Generation” on page 8-2
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Find and Fix Code Generation Issues

In this section...

“Variable step Simulink solver requires rsim.tlc target” on page 8-12
“Simulink solver must be continuous” on page 8-13

“SimMechanics does not support visualization in accelerator mode” on page
8-13

“SimMechanics Does Not Support Run-Time Parameters” on page 8-14

SimMechanics supports code generation using Simulink Coder. However,
certain guidelines and limitations apply. These include:

® Variable step Simulink solver requires rsim.tlc target.

¢ Simulink solver must be continuous.

¢ SimMechanics does not support visualization in accelerator mode.

¢ SimMechanics does not support run-time parameters.

Note To generate code for a SimMechanics model, you must have an active
Simulink Coder installation.

Variable step Simulink solver requires rsim.tlc
target

Code generation is compatible with fixed- and variable-step solvers. If you
select a variable-step solver, you must specify system target file rsim.tlc. To
specify the rsim.tlc system target file, follow these steps:

1 In the Simulink Editor window for your model, select Simulation > Model
Configuration Parameters.

2 In the left pane of the Model Configuration Parameters dialog box,
select Code Generation.

3 In System target file, enter rsim.tlc.
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4 Click Apply.

5 Click Build to generate code for the active model.

Simulink solver must be continuous

Both fixed- and variable-step solvers can be continuous or discrete.
Generating code from a SimMechanics model requires a continuous solver.
SimMechanics blocks use continuous time samples, and are incompatible
with discrete solvers. If you attempt to generate code with a discrete solver,
Simulink Coder issues an error.

If you receive an error stating that SimMechanics does not support a discrete
solver, select a continuous Simulink solver. To change the Simulink solver,
follow these steps:

1 In the Simulink Editor window for your model, select Simulation > Model
Configuration Parameters.

2 In Solver, under Solver options, click Solver.

3 In the drop-down menu, select any solver with the exception of discrete
(no continuous states).

SimMechanics does not support visualization in
accelerator mode

SimMechanics supports Accelerator and Rapid Accelerator simulation modes.
Selecting an accelerator mode generates executable code that shortens the
time required to run a simulation. However, the simulation produces no
visualization output. Mechanics Explorer does not open, and you cannot
visualize the model simulation. To restore visualization, select the Normal
simulation mode.

If you simulate a model in Accelerator or Rapid Accelerator mode,
SimMechanics issues a warning indicating that accelerator modes do not
support visualization. To remove the warning, disable visualization with
Mechanics Explorer:

1 In the Simulink Editor window for your model, select Simulation > Model
Configuration Parameters.
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2 In the Model Configuration Parameters window, expand the
SimMechanics 2G node.

3 Select Explorer.

4 Clear the Open Mechanics Explorer on model update or simulation
check box.

Note Clearing the Open Mechanics Explorer on model update or
simulation check box disables Mechanics Explorer. When you return
to Normal simulation mode, check the box to restore visualization with

Mechanics Explorer.

SimMechanics Does Not Support Run-Time

Parameters

Model parameters are fixed during code generation. To change model
parameters, edit the parameters in SimMechanics and regenerate code for the
model. You can only change model parameters in SimMechanics itself.

Related ¢ “Configure Four-Bar Model for Code Generation” on page 8-5
Exqmples e “Configure Model for Rapid Accelerator Mode” on page 8-8
Concepts e “About Code Generation” on page 8-2
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